]> git.pld-linux.org Git - packages/cppunit.git/blob - cppunit.spec
- second part of small fixes inspired by kloczek (this time better checked,
[packages/cppunit.git] / cppunit.spec
1 Summary:        The C++ Unit Test Library
2 Summary(pl):    Biblioteka testowa do C++
3 Name:           cppunit
4 Version:        1.8.0
5 Release:        1
6 License:        LGPL
7 Group:          Libraries
8 Source0:        http://dl.sourceforge.net/cppunit/%{name}-%{version}.tar.gz
9 # Source0-md5:  9f18d97ca99b4f095f5ff18139df59c3
10 URL:            http://cppunit.sourceforge.net/
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  doxygen
14 BuildRequires:  libstdc++-devel
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 CppUnit is the C++ port of the famous JUnit framework for unit
19 testing.
20
21 %description -l pl
22 CppUnit jest portem C++ s³ynnego ¶rodowiska testowego JUnit.
23
24 %package devel
25 Summary:        cppunit header files
26 Summary(pl):    Pliki nag³ówkowe cppunit
27 Group:          Development/Libraries
28 Requires:       %{name} = %{version}
29
30 %description devel
31 cppunit header files.
32
33 %description devel -l pl
34 Pliki nag³ówkowe cppunit.
35
36 %package static
37 Summary:        cppunit static library
38 Summary(pl):    Statyczna biblioteka cppunit
39 Group:          Development/Libraries
40 Requires:       %{name}-devel = %{version}
41
42 %description static
43 cppunit static library.
44
45 %description static -l pl
46 Statyczna biblioteka cppunit.
47
48 %prep
49 %setup -q
50
51 echo 'libcppunit_la_LIBADD = -lstdc++ -lpthread' >> src/cppunit/Makefile.am
52
53 %build
54 rm -f missing
55 %{__aclocal} -I config
56 %{__autoconf}
57 %{__automake}
58 %configure
59 %{__make}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %{__make} install \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 rm -rf $RPM_BUILD_ROOT%{_includedir}/cppunit/{ui/mfc,ui/qt,config-[bm]*}
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post   -p /sbin/ldconfig
73 %postun -p /sbin/ldconfig
74
75 %files
76 %defattr(644,root,root,755)
77 %doc AUTHORS BUGS NEWS README THANKS TODO
78 %attr(755,root,root) %{_libdir}/lib*.so.*.*
79
80 %files devel
81 %defattr(644,root,root,755)
82 %doc doc/FAQ doc/html
83 %attr(755,root,root) %{_bindir}/cppunit-config
84 %{_libdir}/lib*.la
85 %attr(755,root,root) %{_libdir}/lib*.so
86 %{_includedir}/cppunit
87 %{_aclocaldir}/cppunit.m4
88 %{_mandir}/man1/cppunit-config.1*
89
90 %files static
91 %defattr(644,root,root,755)
92 %{_libdir}/lib*.a
This page took 0.059972 seconds and 4 git commands to generate.