]> git.pld-linux.org Git - packages/cppunit.git/blob - cppunit.spec
- R: libstdc++-devel in -devel, rel 3, STBR
[packages/cppunit.git] / cppunit.spec
1 Summary:        The C++ Unit Test Library
2 Summary(pl):    Biblioteka testowa do C++
3 Name:           cppunit
4 Version:        1.10.2
5 Release:        3
6 License:        LGPL
7 Group:          Libraries
8 Source0:        http://dl.sourceforge.net/cppunit/%{name}-%{version}.tar.gz
9 # Source0-md5:  0bc06cd219410f7d4f6bbfc9bdd7c824
10 Patch0:         %{name}-am18.patch
11 URL:            http://cppunit.sourceforge.net/
12 BuildRequires:  autoconf >= 2.50
13 BuildRequires:  automake >= 1.4
14 BuildRequires:  doxygen
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  libtool >= 2:1.4d
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 CppUnit is the C++ port of the famous JUnit framework for unit
21 testing.
22
23 %description -l pl
24 CppUnit jest portem C++ s³ynnego ¶rodowiska testowego JUnit.
25
26 %package devel
27 Summary:        cppunit header files
28 Summary(pl):    Pliki nag³ówkowe cppunit
29 Group:          Development/Libraries
30 Requires:       %{name} = %{version}-%{release}
31 Requires:       libstdc++-devel
32
33 %description devel
34 cppunit header files.
35
36 %description devel -l pl
37 Pliki nag³ówkowe cppunit.
38
39 %package static
40 Summary:        cppunit static library
41 Summary(pl):    Statyczna biblioteka cppunit
42 Group:          Development/Libraries
43 Requires:       %{name}-devel = %{version}-%{release}
44
45 %description static
46 cppunit static library.
47
48 %description static -l pl
49 Statyczna biblioteka cppunit.
50
51 %prep
52 %setup -q
53 %patch0 -p1
54
55 echo 'libcppunit_la_LIBADD = -ldl' >> src/cppunit/Makefile.am
56
57 %build
58 %{__libtoolize}
59 %{__aclocal} -I config
60 %{__autoconf}
61 %{__autoheader}
62 %{__automake}
63 %configure
64 %{__make}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__make} install \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 rm -rf $RPM_BUILD_ROOT%{_includedir}/cppunit/{ui/mfc,ui/qt,config/config-[bm]*}
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post   -p /sbin/ldconfig
78 %postun -p /sbin/ldconfig
79
80 %files
81 %defattr(644,root,root,755)
82 %doc AUTHORS BUGS NEWS README THANKS TODO
83 %attr(755,root,root) %{_libdir}/lib*.so.*.*
84
85 %files devel
86 %defattr(644,root,root,755)
87 %doc doc/FAQ doc/html
88 %attr(755,root,root) %{_bindir}/cppunit-config
89 %attr(755,root,root) %{_libdir}/lib*.so
90 %{_libdir}/lib*.la
91 %{_includedir}/cppunit
92 %{_aclocaldir}/cppunit.m4
93 %{_mandir}/man1/cppunit-config.1*
94
95 %files static
96 %defattr(644,root,root,755)
97 %{_libdir}/lib*.a
This page took 0.053864 seconds and 4 git commands to generate.