]> git.pld-linux.org Git - packages/cppunit.git/blob - cppunit.spec
- new
[packages/cppunit.git] / cppunit.spec
1 Summary:        The C++ Unit Test Library
2 Summary(pl):    Biblioteka testowa do C++
3 Name:           cppunit
4 Version:        1.8.0
5 Release:        1
6 License:        LGPL
7 Group:          Libraries
8 Source0:        ftp://ftp.sourceforge.net/pub/sourceforge/cppunit/%{name}-%{version}.tar.gz
9 URL:            http://cppunit.sourceforge.net/
10 BuildRequires:  autoconf
11 BuildRequires:  automake
12 BuildRequires:  doxygen
13 BuildRequires:  libstdc++-devel
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 CppUnit is the C++ port of the famous JUnit framework for unit
18 testing.
19
20 %description -l pl
21 CppUnit jest portem C++ s³ynnego ¶rodowiska testowego JUnit.
22
23 %package devel
24 Summary:        cppunit header files
25 Summary(pl):    Pliki nag³ówkowe cppunit
26 Group:          Development/Libraries
27 Requires:       %{name} = %{version}
28
29 %description devel
30 cppunit header files.
31
32 %description devel -l pl
33 Pliki nag³ówkowe cppunit.
34
35 %package static
36 Summary:        cppunit static library
37 Summary(pl):    Statyczna biblioteka cppunit
38 Group:          Development/Libraries
39 Requires:       %{name}-devel = %{version}
40
41 %description static
42 cppunit static library.
43
44 %description static -l pl
45 Statyczna biblioteka cppunit.
46
47 %prep
48 %setup -q
49
50 echo 'libcppunit_la_LIBADD = -lstdc++ -lpthread' >> src/cppunit/Makefile.am
51
52 %build
53 aclocal -I config
54 %{__autoconf}
55 %{__automake}
56 %configure
57
58 %{__make}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} install DESTDIR=$RPM_BUILD_ROOT
64
65 rm -rf $RPM_BUILD_ROOT%{_includedir}/cppunit/{ui/mfc,ui/qt,config-[bm]*}
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post   -p /sbin/ldconfig
71 %postun -p /sbin/ldconfig
72
73 %files
74 %defattr(644,root,root,755)
75 %doc AUTHORS BUGS NEWS README THANKS TODO
76 %attr(755,root,root) %{_libdir}/lib*.so.*.*
77
78 %files devel
79 %defattr(644,root,root,755)
80 %doc doc/FAQ doc/html
81 %attr(755,root,root) %{_bindir}/cppunit-config
82 %attr(755,root,root) %{_libdir}/lib*.la
83 %attr(755,root,root) %{_libdir}/lib*.so
84 %{_includedir}/cppunit
85 %{_aclocaldir}/cppunit.m4
86 %{_mandir}/man1/cppunit-config.1*
87
88 %files static
89 %defattr(644,root,root,755)
90 %{_libdir}/lib*.a
This page took 0.050708 seconds and 4 git commands to generate.