]> git.pld-linux.org Git - packages/cppunit.git/blob - cppunit.spec
- updated to 1.10.2
[packages/cppunit.git] / cppunit.spec
1 Summary:        The C++ Unit Test Library
2 Summary(pl):    Biblioteka testowa do C++
3 Name:           cppunit
4 Version:        1.10.2
5 Release:        1
6 License:        LGPL
7 Group:          Libraries
8 Source0:        http://dl.sourceforge.net/cppunit/%{name}-%{version}.tar.gz
9 # Source0-md5:  0bc06cd219410f7d4f6bbfc9bdd7c824
10 URL:            http://cppunit.sourceforge.net/
11 BuildRequires:  autoconf >= 2.50
12 BuildRequires:  automake >= 1.4
13 BuildRequires:  doxygen
14 BuildRequires:  libstdc++-devel
15 BuildRequires:  libtool >= 2:1.4d
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 CppUnit is the C++ port of the famous JUnit framework for unit
20 testing.
21
22 %description -l pl
23 CppUnit jest portem C++ s³ynnego ¶rodowiska testowego JUnit.
24
25 %package devel
26 Summary:        cppunit header files
27 Summary(pl):    Pliki nag³ówkowe cppunit
28 Group:          Development/Libraries
29 Requires:       %{name} = %{version}-%{release}
30
31 %description devel
32 cppunit header files.
33
34 %description devel -l pl
35 Pliki nag³ówkowe cppunit.
36
37 %package static
38 Summary:        cppunit static library
39 Summary(pl):    Statyczna biblioteka cppunit
40 Group:          Development/Libraries
41 Requires:       %{name}-devel = %{version}-%{release}
42
43 %description static
44 cppunit static library.
45
46 %description static -l pl
47 Statyczna biblioteka cppunit.
48
49 %prep
50 %setup -q
51
52 echo 'libcppunit_la_LIBADD = -ldl' >> src/cppunit/Makefile.am
53
54 %build
55 %{__libtoolize}
56 %{__aclocal} -I config
57 %{__autoconf}
58 %{__autoheader}
59 %{__automake}
60 %configure
61 %{__make}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %{__make} install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 rm -rf $RPM_BUILD_ROOT%{_includedir}/cppunit/{ui/mfc,ui/qt,config/config-[bm]*}
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %post   -p /sbin/ldconfig
75 %postun -p /sbin/ldconfig
76
77 %files
78 %defattr(644,root,root,755)
79 %doc AUTHORS BUGS NEWS README THANKS TODO
80 %attr(755,root,root) %{_libdir}/lib*.so.*.*
81
82 %files devel
83 %defattr(644,root,root,755)
84 %doc doc/FAQ doc/html
85 %attr(755,root,root) %{_bindir}/cppunit-config
86 %attr(755,root,root) %{_libdir}/lib*.so
87 %{_libdir}/lib*.la
88 %{_includedir}/cppunit
89 %{_aclocaldir}/cppunit.m4
90 %{_mandir}/man1/cppunit-config.1*
91
92 %files static
93 %defattr(644,root,root,755)
94 %{_libdir}/lib*.a
This page took 0.042861 seconds and 4 git commands to generate.