]> git.pld-linux.org Git - packages/cppunit.git/blob - cppunit.spec
- added am18 patch, release 2
[packages/cppunit.git] / cppunit.spec
1 Summary:        The C++ Unit Test Library
2 Summary(pl):    Biblioteka testowa do C++
3 Name:           cppunit
4 Version:        1.10.2
5 Release:        2
6 License:        LGPL
7 Group:          Libraries
8 Source0:        http://dl.sourceforge.net/cppunit/%{name}-%{version}.tar.gz
9 # Source0-md5:  0bc06cd219410f7d4f6bbfc9bdd7c824
10 Patch0:         %{name}-am18.patch
11 URL:            http://cppunit.sourceforge.net/
12 BuildRequires:  autoconf >= 2.50
13 BuildRequires:  automake >= 1.4
14 BuildRequires:  doxygen
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  libtool >= 2:1.4d
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 CppUnit is the C++ port of the famous JUnit framework for unit
21 testing.
22
23 %description -l pl
24 CppUnit jest portem C++ s³ynnego ¶rodowiska testowego JUnit.
25
26 %package devel
27 Summary:        cppunit header files
28 Summary(pl):    Pliki nag³ówkowe cppunit
29 Group:          Development/Libraries
30 Requires:       %{name} = %{version}-%{release}
31
32 %description devel
33 cppunit header files.
34
35 %description devel -l pl
36 Pliki nag³ówkowe cppunit.
37
38 %package static
39 Summary:        cppunit static library
40 Summary(pl):    Statyczna biblioteka cppunit
41 Group:          Development/Libraries
42 Requires:       %{name}-devel = %{version}-%{release}
43
44 %description static
45 cppunit static library.
46
47 %description static -l pl
48 Statyczna biblioteka cppunit.
49
50 %prep
51 %setup -q
52 %patch0 -p1
53
54 echo 'libcppunit_la_LIBADD = -ldl' >> src/cppunit/Makefile.am
55
56 %build
57 %{__libtoolize}
58 %{__aclocal} -I config
59 %{__autoconf}
60 %{__autoheader}
61 %{__automake}
62 %configure
63 %{__make}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 %{__make} install \
69         DESTDIR=$RPM_BUILD_ROOT
70
71 rm -rf $RPM_BUILD_ROOT%{_includedir}/cppunit/{ui/mfc,ui/qt,config/config-[bm]*}
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post   -p /sbin/ldconfig
77 %postun -p /sbin/ldconfig
78
79 %files
80 %defattr(644,root,root,755)
81 %doc AUTHORS BUGS NEWS README THANKS TODO
82 %attr(755,root,root) %{_libdir}/lib*.so.*.*
83
84 %files devel
85 %defattr(644,root,root,755)
86 %doc doc/FAQ doc/html
87 %attr(755,root,root) %{_bindir}/cppunit-config
88 %attr(755,root,root) %{_libdir}/lib*.so
89 %{_libdir}/lib*.la
90 %{_includedir}/cppunit
91 %{_aclocaldir}/cppunit.m4
92 %{_mandir}/man1/cppunit-config.1*
93
94 %files static
95 %defattr(644,root,root,755)
96 %{_libdir}/lib*.a
This page took 0.084237 seconds and 4 git commands to generate.