]> git.pld-linux.org Git - packages/cppo.git/blame - cppo.spec
- cleanup ocaml_opt bcond
[packages/cppo.git] / cppo.spec
CommitLineData
b4bd1ab1
ER
1#
2# Conditional build:
2cb517ac
JR
3%bcond_without ocaml_opt # skip building native optimized binaries (bytecode is always built)
4
5# not yet available on x32 (ocaml 4.02.1), remove when upstream will support it
6%ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
7%undefine with_ocaml_opt
8%endif
b4bd1ab1
ER
9
10%define debug_package %{nil}
11Summary: cpp for OCaml
12Summary(pl.UTF-8): Wiązania cppo dla OCamla
13Name: cppo
14Version: 0.9.3
2cb517ac 15Release: 3
b4bd1ab1
ER
16License: BSD
17Group: Applications
18Source0: http://mjambon.com/releases/cppo/%{name}-%{version}.tar.gz
19# Source0-md5: cfea4211ab9a7c1276537ce4fc3669b5
20URL: http://mjambon.com/cppo.html
21BuildRequires: ocaml >= 3.04-7
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25Cppo is an OCaml-friendly implementation of cpp, the C preprocessor.
26It can replace camlp4 for preprocessing OCaml files, using cpp style
27and syntax. It allows defining simple macros and file inclusion.
28
29%description -l pl.UTF-8
30Pakiet ten zawiera binaria potrzebne do uruchamiania programów
31używających tej biblioteki.
32
33%prep
34%setup -q
35
36%build
2cb517ac 37%{__make} -j1 all %{?with_ocaml_opt:opt} \
b4bd1ab1
ER
38 CC="%{__cc} %{rpmcflags} -fPIC"
39
40%install
41rm -rf $RPM_BUILD_ROOT
42install -d $RPM_BUILD_ROOT%{_bindir}
43install -p cppo $RPM_BUILD_ROOT%{_bindir}
44
45%clean
46rm -rf $RPM_BUILD_ROOT
47
48%files
49%defattr(644,root,root,755)
50%doc README Changes LICENSE examples
51%attr(755,root,root) %{_bindir}/cppo
This page took 0.957754 seconds and 4 git commands to generate.