]> git.pld-linux.org Git - packages/cpan2rpm.git/blob - cpan2rpm.spec
b3dc976af88ece8191f71b95df7e2e2c08ae7122
[packages/cpan2rpm.git] / cpan2rpm.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        Create RPMS from CPAN modules
7 Summary(pl):    Narzêdzie tworz±ce pakiety RPM z modu³ów CPAN
8 Name:           cpan2rpm
9 Version:        2.028
10 Release:        1
11 License:        GPL v2+
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/authors/id/E/EC/ECALDER/%{name}-%{version}.tar.gz
14 # Source0-md5:  4f85e07dfa848e5b72791aed975e8bc4
15 URL:            http://perl.arix.com/cpan2rpm/
16 BuildRequires:  perl-devel >= 1:5.8.0
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 cpan2rpm creates RPMs from CPAN packages, automating the locating,
23 fetching, spec file creation and building of the package.
24
25 %description -l pl
26 cpan2rpm tworzy pakiety RPM z pakietów CPAN, automatycznie je
27 znajduj±c, ¶ci±gaj±c, tworz±c plik spec i buduj±c pakiet.
28
29 %prep
30 %setup -q
31
32 %build
33 %{__perl} Makefile.PL \
34         INSTALLDIRS=vendor
35
36 # avoid running cpan2rpm and using network
37 touch cpan2rpm.spec
38
39 %{__make}
40
41 %{?with_tests:%{__make} test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} install \
47         DESTDIR=$RPM_BUILD_ROOT
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc Changes README
55 %attr(755,root,root) %{_bindir}/*
56 %{_mandir}/man1/*
This page took 0.033374 seconds and 2 git commands to generate.