]> git.pld-linux.org Git - packages/cpan2rpm.git/blob - cpan2rpm.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/cpan2rpm.git] / cpan2rpm.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 Summary:        Create RPMS from CPAN modules
6 Summary(pl.UTF-8):      Narzędzie tworzące pakiety RPM z modułów CPAN
7 Name:           cpan2rpm
8 Version:        2.028
9 Release:        1
10 License:        GPL v2+
11 Group:          Development/Languages/Perl
12 Source0:        http://www.cpan.org/authors/id/E/EC/ECALDER/%{name}-%{version}.tar.gz
13 # Source0-md5:  4f85e07dfa848e5b72791aed975e8bc4
14 Patch0:         %{name}-make.patch
15 URL:            http://perl.arix.com/cpan2rpm/
16 BuildRequires:  perl-devel >= 1:5.8.0
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 cpan2rpm creates RPMs from CPAN packages, automating the locating,
23 fetching, spec file creation and building of the package.
24
25 %description -l pl.UTF-8
26 cpan2rpm tworzy pakiety RPM z pakietów CPAN, automatycznie je
27 znajdując, ściągając, tworząc plik spec i budując pakiet.
28
29 %prep
30 %setup -q
31 %patch0 -p1
32
33 %build
34 %{__perl} Makefile.PL \
35         INSTALLDIRS=vendor
36
37 # avoid running cpan2rpm and using network
38 touch cpan2rpm.spec
39
40 %{__make}
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes README
56 %attr(755,root,root) %{_bindir}/*
57 %{_mandir}/man1/*
This page took 0.051396 seconds and 3 git commands to generate.