]> git.pld-linux.org Git - packages/courier-sox.git/blob - courier-sox.spec
- updated to 0.18
[packages/courier-sox.git] / courier-sox.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static libraries
4 %bcond_without  tests           # "make check"
5
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        Courier Socks 5 client libraries
8 Summary(pl.UTF-8):      Biblioteki klienckie Socks 5
9 Name:           courier-sox
10 Version:        0.12
11 Release:        3
12 License:        GPL v3 with OpenSSL exception
13 Group:          Networking/Utilities
14 Source0:        http://downloads.sourceforge.net/courier/%{name}-%{version}.tar.bz2
15 # Source0-md5:  c5f3778d9c5d7136b707b5f8ebb80515
16 Patch0:         %{name}-init.patch
17 URL:            http://www.courier-mta.org/
18 BuildRequires:  courier-authlib-devel >= 0.56.20050702
19 BuildRequires:  gdbm-devel
20 BuildRequires:  libltdl-devel >= 2:2.0
21 BuildRequires:  perl-base
22 BuildRequires:  rpm-perlprov
23 BuildRequires:  rpmbuild(macros) >= 1.268
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This is a generic Socks 5 client support library.
28
29 %description -l pl.UTF-8
30 Ogólna biblioteka kliencka Socks 5.
31
32 %package devel
33 Summary:        Socks 5 client header files
34 Summary(pl.UTF-8):      Pliki nagłówkowe klienta socks 5
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37
38 %description devel
39 This package contains header files for building applications that use
40 Socks 5 proxies.
41
42 %description devel -l pl.UTF-8
43 Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji używających
44 proxy Socks 5.
45
46 %package static
47 Summary:        Socks 5 client static libraries
48 Summary(pl.UTF-8):      Biblioteki statyczne klienta socks 5
49 Group:          Development/Libraries
50 Requires:       %{name}-devel = %{version}-%{release}
51
52 %description static
53 This package contains static libraries for building applications that
54 use Socks 5 proxies.
55
56 %description static -l pl.UTF-8
57 Ten pakiet zawiera biblioteki statyczne do tworzenia aplikacji
58 używających proxy Socks 5.
59
60 %package server
61 Summary:        Socks 5 server
62 Summary(pl.UTF-8):      Serwer socks 5
63 Group:          Networking/Daemons
64 Requires(post,preun):   /sbin/chkconfig
65 Requires:       %{name} = %{version}-%{release}
66 # requires library and courierlogger
67 Requires:       courier-authlib >= 0.56.20050702
68
69 %description server
70 This package contains the Courier Socks 5 server.
71
72 %description server -l pl.UTF-8
73 Ten pakiet zawiera serwer Courier Socks 5.
74
75 %prep
76 %setup -q
77 %patch0 -p1
78
79 %build
80 %configure \
81         --libexecdir=%{_libexecdir}/courier-sox \
82         %{!?with_static_libs:--disable-static}
83
84 %{__make}
85
86 %if %{with tests}
87 %{__make} check
88 %endif
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92
93 %{__make} install \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 install -D courier-sox.sysvinit $RPM_BUILD_ROOT/etc/rc.d/init.d/courier-sox
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post   -p /sbin/ldconfig
102 %postun -p /sbin/ldconfig
103
104 %post server
105 /sbin/chkconfig --add courier-sox
106 %service courier-sox restart
107
108 %preun server
109 if [ "$1" = "0" ]; then
110         %service courier-sox stop
111         /sbin/chkconfig --del courier-sox
112 fi
113
114 %files
115 %defattr(644,root,root,755)
116 %doc AUTHORS ChangeLog NEWS README *.html
117 %attr(755,root,root) %{_bindir}/mkbl4
118 %attr(755,root,root) %{_bindir}/socksify
119 %attr(755,root,root) %{_libdir}/libsocks.so.*.*.*
120 %attr(755,root,root) %ghost %{_libdir}/libsocks.so.0
121 %attr(755,root,root) %{_libdir}/libsockswrap.so.*.*.*
122 %attr(755,root,root) %ghost %{_libdir}/libsockswrap.so.0
123 %{_mandir}/man1/socksify.1*
124 %{_mandir}/man5/socksrc.5*
125 %{_mandir}/man8/mkbl4.8*
126 %dir %{_sysconfdir}/socksrc
127 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/socksrc/system
128
129 %files devel
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_libdir}/libsocks.so
132 %attr(755,root,root) %{_libdir}/libsockswrap.so
133 %{_libdir}/libsocks.la
134 %{_libdir}/libsockswrap.la
135 %{_includedir}/socks.h
136 %{_mandir}/man3/socks.3*
137
138 %if %{with static_libs}
139 %files static
140 %defattr(644,root,root,755)
141 %{_libdir}/libsocks.a
142 %{_libdir}/libsockswrap.a
143 %endif
144
145 %files server
146 %defattr(644,root,root,755)
147 %attr(754,root,root) /etc/rc.d/init.d/courier-sox
148 %attr(755,root,root) %{_sbindir}/sockd
149 %dir %{_libexecdir}/courier-sox
150 %attr(755,root,root) %{_libexecdir}/courier-sox/sockd
151 %{_mandir}/man1/sockd.1*
This page took 0.119418 seconds and 3 git commands to generate.