]> git.pld-linux.org Git - packages/courier-sox.git/blob - courier-sox.spec
- few fixes for init file
[packages/courier-sox.git] / courier-sox.spec
1 #
2 # TODO:
3 #       - write/modify init file
4 #
5 Summary:        Courier Socks 5 client library
6 Summary(pl):    Biblioteki klienckie Socks 5
7 Name:           courier-sox
8 Version:        0.05
9 Release:        0.5
10 License:        GPL
11 Group:          Networking/Daemons
12 #Source0:       http://dl.sourceforge.net/courier/%{name}-%{version}.tar.bz2
13 Source0:        http://www.courier-mta.org/beta/sox/%{name}-%{version}.tar.bz2
14 # Source0-md5:  41a87d18a56dcabd3fc513ceba7b679b
15 Patch0:         %{name}-build.patch
16 URL:            http://www.courier-mta.org
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  libtool
20 BuildRequires:  libltdl-devel
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _libexecdir     %{_libdir}/courier-sox
24
25 %description
26 This is a generic Socks 5 client support library. It does not include
27 a Socks 5 server (yet). This is just a client-side library.
28
29 %description -l pl
30 Ogólna biblioteka kliencka Socks 5. Nie zawiera (jeszcze) serwera
31 Socks 5, jest tylko bibliotek± dla strony klienta.
32
33 %package devel
34 Summary:        Socks 5 client header files
35 Summary(pl):    Pliki nag³ówkowe klienta socks 5
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38
39 %description devel
40 This package contains header files for building applications that use
41 Socks 5 proxies.
42
43 %description devel -l pl
44 Ten pakiet zawiera pliki nag³ówkowe do tworzenia aplikacji u¿ywaj±cych
45 proxy Socks 5.
46
47 %package server
48 Summary:        Socks 5 server
49 Summary(pl):    Serwer socks 5
50 Group:          Networking/Utilities
51 Requires:       %{name} = %{version}-%{release}
52 Requires(post,preun):   /sbin/chkconfig
53
54 %description server
55 This package contains the Courier Socks 5 server. Install this package
56 if you want to run a Socks 5 server.
57
58 %description server -l pl
59 Ten pakiet zawiera serwer couriera socks 5. Je¿eli chcesz uruchamiaæ
60 serwer socks5, zainstaluj ten pakiet.
61
62 %package static
63 Summary:        Socks 5 client static libraries
64 Summary(pl):    Biblioteki statyczne klienta socks 5
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67
68 %description static
69 This package contains static libraries for building applications that
70 use Socks 5 proxies.
71
72 %description static -l pl
73 Ten pakiet zawiera biblioteki statyczne do tworzenia aplikacji
74 u¿ywaj±cych proxy Socks 5.
75
76 %prep
77 %setup -q
78 %patch0 -p1
79
80 %build
81 %{__libtoolize}
82 %{__aclocal}
83 %{__autoconf}
84 %{__autoheader}
85 %{__automake}
86 %configure \
87         --libexecdir=%{_libexecdir}
88
89 %{__make}
90 %{__make} check
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94
95 %{__make} install \
96         DESTDIR=$RPM_BUILD_ROOT
97
98 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
99 install courier-sox.sysvinit $RPM_BUILD_ROOT/etc/rc.d/init.d/courier-sox
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post   -p /sbin/ldconfig
105 %postun -p /sbin/ldconfig
106
107 %post server
108 /sbin/chkconfig --add courier-sox
109
110 if [ -f /var/lock/subsys/courier-sox ]; then
111         /etc/rc.d/init.d/courier-sox restart >&2
112 else
113         echo "Run \"/etc/rc.d/init.d/courier-sox start\" to start courier-sox"
114 fi
115
116 %preun server
117 if [ "$1" = "0" ]; then
118         if [ -f /var/lock/subsys/courier-sox ]; then
119                 /etc/rc.d/init.d/courier-sox stop
120         fi
121         /sbin/chkconfig --del courier-sox
122 fi
123
124 %files
125 %defattr(644,root,root,755)
126 %doc AUTHORS ChangeLog NEWS README *.html
127 %attr(755,root,root) %{_bindir}/*
128 %attr(755,root,root) %{_libdir}/lib*.so.*.*
129 %{_libdir}/lib*.la
130 %{_mandir}/man1/socksify*
131 %{_mandir}/man3/socks*
132 %{_mandir}/man5/*
133 %{_sysconfdir}/socksrc
134
135 %files devel
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_libdir}/lib*.so
138 %{_includedir}/*
139
140 %files server
141 %defattr(644,root,root,755)
142 %attr(754,root,root) /etc/rc.d/init.d/courier-sox
143 %{_mandir}/man1/sockd*
144 %attr(755,root,root) %{_sbindir}/sockd
145 %attr(755,root,root) %{_libexecdir}/sockd
146
147 %files static
148 %defattr(644,root,root,755)
149 %{_libdir}/lib*.a
This page took 0.065389 seconds and 3 git commands to generate.