]> git.pld-linux.org Git - packages/courier-imap.git/commitdiff
- reverting last change: removing new macros from %p{re,ost}{,un}
authorsaq <saq@pld-linux.org>
Thu, 26 Jul 2001 05:42:05 +0000 (05:42 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    courier-imap.spec -> 1.27

courier-imap.spec

index 50293aa65ac657500338f14f5afbb29e8874dd4b..5da4b0fc5bc6c64fc4b90e29bc6701bc643d27a8 100644 (file)
@@ -121,22 +121,56 @@ gzip -9nf README* imap/BUGS AUTHORS COPYING
 touch $RPM_BUILD_ROOT/etc/security/blacklist.{pop3,imap}
 
 %post
-DESC="%{name} daemon"; %chkconfig_add
+/sbin/chkconfig --add courier-imap
+
+if [ -f /var/lock/subsys/courier-imap ]; then
+       /etc/rc.d/init.d/courier-imap restart >&2
+else
+       echo "Run \"/etc/rc.d/init.d/courier-imap start\" to start courier-imap daemon."
+fi
 
 %preun
-%chkconfig_del
+if [ "$1" = "0" ]; then
+       if [ -f /var/lock/subsys/courier-imap ]; then
+               /etc/rc.d/init.d/courier-imap stop >&2
+       fi
+       /sbin/chkconfig --del courier-imap
+fi
 
 %post common
-NAME=authdaemon; DESC="%{name} authdaemon"; %chkconfig_add
+/sbin/chkconfig --add authdaemon
+
+if [ -f /var/lock/subsys/authdaemon ]; then
+       /etc/rc.d/init.d/authdaemon restart >&2
+else
+       echo "Run \"/etc/rc.d/init.d/authdaemon start\" to start courier-imap authdaemon."
+fi
 
 %preun common
-NAME=authdaemon; %chkconfig_del
+if [ "$1" = "0" ]; then
+       if [ -f /var/lock/subsys/authdaemon ]; then
+               /etc/rc.d/init.d/authdaemon stop >&2
+       fi
+
+       /sbin/chkconfig --del authdaemon
+fi
 
 %post pop3
-NAME=%{name}-pop3; DESC="%{name} pop3 daemon; %chkconfig_add
+/sbin/chkconfig --add courier-imap-pop3
+
+if [ -f /var/lock/subsys/courier-imap-pop3 ]; then
+       /etc/rc.d/init.d/courier-imap-pop3 restart >&2
+else
+       echo "Run \"/etc/rc.d/init.d/courier-imap-pop3 start\" to start courier-imap pop3 daemon."
+fi
 
 %preun pop3
-NAME=%{name}-pop3; %chkconfig_del
+if [ "$1" = "0" ]; then
+       if [ -f /var/lock/subsys/courier-imap-pop3 ]; then
+               /etc/rc.d/init.d/courier-imap-pop3 stop >&2
+       fi
+       /sbin/chkconfig --del courier-imap
+fi
 
 %clean
 rm -rf $RPM_BUILD_ROOT
This page took 0.086021 seconds and 4 git commands to generate.