]> git.pld-linux.org Git - packages/courier-authlib.git/blob - courier-authlib.spec
6e2615c475c3e952c6acaf97d927fc66068d9293
[packages/courier-authlib.git] / courier-authlib.spec
1 #
2 # TODO:
3 #       - pl
4 #       - files
5 #       - post, preun
6 #       - triggers to allow upgrade from courier,courier-imap,sqwebmail
7 #
8 Summary:        Courier authentication library
9 Summary(pl):    -
10 Name:           courier-authlib
11 %define         snap 20041116
12 Version:        0.50
13 Release:        0.%{snap}.0.1
14 License:        GPL
15 Group:          Networking/Daemons
16 Source0:        http://www.courier-mta.org/beta/%{name}/%{name}-%{version}.%{snap}.tar.bz2
17 # Source0-md5:  d6afed924f2195f55e17082336d679a7
18 URL:            http://www.courier-mta.org
19 Requires(post,preun):   /sbin/chkconfig
20 BuildRequires:  expect
21 BuildRequires:  gdbm-devel
22 BuildRequires:  libtool
23 BuildRequires:  mysql-devel
24 BuildRequires:  openldap-devel
25 BuildRequires:  pam-devel
26 BuildRequires:  postgresql-devel
27 BuildRequires:  zlib-devel
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 The Courier authentication library provides authentication services
32 for other Courier applications.
33
34 %description -l pl
35 -
36
37 %package devel
38 Summary:        Development libraries for the Courier authentication library.
39 Summary(pl):    -
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description devel
44 This package contains the development libraries and files needed to
45 compile Courier packages that use this authentication library. Install
46 this package in order to build the rest of the Courier packages. After
47 they are built and installed this package can be removed. Files in
48 this package are not needed at runtime.
49
50 %description devel -l pl
51 -
52
53 %package authldap
54 Summary:        LDAP support for the Courier authentication library
55 Summary(pl):    -
56 Group:          Networking/Daemons
57 PreReq:         %{name} = %{version}-%{release}
58
59 %description authldap
60 This package installs LDAP support for the Courier authentication
61 library. Install this package in order to be able to authenticate
62 using LDAP.
63
64 %description authldap -l pl
65 -
66
67 %package authmysql
68 Summary:        MySQL support for the Courier authentication library.
69 Summary(pl):    -
70 Group:          Networking/Daemons
71 PreReq:         %{name} = %{version}-%{release}
72
73 %description authmysql
74 This package installs MySQL support for the Courier authentication
75 library. Install this package in order to be able to authenticate
76 using MySQL.
77
78 %description authmysql -l pl
79 -
80
81 %package authpgsql
82 Summary:        PostgreSQL support for the Courier authentication library
83 Summary(pl):    -
84 Group:          Networking/Daemons
85 PreReq:         %{name} = %{version}-%{release}
86
87 %description authpgsql
88 This package installs PostgreSQL support for the Courier
89 authentication library. Install this package in order to be able to
90 authenticate using PostgreSQL.
91
92 %description authpgsql -l pl
93 -
94
95 %package userdb
96 Summary:        Userdb support for the Courier authentication library
97 Summary(pl):    -
98 Group:          Networking/Daemons
99 PreReq:         %{name} = %{version}-%{release}
100
101 %description userdb
102 This package installs the userdb support for the Courier
103 authentication library. Userdb is a simple way to manage virtual mail
104 accounts using a GDBM-based database file.
105
106 Install this package in order to be able to authenticate with userdb.
107
108 %description userdb -l pl
109 -
110
111 %prep
112 %setup -q -n %{name}-%{version}.%{snap}
113
114 %build
115 %configure
116
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d
126
127 install courier-authlib.sysvinit $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/courier-authlib
128
129 # make config files
130 ./sysconftool $RPM_BUILD_ROOT%{_sysconfdir}/authlib/*.dist
131 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/authlib/*.dist
132
133 # remove static library - for now
134 rm -f $RPM_BUILD_ROOT%{_libdir}/courier-authlib/*.a
135
136 %post
137 %{_libexecdir}/courier-authlib/authmigrate >/dev/null
138
139 /sbin/chkconfig --add courier-authlib
140
141 %preun
142 if test -x %{_sbindir}/authdaemond
143 then
144         %{_sbindir}/authdaemond >/dev/null 2>&1 || /bin/true
145 fi
146
147 if test "$1" = "0"
148 then
149         /sbin/chkconfig --del courier-authlib
150 fi
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %files
156 %defattr(644,root,root,755)
157 %doc README README*html README.authmysql.myownquery
158 %doc NEWS COPYING* AUTHORS ChangeLog authldap.schema
159 %dir %{_sysconfdir}/authlib
160 %dir %{_libexecdir}/courier-authlib
161 %attr(755,root,root) %{_sysconfdir}/rc.d/init.d/courier-authlib
162 %attr(755,root,root) %{_sysconfdir}/authlib/authdaemonrc
163 %attr(755,root,root) %{_libexecdir}/courier-authlib/authdaemond
164 %attr(755,root,root) %{_libexecdir}/courier-authlib/authsystem.passwd
165 %attr(755,root,root) %{_libexecdir}/courier-authlib/makedatprog
166 %attr(770,root,daemon) %dir %{_localstatedir}/spool/authdaemon
167 %attr(755,root,root) %{_sbindir}/authdaemond
168 %attr(755,root,root) %{_sbindir}/authenumerate
169 %attr(755,root,root) %{_sbindir}/authtest
170 %attr(755,root,root) %{_sbindir}/courierlogger
171 %{_mandir}/man1/*
172
173 %files devel
174 %defattr(644,root,root,755)
175 %doc authlib.html auth_*.html
176 %attr(755,root,root) %{_bindir}/courierauthconfig
177 %{_includedir}/*
178 %{_mandir}/man3/*
179
180 %files authldap
181 %defattr(644,root,root,755)
182 %doc authldap.schema README.ldap
183 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/authlib/authldaprc
184 %attr(755,root,root) %{_libexecdir}/courier-authlib/libauthldap*
185
186 %files authmysql
187 %defattr(644,root,root,755)
188 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/authlib/authmysqlrc
189 %attr(755,root,root) %{_libexecdir}/courier-authlib/libauthmysql*
190
191 %files authpgsql
192 %defattr(644,root,root,755)
193 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/authlib/authpgsqlrc
194 %attr(755,root,root) %{_libexecdir}/courier-authlib/libauthpgsql*
195
196 %files userdb
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_sbindir}/makeuserdb
199 %attr(755,root,root) %{_sbindir}/userdb
200 %attr(755,root,root) %{_sbindir}/userdbpw
201 %attr(755,root,root) %{_sbindir}/vchkpw2userdb
202 %attr(755,root,root) %{_libexecdir}/courier-authlib/libauthuserdb*
203 %{_mandir}/man8/*userdb*
This page took 0.038217 seconds and 2 git commands to generate.