]> git.pld-linux.org Git - packages/courier-authlib.git/blob - courier-authlib.spec
- pl, some unifications
[packages/courier-authlib.git] / courier-authlib.spec
1 #
2 # TODO:
3 #       - files
4 #       - post, preun
5 #       - triggers to allow upgrade from courier,courier-imap,sqwebmail
6 #
7 Summary:        Courier authentication library
8 Summary(pl):    Biblioteka uwierzytelniania Couriera
9 Name:           courier-authlib
10 %define         snap 20041116
11 Version:        0.50
12 Release:        0.%{snap}.0.1
13 License:        GPL
14 Group:          Networking/Daemons
15 Source0:        http://www.courier-mta.org/beta/courier-authlib/%{name}-%{version}.%{snap}.tar.bz2
16 # Source0-md5:  d6afed924f2195f55e17082336d679a7
17 URL:            http://www.courier-mta.org/
18 Requires(post,preun):   /sbin/chkconfig
19 BuildRequires:  expect
20 BuildRequires:  gdbm-devel
21 BuildRequires:  libtool
22 BuildRequires:  mysql-devel
23 BuildRequires:  openldap-devel
24 BuildRequires:  pam-devel
25 BuildRequires:  postgresql-devel
26 BuildRequires:  zlib-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 The Courier authentication library provides authentication services
31 for other Courier applications.
32
33 %description -l pl
34 Biblioteka uwierzytelniania Couriera dostarcza us³ugi uwierzytelniania
35 dla innych aplikacji Couriera.
36
37 %package devel
38 Summary:        Development files for the Courier authentication library
39 Summary(pl):    Pliki programistyczne dla biblioteki uwierzytelniania Couriera
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description devel
44 This package contains the development files needed to compile Courier
45 packages that use this authentication library. Install this package in
46 order to build the rest of the Courier packages. After they are built
47 and installed this package can be removed. Files in this package are
48 not needed at runtime.
49
50 %description devel -l pl
51 Ten pakiet zawiera pliki programistyczne potrzebne do kompilacji
52 pakietów Couriera u¿ywaj±cych biblioteki uwierzytelniania. Nale¿y go
53 zainstalowaæ aby zbudowaæ resztê pakietów Couriera. Po ich zbudowaniu
54 i zainstalowaniu ten pakiet mo¿na usun±æ. Pliki z tego pakietu nie s±
55 potrzebne w czasie dzia³ania programów.
56
57 %package authldap
58 Summary:        LDAP support for the Courier authentication library
59 Summary(pl):    Obs³uga LDAP dla biblioteki uwierzytelniania Couriera
60 Group:          Networking/Daemons
61 PreReq:         %{name} = %{version}-%{release}
62
63 %description authldap
64 This package installs LDAP support for the Courier authentication
65 library. Install this package in order to be able to authenticate
66 using LDAP.
67
68 %description authldap -l pl
69 Ten pakiet dodaje obs³ugê LDAP do biblioteki uwierzytelniania
70 Couriera. Nale¿y go zainstalowaæ aby móc uwierzytelniaæ siê z u¿yciem
71 LDAP.
72
73 %package authmysql
74 Summary:        MySQL support for the Courier authentication library
75 Summary(pl):    Obs³uga MySQL dla biblioteki uwierzytelniania Couriera
76 Group:          Networking/Daemons
77 PreReq:         %{name} = %{version}-%{release}
78
79 %description authmysql
80 This package installs MySQL support for the Courier authentication
81 library. Install this package in order to be able to authenticate
82 using MySQL.
83
84 %description authmysql -l pl
85 Ten pakiet dodaje obs³ugê MySQL do biblioteki uwierzytelniania
86 Couriera. Nale¿y go zainstalowaæ aby móc uwierzytelniaæ siê z u¿yciem
87 MySQL.
88
89 %package authpgsql
90 Summary:        PostgreSQL support for the Courier authentication library
91 Summary(pl):    Obs³uga PostgreSQL dla biblioteki uwierzytelniania Couriera
92 Group:          Networking/Daemons
93 PreReq:         %{name} = %{version}-%{release}
94
95 %description authpgsql
96 This package installs PostgreSQL support for the Courier
97 authentication library. Install this package in order to be able to
98 authenticate using PostgreSQL.
99
100 %description authpgsql -l pl
101 Ten pakiet dodaje obs³ugê PostgreSQL do biblioteki uwierzytelniania
102 Couriera. Nale¿y go zainstalowaæ aby móc uwierzytelniaæ siê z u¿yciem
103 PostgreSQL.
104
105 %package userdb
106 Summary:        Userdb support for the Courier authentication library
107 Summary(pl):    Obs³uga userdb dla biblioteki uwierzytelniania Couriera
108 Group:          Networking/Daemons
109 PreReq:         %{name} = %{version}-%{release}
110
111 %description userdb
112 This package installs the userdb support for the Courier
113 authentication library. Userdb is a simple way to manage virtual mail
114 accounts using a GDBM-based database file.
115
116 Install this package in order to be able to authenticate with userdb.
117
118 %description userdb -l pl
119 Ten pakiet dodaje obs³ugê userdb do biblioteki uwierzytelniania
120 Couriera. Userdb to prosty sposób zarz±dzania wirtualnymi kontami
121 pocztowymi przy u¿yciu pliku bazy danych opartej na GDBM.
122
123 Nale¿y go zainstalowaæ aby móc uwierzytelniaæ siê z u¿yciem userdb.
124
125 %prep
126 %setup -q -n %{name}-%{version}.%{snap}
127
128 %build
129 %configure
130
131 %{__make}
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135
136 %{__make} install \
137         DESTDIR=$RPM_BUILD_ROOT
138
139 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
140
141 install courier-authlib.sysvinit $RPM_BUILD_ROOT/etcdir}/rc.d/init.d/courier-authlib
142
143 # make config files
144 ./sysconftool $RPM_BUILD_ROOT%{_sysconfdir}/authlib/*.dist
145 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/authlib/*.dist
146
147 # remove static library - for now
148 rm -f $RPM_BUILD_ROOT%{_libdir}/courier-authlib/*.a
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %post
154 %{_libexecdir}/courier-authlib/authmigrate >/dev/null
155
156 /sbin/chkconfig --add courier-authlib
157
158 %preun
159 if [ -x %{_sbindir}/authdaemond ]; then
160         %{_sbindir}/authdaemond >/dev/null 2>&1 || /bin/true
161 fi
162
163 if [ "$1" = "0" ]; then
164         /sbin/chkconfig --del courier-authlib
165 fi
166
167 %files
168 %defattr(644,root,root,755)
169 %doc README README*html README.authmysql.myownquery
170 %doc NEWS COPYING* AUTHORS ChangeLog authldap.schema
171 %dir %{_sysconfdir}/authlib
172 %dir %{_libexecdir}/courier-authlib
173 %attr(755,root,root) %{_sysconfdir}/rc.d/init.d/courier-authlib
174 %attr(755,root,root) %{_sysconfdir}/authlib/authdaemonrc
175 %attr(755,root,root) %{_libexecdir}/courier-authlib/authdaemond
176 %attr(755,root,root) %{_libexecdir}/courier-authlib/authsystem.passwd
177 %attr(755,root,root) %{_libexecdir}/courier-authlib/makedatprog
178 %attr(770,root,daemon) %dir %{_localstatedir}/spool/authdaemon
179 %attr(755,root,root) %{_sbindir}/authdaemond
180 %attr(755,root,root) %{_sbindir}/authenumerate
181 %attr(755,root,root) %{_sbindir}/authtest
182 %attr(755,root,root) %{_sbindir}/courierlogger
183 %{_mandir}/man1/*
184
185 %files devel
186 %defattr(644,root,root,755)
187 %doc authlib.html auth_*.html
188 %attr(755,root,root) %{_bindir}/courierauthconfig
189 %{_includedir}/*
190 %{_mandir}/man3/*
191
192 %files authldap
193 %defattr(644,root,root,755)
194 %doc authldap.schema README.ldap
195 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/authlib/authldaprc
196 %attr(755,root,root) %{_libexecdir}/courier-authlib/libauthldap*
197
198 %files authmysql
199 %defattr(644,root,root,755)
200 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/authlib/authmysqlrc
201 %attr(755,root,root) %{_libexecdir}/courier-authlib/libauthmysql*
202
203 %files authpgsql
204 %defattr(644,root,root,755)
205 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/authlib/authpgsqlrc
206 %attr(755,root,root) %{_libexecdir}/courier-authlib/libauthpgsql*
207
208 %files userdb
209 %defattr(644,root,root,755)
210 %attr(755,root,root) %{_sbindir}/makeuserdb
211 %attr(755,root,root) %{_sbindir}/userdb
212 %attr(755,root,root) %{_sbindir}/userdbpw
213 %attr(755,root,root) %{_sbindir}/vchkpw2userdb
214 %attr(755,root,root) %{_libexecdir}/courier-authlib/libauthuserdb*
215 %{_mandir}/man8/*userdb*
This page took 0.109069 seconds and 3 git commands to generate.