]> git.pld-linux.org Git - packages/couchdb.git/blob - couchdb.spec
- dropped unused parts
[packages/couchdb.git] / couchdb.spec
1 #
2 %define snap    20080608 
3 Summary:        A distributed document-oriented database
4 Summary(pl.UTF-8):      Rozproszona baza danych oparta o dokumenty
5 Name:           couchdb
6 Version:        0.8
7 Release:        0.%{snap}
8 License:        Apache
9 Group:          Applications
10 Source0:        %{name}-%{version}-%{snap}.tar.gz
11 # Source0-md5:  f2f7c819f3b562887ed0c336d36c6b38
12 Source1:        %{name}.init
13 URL:            http://incubator.apache.org/couchdb/
14 BuildRequires:  rpmbuild(macros) >= 1.228
15 Requires(post,preun):   /sbin/chkconfig
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  erlang >= 
19 BuildRequires:  help2man
20 BuildRequires:  intltool
21 Requires(post,preun):   /sbin/chkconfig
22 Requires(pre):  /bin/id
23 Requires(pre):  /usr/bin/getgid
24 Requires(pre):  /usr/sbin/groupadd
25 Requires(pre):  /usr/sbin/useradd
26 Provides:       group(couchdb)
27 Provides:       user(couchdb)
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Apache CouchDB is a distributed, fault-tolerant and schema-free
32 document-oriented database accessible via a RESTful HTTP/JSON
33 API. Among other features, it provides robust, incremental replication
34 with bi-directional conflict detection and resolution, and is
35 queryable and indexable using a table-oriented view engine with
36 JavaScript acting as the default view definition language.
37
38 %description -l pl.UTF-8
39
40 Apache CouchDB jest rozproszoną, odporną na błędy, nie wymagającą
41 schematów, zorientowaną na dokument bazą danych z RESTowym API opartym
42 o HTTP/JSON.  Między innymi zapewnia solidną, przyrostową replikację
43 z dwukierunkowym wykrywaniem i rozwiązywaniem konfliktów, oraz odpytywanie
44 i indeksowanie za pośrednictwem opartego na tablicach silnika widoków
45 używającego JavaScriptu jako głównego języka definicji widoku.
46
47 %prep
48 %setup -q -n %{name}
49 touch ChangeLog # needed by ./configure
50
51 %build
52 ./bootstrap
53 %configure --with-erlang=%{_libdir}/erlang/usr/include
54 %{__make}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 rm -rf $RPM_BUILD_ROOT%{_defaultdocdir}/*
63
64 mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
65 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %pre
71 %groupadd -g 230 couchdb
72 %useradd -u 230 -g couchdb -c "CouchDB server" couchdb
73
74 %post
75 /sbin/chkconfig --add %{name}
76 %service %{name} restart "CouchDB server"
77
78 %preun
79 if [ "$1" = "0" ]; then
80         %service %{name} stop
81         /sbin/chkconfig --del %{name}
82 fi
83
84 %files
85 %defattr(644,root,root,755)
86 %doc AUTHORS BUGS CHANGES NEWS NOTICE README THANKS
87 %attr(755,root,root) %{_bindir}/*
88 %{_datadir}/apache-couchdb
89 %{_libdir}/apache-couchdb
90 %dir %{_sysconfdir}/apache-couchdb/
91 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache-couchdb/couch.ini
92 %attr(700,couchdb,couchdb) %dir %{_sharedstatedir}/apache-couchdb
93 %attr(700,couchdb,couchdb) %dir %{_localstatedir}/log/apache-couchdb
94 %{_mandir}/man1/*
95 %attr(754,root,root) /etc/rc.d/init.d/%{name}
This page took 0.065733 seconds and 3 git commands to generate.