]> git.pld-linux.org Git - packages/corosync.git/commitdiff
Version: 2.1.0 auto/th/corosync-2.1.0-0.1
authorJacek Konieczny <j.konieczny@eggsoft.pl>
Thu, 25 Oct 2012 07:22:49 +0000 (09:22 +0200)
committerJacek Konieczny <jajcus@jajcus.net>
Thu, 25 Oct 2012 07:22:49 +0000 (09:22 +0200)
corosync-install.patch
corosync-lib_deps.patch
corosync-makefile.patch [deleted file]
corosync.spec

index fd722b702c326a0f64bc2edcbd0d0f2fc8133ddd..f9902c3efb6e0b7949dcbe1babd327ac8a9556b8 100644 (file)
@@ -1,26 +1,14 @@
---- corosync-2.0.1.orig/configure.ac   2012-05-22 08:52:01.000000000 +0200
-+++ corosync-2.0.1/configure.ac        2012-07-01 11:05:47.160318795 +0200
-@@ -601,8 +601,8 @@
+diff -dur corosync-2.1.0.orig/configure.ac corosync-2.1.0/configure.ac
+--- corosync-2.1.0.orig/configure.ac   2012-10-10 10:17:50.000000000 +0200
++++ corosync-2.1.0/configure.ac        2012-10-25 08:59:49.000000000 +0200
+@@ -611,8 +611,8 @@
+ AC_SUBST([SONAME])
  
  
- AC_SUBST([OS_LDL])
  AM_CONDITIONAL(INSTALL_TESTAGENTS, test -n "${enable_testagents}")
  AM_CONDITIONAL(INSTALL_TESTAGENTS, test -n "${enable_testagents}")
- AM_CONDITIONAL(INSTALL_MIB, test "${enable_snmp}" = "1")
+ AM_CONDITIONAL(INSTALL_MIB, test "${do_snmp}" = "1")
 -AM_CONDITIONAL(INSTALL_DBUSCONF, test "${enable_dbus}" = "1")
 +AM_CONDITIONAL(INSTALL_DBUSCONF, test "${enable_dbus}" = "yes")
  AM_CONDITIONAL(AUGTOOL, test -n "${AUGTOOL}")
  AC_SUBST([NSS_LDFLAGS])
  
 -AM_CONDITIONAL(INSTALL_DBUSCONF, test "${enable_dbus}" = "1")
 +AM_CONDITIONAL(INSTALL_DBUSCONF, test "${enable_dbus}" = "yes")
  AM_CONDITIONAL(AUGTOOL, test -n "${AUGTOOL}")
  AC_SUBST([NSS_LDFLAGS])
  
---- corosync-2.0.1.orig/init/Makefile.am       2012-05-22 08:52:01.000000000 +0200
-+++ corosync-2.0.1/init/Makefile.am    2012-07-01 11:11:22.512547818 +0200
-@@ -39,10 +39,8 @@
- if INSTALL_SYSTEMD
- systemdconfdir           = $(SYSTEMDDIR)
- systemdconf_DATA   = corosync.service corosync-notifyd.service
--initscriptdir    = $(INITWRAPPERSDIR)
--else
--initscriptdir    = $(INITDDIR)
- endif
-+initscriptdir    = $(INITDDIR)
- initscript_SCRIPTS  = corosync corosync-notifyd
- %: %.in Makefile
+
index 0bdaef5515062fcb8af4e64898152cfc808d3b6c..0c2a36a2740e98b83fc0218d3241141e3d9aa07a 100644 (file)
@@ -1,24 +1,13 @@
-diff -dur -x '*~' corosync-2.0.1.orig/exec/Makefile.am corosync-2.0.1/exec/Makefile.am
---- corosync-2.0.1.orig/exec/Makefile.am       2012-07-01 10:53:36.000000000 +0200
-+++ corosync-2.0.1/exec/Makefile.am    2012-07-01 10:55:31.786194954 +0200
-@@ -86,7 +86,7 @@
- libtotem_pg.so.$(SONAME): $(TOTEM_OBJS)
-       $(CC) -shared -o $@ \
-               -Wl,-soname=libtotem_pg.so.$(SOMAJOR) \
--              $(LDFLAGS) $^ $(nss_LIBS) $(rdmacm_LIBS) $(ibverbs_LIBS) -lpthread $(LIBS)
-+              $(LDFLAGS) $^ $(nss_LIBS) $(rdmacm_LIBS) $(ibverbs_LIBS) $(LIBQB_LIBS) -lpthread $(LIBS)
-       ln -sf libtotem_pg.so.$(SONAME) libtotem_pg.so
-       ln -sf libtotem_pg.so.$(SONAME) libtotem_pg.so.$(SOMAJOR)
+diff -dur corosync-2.1.0.orig/exec/Makefile.am corosync-2.1.0/exec/Makefile.am
+--- corosync-2.1.0.orig/exec/Makefile.am       2012-10-10 10:17:50.000000000 +0200
++++ corosync-2.1.0/exec/Makefile.am    2012-10-25 08:49:37.000000000 +0200
+@@ -50,7 +50,7 @@
+ libtotem_pg_la_SOURCES        = $(TOTEM_SRC)
+ libtotem_pg_la_CFLAGS = $(nss_CFLAGS) $(rdmacm_CFLAGS) $(ibverbs_CFLAGS)
+ libtotem_pg_la_LDFLAGS        = -version-number $(subst .,:,$(SONAME))
+-libtotem_pg_la_LIBADD = -lpthread $(nss_LIBS) $(rdmacm_LIBS) $(ibverbs_LIBS)
++libtotem_pg_la_LIBADD = -lpthread $(LIBQB_LIBS) $(nss_LIBS) $(rdmacm_LIBS) $(ibverbs_LIBS)
  
  
-diff -dur -x '*~' corosync-2.0.1.orig/lib/Makefile.am corosync-2.0.1/lib/Makefile.am
---- corosync-2.0.1.orig/lib/Makefile.am        2012-05-22 08:51:00.000000000 +0200
-+++ corosync-2.0.1/lib/Makefile.am     2012-07-01 10:56:17.943172941 +0200
-@@ -55,7 +55,7 @@
- libquorum_a_SOURCES   = quorum.c
- libvotequorum_a_SOURCES       = votequorum.c
- libcmap_a_SOURCES     = cmap.c
--SAM_LINKER_ADD                = -L. -lquorum -lcmap
-+SAM_LINKER_ADD                = -L. -lquorum -lcmap $(LIBQB_LIBS)
- libsam_a_SOURCES      = sam.c
+ sbin_PROGRAMS         = corosync
  
  
- noinst_HEADERS                = util.h \
+Only in corosync-2.1.0/exec: Makefile.am~
diff --git a/corosync-makefile.patch b/corosync-makefile.patch
deleted file mode 100644 (file)
index 4eb0c16..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- corosync-1.3.0/exec/Makefile.am.orig       2011-04-22 13:02:28.473341374 +0000
-+++ corosync-1.3.0/exec/Makefile.am    2011-04-22 13:02:42.090007879 +0000
-@@ -127,7 +127,7 @@ else
- libtotem_pg.so.$(SONAME): $(TOTEM_OBJS)
-       $(CC) -shared -o $@ \
-               -Wl,-soname=libtotem_pg.so.$(SOMAJOR) \
--              $(LDFLAGS) $^ $(nss_LIBS) $(rdmacm_LIBS) $(ibverbs_LIBS) -lpthread
-+              $(LDFLAGS) $^ $(nss_LIBS) $(rdmacm_LIBS) $(ibverbs_LIBS) -lpthread $(LIBS)
-       ln -sf libtotem_pg.so.$(SONAME) libtotem_pg.so
-       ln -sf libtotem_pg.so.$(SONAME) libtotem_pg.so.$(SOMAJOR)
index 494ccc204e1a245475942070843199be7df726da..91d8251390cb3b32dc29ac26462c0ca8915a5e43 100644 (file)
@@ -1,40 +1,38 @@
 #
 #
-# TODO:
-#      - wait for openais compatible with corosync 2.0 before setting full Release
-#
 # Conditional build:
 # Conditional build:
-%bcond_with    apidocs         # build apidocs (man3 pages are provided anyway)
+%bcond_without apidocs         # build apidocs (some man3 pages are provided anyway)
 %bcond_without dbus            # DBus events
 %bcond_without rdma            # RDMA support
 %bcond_without snmp            # SNMP protocol support
 %bcond_without dbus            # DBus events
 %bcond_without rdma            # RDMA support
 %bcond_without snmp            # SNMP protocol support
-%bcond_with testagents
-%bcond_with watchdog
-%bcond_with monitoring
-%bcond_with xmlconf
+%bcond_without testagents
+%bcond_without watchdog
+%bcond_without monitoring
+%bcond_without xmlconf
 #
 Summary:       Corosync - OSI Certified implementation of a complete cluster engine
 Summary(pl.UTF-8):     Corosync - implementacja silnika klastrowego certyfikowana przez OSI
 Name:          corosync
 #
 Summary:       Corosync - OSI Certified implementation of a complete cluster engine
 Summary(pl.UTF-8):     Corosync - implementacja silnika klastrowego certyfikowana przez OSI
 Name:          corosync
-Version:       2.0.1
+Version:       2.1.0
 Release:       0.1
 License:       BSD
 Group:         Base
 Release:       0.1
 License:       BSD
 Group:         Base
-Source0:       ftp://ftp:downloads@corosync.org/downloads/%{name}-%{version}/corosync-%{version}.tar.gz
-# Source0-md5: 9e23f3f5594676455ff39ff363658155
+Source0:       https://github.com/downloads/corosync/corosync/corosync-2.1.0.tar.gz
+# Source0-md5: dc5152e6dfdb4638ab544e587884483a
 Source1:       %{name}.init
 Source2:       %{name}-notifyd.init
 Source3:       %{name}-notifyd.sysconfig
 Source1:       %{name}.init
 Source2:       %{name}-notifyd.init
 Source3:       %{name}-notifyd.sysconfig
-Patch0:                %{name}-makefile.patch
-Patch1:                %{name}-lib_deps.patch
-Patch2:                %{name}-install.patch
+Patch0:                %{name}-lib_deps.patch
+Patch1:                %{name}-install.patch
 URL:           http://www.corosync.org/
 BuildRequires: autoconf >= 2.61
 BuildRequires: automake
 %{?with_dbus:BuildRequires:    dbus-devel}
 %{?with_apidocs:BuildRequires: doxygen}
 BuildRequires: libqb-devel
 URL:           http://www.corosync.org/
 BuildRequires: autoconf >= 2.61
 BuildRequires: automake
 %{?with_dbus:BuildRequires:    dbus-devel}
 %{?with_apidocs:BuildRequires: doxygen}
 BuildRequires: libqb-devel
+%{?with_monitoring:BuildRequires:      libstatgrab-devel}
 %if %{with rdma}
 BuildRequires: libibverbs-devel
 %if %{with rdma}
 BuildRequires: libibverbs-devel
+BuildRequires: libtool
 BuildRequires: librdmacm-devel
 %endif
 %{?with_xmlconf:BuildRequires: libxslt}
 BuildRequires: librdmacm-devel
 %endif
 %{?with_xmlconf:BuildRequires: libxslt}
@@ -119,9 +117,9 @@ This package contains corosync test agents.
 %setup -q
 %patch0 -p1
 %patch1 -p1
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
 
 %build
 
 %build
+%{__libtoolize}
 %{__aclocal}
 %{__autoconf}
 %{__autoheader}
 %{__aclocal}
 %{__autoconf}
 %{__autoheader}
@@ -142,10 +140,6 @@ This package contains corosync test agents.
 
 %{?with_apidocs:%{__make} doxygen}
 
 
 %{?with_apidocs:%{__make} doxygen}
 
-install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
-install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-notifyd
-install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}-notifyd
-
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/etc/sysconfig}
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/etc/sysconfig}
@@ -159,7 +153,13 @@ sed -e 's/^/#/' $RPM_BUILD_ROOT%{_sysconfdir}/corosync/corosync.conf.example \
        >$RPM_BUILD_ROOT%{_sysconfdir}/corosync/corosync.conf
 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/corosync/corosync.conf.example*
 
        >$RPM_BUILD_ROOT%{_sysconfdir}/corosync/corosync.conf
 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/corosync/corosync.conf.example*
 
-%{?with_apidocs:install doc/api/man/man3/* $RPM_BUILD_ROOT%{_mandir}/man3}
+install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
+install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-notifyd
+install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}-notifyd
+
+# init scripts, we provide our own
+%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/corosync
+%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/corosync-notifyd
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -206,7 +206,6 @@ fi
 %attr(755,root,root) %{_sbindir}/corosync-cfgtool
 %attr(755,root,root) %{_sbindir}/corosync-cmapctl
 %attr(755,root,root) %{_sbindir}/corosync-cpgtool
 %attr(755,root,root) %{_sbindir}/corosync-cfgtool
 %attr(755,root,root) %{_sbindir}/corosync-cmapctl
 %attr(755,root,root) %{_sbindir}/corosync-cpgtool
-%attr(755,root,root) %{_sbindir}/corosync-fplay
 %attr(755,root,root) %{_sbindir}/corosync-keygen
 %attr(755,root,root) %{_sbindir}/corosync-notifyd
 %attr(755,root,root) %{_sbindir}/corosync-quorumtool
 %attr(755,root,root) %{_sbindir}/corosync-keygen
 %attr(755,root,root) %{_sbindir}/corosync-notifyd
 %attr(755,root,root) %{_sbindir}/corosync-quorumtool
@@ -216,7 +215,6 @@ fi
 %{_mandir}/man8/corosync-cmapctl.8*
 %{_mandir}/man8/corosync-cfgtool.8*
 %{_mandir}/man8/corosync-cpgtool.8*
 %{_mandir}/man8/corosync-cmapctl.8*
 %{_mandir}/man8/corosync-cfgtool.8*
 %{_mandir}/man8/corosync-cpgtool.8*
-%{_mandir}/man8/corosync-fplay.8*
 %{_mandir}/man8/corosync-keygen.8*
 %{_mandir}/man8/corosync-notifyd.8*
 %{_mandir}/man8/corosync-quorumtool.8*
 %{_mandir}/man8/corosync-keygen.8*
 %{_mandir}/man8/corosync-notifyd.8*
 %{_mandir}/man8/corosync-quorumtool.8*
@@ -248,11 +246,12 @@ fi
 %attr(755,root,root) %ghost %{_libdir}/libquorum.so.5
 %attr(755,root,root) %{_libdir}/libtotem_pg.so.5.*.*
 %attr(755,root,root) %ghost %{_libdir}/libtotem_pg.so.5
 %attr(755,root,root) %ghost %{_libdir}/libquorum.so.5
 %attr(755,root,root) %{_libdir}/libtotem_pg.so.5.*.*
 %attr(755,root,root) %ghost %{_libdir}/libtotem_pg.so.5
-%attr(755,root,root) %{_libdir}/libvotequorum.so.5.*.*
-%attr(755,root,root) %ghost %{_libdir}/libvotequorum.so.5
+%attr(755,root,root) %{_libdir}/libvotequorum.so.6.*.*
+%attr(755,root,root) %ghost %{_libdir}/libvotequorum.so.6
 
 %files devel
 %defattr(644,root,root,755)
 
 %files devel
 %defattr(644,root,root,755)
+%doc doc/api/html/*
 %attr(755,root,root) %{_libdir}/libcfg.so
 %attr(755,root,root) %{_libdir}/libcmap.so
 %attr(755,root,root) %{_libdir}/libcorosync_common.so
 %attr(755,root,root) %{_libdir}/libcfg.so
 %attr(755,root,root) %{_libdir}/libcmap.so
 %attr(755,root,root) %{_libdir}/libcorosync_common.so
This page took 0.137704 seconds and 4 git commands to generate.