]> git.pld-linux.org Git - packages/corona.git/blob - corona.spec
8daa70595bf15aad7cdf0248de8dbf2428e09810
[packages/corona.git] / corona.spec
1 Summary:        Image input/output library
2 Summary(pl.UTF-8):      Biblioteka wejścia/wyjścia dla obrazów
3 Name:           corona
4 Version:        1.0.2
5 Release:        7
6 License:        zlib
7 Group:          Libraries
8 Source0:        http://downloads.sourceforge.net/corona/%{name}-%{version}.tar.gz
9 # Source0-md5:  29d1a7f1e2c85a83e9620496c62740ce
10 Patch0:         %{name}-system-gif.patch
11 Patch1:         %{name}-config.patch
12 Patch2:         %{name}-gcc43.patch
13 Patch3:         %{name}-libpng15.patch
14 URL:            http://corona.sourceforge.net/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  dos2unix
18 BuildRequires:  giflib-devel >= 4.1.0
19 BuildRequires:  libjpeg-devel
20 BuildRequires:  libpng-devel
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  libtool >= 2:1.5
23 BuildRequires:  rpmbuild(macros) >= 1.565
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Corona is an image input/output library that can read, write, and
28 manipulate image files in just a few lines of code. It can write PNG
29 and TGA files, and read PNG, JPEG, PCX, BMP, TGA, and GIF. Corona was
30 designed to be easy to use, and exports a straightforward C++ API.
31 With just a few lines of C++, you can add image loading to your
32 application.
33
34 %description -l pl.UTF-8
35 Corona to biblioteka wejścia/wyjścia dla obrazów, potrafiąca czytać,
36 zapisywać i obrabiać pliki obrazów w zaledwie kilku liniach kodu.
37 Potrafi zapisywać pliki PNG i TGA, a czytać PNG, JPEG, PCX, BMP, TGA i
38 GIF. Została zaprojektowana jako łatwa w użyciu i eksportuje
39 bezpośrednie API C++. Za pomocą tylko kilku linii kodu C++ można dodać
40 wczytywanie obrazów do swojej aplikacji.
41
42 %package devel
43 Summary:        Header files for corona library
44 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki corona
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       giflib-devel >= 4.1.0
48 Requires:       libjpeg-devel
49 Requires:       libpng-devel
50 Requires:       libstdc++-devel
51
52 %description devel
53 Header files for corona library.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe biblioteki corona.
57
58 %package static
59 Summary:        Static corona library
60 Summary(pl.UTF-8):      Statyczna biblioteka corona
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Static corona library.
66
67 %description static -l pl.UTF-8
68 Statyczna biblioteka corona.
69
70 %prep
71 %setup -q
72 %undos src/*.cpp src/*.h
73 %patch0 -p1
74 %patch1 -p1
75 %patch2 -p1
76 %patch3 -p1
77
78 %build
79 %{__libtoolize}
80 %{__aclocal}
81 %{__autoconf}
82 %{__automake}
83 %configure
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post   -p /sbin/ldconfig
96 %postun -p /sbin/ldconfig
97
98 %files
99 %defattr(644,root,root,755)
100 %doc doc/{changelog.txt,faq.txt,license.txt,literature.txt,readme.txt}
101 %attr(755,root,root) %{_bindir}/corconvert
102 %attr(755,root,root) %{_libdir}/libcorona-*.so
103
104 %files devel
105 %defattr(644,root,root,755)
106 %doc doc/tutorial.txt
107 %attr(755,root,root) %{_bindir}/corona-config
108 %attr(755,root,root) %{_libdir}/libcorona.so
109 %{_libdir}/libcorona.la
110 %{_includedir}/corona.h
111
112 %files static
113 %defattr(644,root,root,755)
114 %{_libdir}/libcorona.a
This page took 0.094138 seconds and 2 git commands to generate.