]> git.pld-linux.org Git - packages/corona.git/blame - corona.spec
- release 5
[packages/corona.git] / corona.spec
CommitLineData
7d33202d
JB
1Summary: Image input/output library
2Summary(pl.UTF-8): Biblioteka wejścia/wyjścia dla obrazów
3Name: corona
4Version: 1.0.2
f721b3c6 5Release: 5
7d33202d
JB
6License: zlib
7Group: Libraries
8Source0: http://dl.sourceforge.net/corona/%{name}-%{version}.tar.gz
9# Source0-md5: 29d1a7f1e2c85a83e9620496c62740ce
10Patch0: %{name}-system-gif.patch
11Patch1: %{name}-config.patch
040626c1 12Patch2: %{name}-gcc43.patch
7d33202d
JB
13URL: http://corona.sourceforge.net/
14BuildRequires: autoconf
15BuildRequires: automake
3459428b 16BuildRequires: dos2unix
7d33202d
JB
17BuildRequires: giflib-devel >= 4.1.0
18BuildRequires: libjpeg-devel
19BuildRequires: libpng-devel
20BuildRequires: libstdc++-devel
21BuildRequires: libtool >= 2:1.5
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25Corona is an image input/output library that can read, write, and
26manipulate image files in just a few lines of code. It can write PNG
27and TGA files, and read PNG, JPEG, PCX, BMP, TGA, and GIF. Corona was
28designed to be easy to use, and exports a straightforward C++ API.
29With just a few lines of C++, you can add image loading to your
30application.
31
32%description -l pl.UTF-8
33Corona to biblioteka wejścia/wyjścia dla obrazów, potrafiąca czytać,
34zapisywać i obrabiać pliki obrazów w zaledwie kilku liniach kodu.
35Potrafi zapisywać pliki PNG i TGA, a czytać PNG, JPEG, PCX, BMP, TGA i
36GIF. Została zaprojektowana jako łatwa w użyciu i eksportuje
37bezpośrednie API C++. Za pomocą tylko kilku linii kodu C++ można dodać
38wczytywanie obrazów do swojej aplikacji.
39
40%package devel
41Summary: Header files for corona library
42Summary(pl.UTF-8): Pliki nagłówkowe biblioteki corona
43Group: Development/Libraries
44Requires: %{name} = %{version}-%{release}
45Requires: giflib-devel >= 4.1.0
46Requires: libjpeg-devel
47Requires: libpng-devel
48Requires: libstdc++-devel
49
50%description devel
51Header files for corona library.
52
53%description devel -l pl.UTF-8
54Pliki nagłówkowe biblioteki corona.
55
56%package static
57Summary: Static corona library
58Summary(pl.UTF-8): Statyczna biblioteka corona
59Group: Development/Libraries
60Requires: %{name}-devel = %{version}-%{release}
61
62%description static
63Static corona library.
64
65%description static -l pl.UTF-8
66Statyczna biblioteka corona.
67
68%prep
69%setup -q
70%patch0 -p1
71%patch1 -p1
c000d739 72dos2unix src/OpenTGA.cpp
040626c1 73%patch2 -p1
7d33202d
JB
74
75%build
76%{__libtoolize}
77%{__aclocal}
78%{__autoconf}
79%{__automake}
80%configure
81%{__make}
82
83%install
84rm -rf $RPM_BUILD_ROOT
85
86%{__make} install \
87 DESTDIR=$RPM_BUILD_ROOT
88
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%post -p /sbin/ldconfig
93%postun -p /sbin/ldconfig
94
95%files
96%defattr(644,root,root,755)
97%doc doc/{changelog.txt,faq.txt,license.txt,literature.txt,readme.txt}
98%attr(755,root,root) %{_bindir}/corconvert
99%attr(755,root,root) %{_libdir}/libcorona-*.so
100
101%files devel
102%defattr(644,root,root,755)
103%doc doc/tutorial.txt
104%attr(755,root,root) %{_bindir}/corona-config
105%attr(755,root,root) %{_libdir}/libcorona.so
106%{_libdir}/libcorona.la
107%{_includedir}/corona.h
108
109%files static
110%defattr(644,root,root,755)
111%{_libdir}/libcorona.a
This page took 0.175983 seconds and 4 git commands to generate.