]> git.pld-linux.org Git - packages/coreutils.git/commitdiff
- Changed the meaning of -n: it only sets the space between sentences, auto/th/coreutils-6_7-3
authorqrczak <qrczak@pld-linux.org>
Tue, 13 Feb 2007 16:35:01 +0000 (16:35 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  it doesn't imply -u.
- Release 3

Changed files:
    coreutils-fmt-wchars.patch -> 1.2
    coreutils.spec -> 1.120

coreutils-fmt-wchars.patch
coreutils.spec

index 099e38787322971e49fc5c32d53b52a3cfa6320f..5636a55d3f59ae0dad4ee505d875f990c8aa592f 100644 (file)
@@ -1,5 +1,5 @@
 --- coreutils-6.7/src/fmt.c.orig       2006-10-22 18:54:15.000000000 +0200
-+++ coreutils-6.7/src/fmt.c    2007-02-13 16:51:44.000000000 +0100
++++ coreutils-6.7/src/fmt.c    2007-02-13 17:20:22.000000000 +0100
 @@ -18,6 +18,7 @@
  /* Written by Ross Paterson <rap@doc.ic.ac.uk>.  */
  
  
  void
  usage (int status)
-@@ -289,6 +313,7 @@
+@@ -288,7 +312,8 @@
+            stdout);
        fputs (_("\
    -t, --tagged-paragraph    indentation of first line different from second\n\
-   -u, --uniform-spacing     one space between words, two after sentences\n\
-+  -n, --single-spacing      one space between words and after sentences\n\
+-  -u, --uniform-spacing     one space between words, two after sentences\n\
++  -u, --uniform-spacing     one space between words, two between sentences\n\
++  -n, --single-spaces       single spaces between sentences\n\
    -w, --width=WIDTH         maximum line width (default of 75 columns)\n\
  "), stdout);
        fputs (HELP_OPTION_DESCRIPTION, stdout);
    {"split-only", no_argument, NULL, 's'},
    {"tagged-paragraph", no_argument, NULL, 't'},
    {"uniform-spacing", no_argument, NULL, 'u'},
-+  {"single-spacing", no_argument, NULL, 'n'},
++  {"single-spaces", no_argument, NULL, 'n'},
    {"width", required_argument, NULL, 'w'},
    {GETOPT_HELP_OPTION_DECL},
    {GETOPT_VERSION_OPTION_DECL},
-@@ -334,8 +360,8 @@
+@@ -333,9 +359,10 @@
+   atexit (close_stdout);
  
    crown = tagged = split = uniform = false;
++  sentence_space = 2;
    max_width = WIDTH;
 -  prefix = "";
 -  prefix_length = prefix_lead_space = prefix_full_length = 0;
  
    if (argc > 1 && argv[1][0] == '-' && ISDIGIT (argv[1][1]))
      {
-@@ -348,7 +374,7 @@
+@@ -348,7 +375,7 @@
        argc--;
      }
  
                                 long_options, NULL))
         != -1)
      switch (optchar)
-@@ -374,6 +400,12 @@
-       case 'u':
+@@ -376,6 +403,10 @@
        uniform = true;
-+        sentence_space = 2;
-+      break;
-+
-+      case 'n':
-+      uniform = true;
-+        sentence_space = 1;
        break;
  
++      case 'n':
++        sentence_space = 1;
++      break;
++
        case 'w':
-@@ -440,26 +472,32 @@
+       max_width_option = optarg;
+       break;
+@@ -440,26 +471,32 @@
  }
  
  /* Trim space from the front and back of the string P, yielding the prefix,
  }
  
  /* read file F and send formatted output to stdout.  */
-@@ -528,24 +566,24 @@
+@@ -528,24 +565,24 @@
  static bool
  get_paragraph (FILE *f)
  {
        c = get_prefix (f);
      }
  
-@@ -601,23 +639,23 @@
+@@ -601,23 +638,23 @@
     that failed to match the prefix.  In the latter, C is \n or EOF.
     Return the character (\n or EOF) ending the line.  */
  
      }
    return c;
  }
-@@ -627,11 +665,11 @@
+@@ -627,11 +664,11 @@
     otherwise false.  */
  
  static bool
  }
  
  /* Read a line from input file F, given first non-blank character C
-@@ -642,11 +680,11 @@
+@@ -642,11 +679,11 @@
  
     Return the first non-blank character of the next line.  */
  
    WORD *end_of_word;
  
    end_of_parabuf = &parabuf[MAXCHARS];
-@@ -658,6 +696,7 @@
+@@ -658,6 +695,7 @@
        /* Scan word.  */
  
        word_limit->text = wptr;
        do
        {
          if (wptr == end_of_parabuf)
-@@ -666,10 +705,12 @@
+@@ -666,10 +704,12 @@
              flush_paragraph ();
            }
          *wptr++ = c;
        check_punctuation (word_limit);
  
        /* Scan inter-word space.  */
-@@ -677,48 +718,48 @@
+@@ -677,48 +717,48 @@
        start = in_column;
        c = get_space (f, c);
        word_limit->space = in_column - start;
        }
        c = get_space (f, c);
      }
-@@ -728,21 +769,21 @@
+@@ -728,21 +768,21 @@
  /* Read blank characters from input file F, starting with C, and keeping
     in_column up-to-date.  Return first non-blank character.  */
  
      }
  }
  
-@@ -751,9 +792,9 @@
+@@ -751,9 +791,9 @@
  static void
  check_punctuation (WORD *w)
  {
  
    w->paren = isopen (*start);
    w->punct = !! ispunct (fin);
-@@ -777,7 +818,9 @@
+@@ -777,7 +817,9 @@
  
    if (word_limit == word)
      {
        wptr = parabuf;
        return;
      }
-@@ -809,7 +852,8 @@
+@@ -809,7 +851,8 @@
    /* Copy text of words down to start of parabuf -- we use memmove because
       the source and target may overlap.  */
  
    shift = split_point->text - parabuf;
    wptr -= shift;
  
-@@ -833,53 +877,53 @@
+@@ -833,53 +876,53 @@
  fmt_paragraph (void)
  {
    WORD *start, *w;
  }
  
  /* Return the constant component of the cost of breaking before the
-@@ -904,33 +948,33 @@
+@@ -904,33 +947,33 @@
        else if ((this - 1)->punct)
        cost -= PUNCT_BONUS;
        else if (this > word + 1 && (this - 2)->final)
        cost += RAGGED_COST (n);
      }
    return cost;
-@@ -959,8 +1003,8 @@
+@@ -959,8 +1002,8 @@
  
    out_column = 0;
    put_space (prefix_indent);
    put_space (indent - out_column);
  
    endline = w->next_break - 1;
-@@ -970,8 +1014,8 @@
+@@ -970,8 +1013,8 @@
        put_space (w->space);
      }
    put_word (w);
  }
  
  /* Output to stdout the word W.  */
-@@ -979,13 +1023,13 @@
+@@ -979,13 +1022,13 @@
  static void
  put_word (WORD *w)
  {
  }
  
  /* Output to stdout SPACE spaces, or equivalent tabs.  */
-@@ -1002,13 +1046,13 @@
+@@ -1002,13 +1045,13 @@
        if (out_column + 1 < tab_target)
        while (out_column < tab_target)
          {
        out_column++;
      }
  }
+--- coreutils-6.7/po/pl.po~    2007-02-13 17:23:15.000000000 +0100
++++ coreutils-6.7/po/pl.po     2007-02-13 17:32:43.000000000 +0100
+@@ -3788,12 +3788,14 @@
+ #: src/fmt.c:289
+ msgid ""
+ "  -t, --tagged-paragraph    indentation of first line different from second\n"
+-"  -u, --uniform-spacing     one space between words, two after sentences\n"
++"  -u, --uniform-spacing     one space between words, two between sentences\n"
++"  -n, --single-spaces       single spaces between sentences\n"
+ "  -w, --width=WIDTH         maximum line width (default of 75 columns)\n"
+ msgstr ""
+ "  -t, --tagged-paragraph    wciêcie pierwszej linii inne ni¿ drugiej\n"
+ "  -u, --uniform-spacing     jedna spacja miêdzy s³owami, dwie miêdzy "
+ "zdaniami\n"
++"  -n, --single-spaces       pojedyncze spacje miêdzy zdaniami\n"
+ "  -w, --width=ILE           maksymalna szeroko¶æ linii (domy¶lnie 75 "
+ "kolumn)\n"
index cf2f6c5e037372836494ac4f5f0bca5b1fa8ff97..fa4ed275b48ad5f64a05e8788575bcea1c829a5c 100644 (file)
@@ -6,7 +6,7 @@ Summary:        GNU Core-utils - basic command line utilities
 Summary(pl.UTF-8):     GNU Core-utils - podstawowe narzędzia działające z linii poleceń
 Name:          coreutils
 Version:       6.7
-Release:       2
+Release:       3
 License:       GPL
 Group:         Applications/System
 Source0:       ftp://ftp.gnu.org/gnu/coreutils/%{name}-%{version}.tar.bz2
This page took 0.05229 seconds and 4 git commands to generate.