]> git.pld-linux.org Git - packages/coreutils.git/commitdiff
up to 9.0 (rel 0.1 pl.po and info patches need update)
authorJan Palus <atler@pld-linux.org>
Mon, 27 Sep 2021 22:16:24 +0000 (00:16 +0200)
committerJan Palus <atler@pld-linux.org>
Mon, 27 Sep 2021 22:19:09 +0000 (00:19 +0200)
coreutils-8.32-ls-removed-dir.patch [deleted file]
coreutils-fmt-wchars.patch
coreutils.spec

diff --git a/coreutils-8.32-ls-removed-dir.patch b/coreutils-8.32-ls-removed-dir.patch
deleted file mode 100644 (file)
index 77dce89..0000000
+++ /dev/null
@@ -1,153 +0,0 @@
-From 8c022656320592dbad146f5d3a3ae1875f419446 Mon Sep 17 00:00:00 2001
-From: Paul Eggert <eggert@cs.ucla.edu>
-Date: Thu, 5 Mar 2020 17:25:29 -0800
-Subject: [PATCH 1/2] ls: restore 8.31 behavior on removed directories
-
-* NEWS: Mention this.
-* src/ls.c: Do not include <sys/sycall.h>
-(print_dir): Don't worry about whether the directory is removed.
-* tests/ls/removed-directory.sh: Adjust to match new (i.e., old)
-behavior.
-
-Upstream-commit: 10fcb97bd728f09d4a027eddf8ad2900f0819b0a
-Signed-off-by: Kamil Dudka <kdudka@redhat.com>
----
- src/ls.c                      | 22 ----------------------
- tests/ls/removed-directory.sh | 10 ++--------
- 2 files changed, 2 insertions(+), 30 deletions(-)
-
-diff --git a/src/ls.c b/src/ls.c
-index 9d25f62..850ecc2 100644
---- a/src/ls.c
-+++ b/src/ls.c
-@@ -49,10 +49,6 @@
- # include <sys/ptem.h>
- #endif
--#ifdef __linux__
--# include <sys/syscall.h>
--#endif
--
- #include <stdio.h>
- #include <assert.h>
- #include <setjmp.h>
-@@ -2896,7 +2892,6 @@ print_dir (char const *name, char const *realname, bool command_line_arg)
-   struct dirent *next;
-   uintmax_t total_blocks = 0;
-   static bool first = true;
--  bool found_any_entries = false;
-   errno = 0;
-   dirp = opendir (name);
-@@ -2972,7 +2967,6 @@ print_dir (char const *name, char const *realname, bool command_line_arg)
-       next = readdir (dirp);
-       if (next)
-         {
--          found_any_entries = true;
-           if (! file_ignored (next->d_name))
-             {
-               enum filetype type = unknown;
-@@ -3018,22 +3012,6 @@ print_dir (char const *name, char const *realname, bool command_line_arg)
-           if (errno != EOVERFLOW)
-             break;
-         }
--#ifdef __linux__
--      else if (! found_any_entries)
--        {
--          /* If readdir finds no directory entries at all, not even "." or
--             "..", then double check that the directory exists.  */
--          if (syscall (SYS_getdents, dirfd (dirp), NULL, 0) == -1
--              && errno != EINVAL)
--            {
--              /* We exclude EINVAL as that pertains to buffer handling,
--                 and we've passed NULL as the buffer for simplicity.
--                 ENOENT is returned if appropriate before buffer handling.  */
--              file_failure (command_line_arg, _("reading directory %s"), name);
--            }
--          break;
--        }
--#endif
-       else
-         break;
-diff --git a/tests/ls/removed-directory.sh b/tests/ls/removed-directory.sh
-index e8c835d..fe8f929 100755
---- a/tests/ls/removed-directory.sh
-+++ b/tests/ls/removed-directory.sh
-@@ -26,20 +26,14 @@ case $host_triplet in
-   *) skip_ 'non linux kernel' ;;
- esac
--LS_FAILURE=2
--
--cat <<\EOF >exp-err || framework_failure_
--ls: reading directory '.': No such file or directory
--EOF
--
- cwd=$(pwd)
- mkdir d || framework_failure_
- cd d || framework_failure_
- rmdir ../d || framework_failure_
--returns_ $LS_FAILURE ls >../out 2>../err || fail=1
-+ls >../out 2>../err || fail=1
- cd "$cwd" || framework_failure_
- compare /dev/null out || fail=1
--compare exp-err err || fail=1
-+compare /dev/null err || fail=1
- Exit $fail
--- 
-2.21.1
-
-
-From 847324a0debd9d12062c79e7a7a9d3d8ce76390d Mon Sep 17 00:00:00 2001
-From: Paul Eggert <eggert@cs.ucla.edu>
-Date: Sat, 7 Mar 2020 10:29:51 -0800
-Subject: [PATCH 2/2] ls: improve removed-directory test
-
-* tests/ls/removed-directory.sh: Remove host_triplet test.
-Skip this test if one cannot remove the working directory.
-From a suggestion by Bernhard Voelker (Bug#39929).
-
-Upstream-commit: 672819c73f2e94e61386dc0584bddf9da860cc26
-Signed-off-by: Kamil Dudka <kdudka@redhat.com>
----
- tests/ls/removed-directory.sh | 13 ++++---------
- 1 file changed, 4 insertions(+), 9 deletions(-)
-
-diff --git a/tests/ls/removed-directory.sh b/tests/ls/removed-directory.sh
-index fe8f929..63b209d 100755
---- a/tests/ls/removed-directory.sh
-+++ b/tests/ls/removed-directory.sh
-@@ -1,7 +1,7 @@
- #!/bin/sh
--# If ls is asked to list a removed directory (e.g. the parent process's
--# current working directory that has been removed by another process), it
--# emits an error message.
-+# If ls is asked to list a removed directory (e.g., the parent process's
-+# current working directory has been removed by another process), it
-+# should not emit an error message merely because the directory is removed.
- # Copyright (C) 2020 Free Software Foundation, Inc.
-@@ -21,15 +21,10 @@
- . "${srcdir=.}/tests/init.sh"; path_prepend_ ./src
- print_ver_ ls
--case $host_triplet in
--  *linux*) ;;
--  *) skip_ 'non linux kernel' ;;
--esac
--
- cwd=$(pwd)
- mkdir d || framework_failure_
- cd d || framework_failure_
--rmdir ../d || framework_failure_
-+rmdir ../d || skip_ "can't remove working directory on this platform"
- ls >../out 2>../err || fail=1
- cd "$cwd" || framework_failure_
--- 
-2.21.1
-
index 6f05bc178749ca25065e8703704a4c5ae900dc3c..64748ea0ad5e51d1d78f27f7cf9bb7bc0b9dd0a2 100644 (file)
@@ -97,9 +97,9 @@
  
      /* Static attributes determined during input.  */
  
--    const char *text;         /* the text of the word */
+-    char const *text;         /* the text of the word */
 -    int length;                       /* length of this word */
-+    const wchar_t *text;      /* the text of the word */
++    wchar_t const *text;      /* the text of the word */
 +    int length;                       /* length of this word, in characters */
 +    int width;                        /* width of this word, in columns */
      int space;                        /* the size of the following space */
    };
 @@ -154,16 +175,16 @@
  static void set_prefix (char *p);
- static void fmt (FILE *f);
+ static bool fmt (FILE *f, char const *);
  static bool get_paragraph (FILE *f);
 -static int get_line (FILE *f, int c);
 -static int get_prefix (FILE *f);
 +static int sentence_space;
 +
  /* Prefix minus leading and trailing spaces (default "").  */
--static const char *prefix;
+-static char const *prefix;
 +static wchar_t *prefix;
  
  /* User-supplied maximum line width (default WIDTH).  The only output
 +  *s = L'\0';
  }
  
- /* read file F and send formatted output to stdout.  */
+ /* Read F and send formatted output to stdout.
 @@ -550,24 +587,24 @@
  static bool
  get_paragraph (FILE *f)
 +static wint_t
 +copy_rest (FILE *f, wint_t c)
  {
--  const char *s;
-+  const wchar_t *s;
+-  char const *s;
++  wchar_t const *s;
  
    out_column = 0;
 -  if (in_column > next_prefix_indent || (c != '\n' && c != EOF))
        prefix_lead_space : in_column;
    else
      {
--      const char *p;
-+      const wchar_t *p;
+-      char const *p;
++      wchar_t const *p;
        next_prefix_indent = in_column;
 -      for (p = prefix; *p != '\0'; p++)
 +      for (p = prefix; *p != L'\0'; p++)
  static void
  put_word (WORD *w)
  {
--  const char *s;
-+  const wchar_t *s;
+-  char const *s;
++  wchar_t const *s;
    int n;
  
    s = w->text;
index 0cab6cd044a9a0f49f959dff81f77e42d5479e13..8fd8661120dc20b01de07609e3afd4a5c30ed916 100644 (file)
@@ -7,12 +7,12 @@
 Summary:       GNU Core-utils - basic command line utilities
 Summary(pl.UTF-8):     GNU Core-utils - podstawowe narzędzia działające z linii poleceń
 Name:          coreutils
-Version:       8.32
-Release:       1
+Version:       9.0
+Release:       0.1
 License:       GPL v3+
 Group:         Applications/System
 Source0:       http://ftp.gnu.org/gnu/coreutils/%{name}-%{version}.tar.xz
-# Source0-md5: 022042695b7d5bcf1a93559a9735e668
+# Source0-md5: 0d79ae8a6124546e3b94171375e5e5d0
 Source1:       %{name}-non-english-man-pages.tar.bz2
 # Source1-md5: f7c986ebc74ccb8d08ed70141063f14c
 Source2:       DIR_COLORS
@@ -25,7 +25,6 @@ Patch0:               %{name}-info.patch
 Patch1:                %{name}-getgid.patch
 Patch2:                %{name}-uname-cpuinfo.patch
 Patch3:                %{name}-date-man.patch
-Patch4:                %{name}-8.32-ls-removed-dir.patch
 
 Patch6:                %{name}-fmt-wchars.patch
 Patch7:                %{name}-sparc64.patch
@@ -113,7 +112,6 @@ Programy zawarte w tym pakiecie to:
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
 
 %patch6 -p1
 %ifarch sparc64
@@ -175,7 +173,8 @@ build-aux/gen-lists-of-programs.sh --automake > src/cu-progs.mk
        %{?with_multicall:--enable-single-binary=symlinks} \
        --disable-silent-rules \
        --enable-install-program=arch \
-       --enable-no-install-program=hostname,kill,uptime
+       --enable-no-install-program=hostname,kill,uptime \
+       --disable-year2038
 
 %{__make} -j1
 
This page took 0.09068 seconds and 4 git commands to generate.