]> git.pld-linux.org Git - packages/coreutils.git/commitdiff
- up to 7.6 auto/th/coreutils-7_6-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 12 Sep 2009 18:31:21 +0000 (18:31 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    coreutils-7.4-sttytcsadrain.patch -> 1.2
    coreutils-fmt-wchars.patch -> 1.6
    coreutils-pam.patch -> 1.14
    coreutils-runuser.patch -> 1.11
    coreutils-uname-cpuinfo.patch -> 1.5
    coreutils.spec -> 1.153

coreutils-7.4-sttytcsadrain.patch
coreutils-fmt-wchars.patch
coreutils-pam.patch
coreutils-runuser.patch
coreutils-uname-cpuinfo.patch
coreutils.spec

index af25979515ffe8a1d580661ece3eb6375522dc41..9ebeb5c7ccb17dc393146b30cdd9e8553cbd8172 100644 (file)
@@ -2,11 +2,11 @@ diff -urNp coreutils-7.4-orig/src/stty.c coreutils-7.4/src/stty.c
 --- coreutils-7.4-orig/src/stty.c      2009-04-24 14:41:19.000000000 +0200
 +++ coreutils-7.4/src/stty.c   2009-06-11 10:15:41.000000000 +0200
 @@ -1001,7 +1001,7 @@ main (int argc, char **argv)
-        spurious difference in an uninitialized portion of the structure.  */
+         spurious difference in an uninitialized portion of the structure.  */
        DECLARE_ZEROED_AGGREGATE (struct termios, new_mode);
  
 -      if (tcsetattr (STDIN_FILENO, TCSADRAIN, &mode))
 +      if (tcsetattr (STDIN_FILENO, TCSANOW, &mode))
-       error (EXIT_FAILURE, errno, "%s", device_name);
+         error (EXIT_FAILURE, errno, "%s", device_name);
  
        /* POSIX (according to Zlotnick's book) tcsetattr returns zero if
index b9d2f40402656a5521f5f5b30428662190dec676..3b636b07fe20f16fe95b7196d6d343cd0bef11ba 100644 (file)
@@ -1,6 +1,26 @@
---- coreutils-6.7/src/fmt.c.orig       2006-10-22 18:54:15.000000000 +0200
-+++ coreutils-6.7/src/fmt.c    2007-02-13 17:20:22.000000000 +0100
-@@ -18,6 +18,7 @@
+diff -ur coreutils-7.6.org/po/pl.po coreutils-7.6/po/pl.po
+--- coreutils-7.6.org/po/pl.po 2009-09-12 20:25:34.788233704 +0200
++++ coreutils-7.6/po/pl.po     2009-09-12 20:25:11.898026716 +0200
+@@ -4202,12 +4202,14 @@
+ #: src/fmt.c:285
+ msgid ""
+ "  -t, --tagged-paragraph    indentation of first line different from second\n"
+-"  -u, --uniform-spacing     one space between words, two after sentences\n"
++"  -u, --uniform-spacing     one space between words, two between sentences\n"
++"  -n, --single-spaces       single spaces between sentences\n"
+ "  -w, --width=WIDTH         maximum line width (default of 75 columns)\n"
+ msgstr ""
+ "  -t, --tagged-paragraph    wcięcie pierwszej linii inne niż drugiej\n"
+ "  -u, --uniform-spacing     jedna spacja między słowami, dwie między "
+ "zdaniami\n"
++"  -n, --single-spaces       pojedyncze spacje między zdaniami\n"
+ "  -w, --width=ILE           maksymalna szerokość linii (domyślnie 75 "
+ "kolumn)\n"
+diff -ur coreutils-7.6.org/src/fmt.c coreutils-7.6/src/fmt.c
+--- coreutils-7.6.org/src/fmt.c        2009-09-01 13:01:16.000000000 +0200
++++ coreutils-7.6/src/fmt.c    2009-09-12 20:25:11.894693234 +0200
+@@ -17,6 +17,7 @@
  /* Written by Ross Paterson <rap@doc.ic.ac.uk>.  */
  
  #include <config.h>
@@ -8,7 +28,7 @@
  #include <stdio.h>
  #include <sys/types.h>
  #include <getopt.h>
-@@ -39,7 +40,7 @@
+@@ -38,7 +39,7 @@
  /* The following parameters represent the program's idea of what is
     "best".  Adjust to taste, subject to the caveats given.  */
  
@@ -17,7 +37,7 @@
  #define WIDTH 75
  
  /* Prefer lines to be LEEWAY % shorter than the maximum width, giving
-@@ -51,7 +52,7 @@
+@@ -50,7 +51,7 @@
  #define DEF_INDENT 3
  
  /* Costs and bonuses are expressed as the equivalent departure from the
@@ -26,7 +46,7 @@
     cost of 50 means that it is as bad as a line 5 characters too short
     or too long.  The definition of SHORT_COST(n) should not be changed.
     However, EQUIV(n) may need tuning.  */
-@@ -78,11 +79,11 @@
+@@ -77,11 +78,11 @@
  #define LINE_COST     EQUIV (70)
  
  /* Cost of breaking a line after the first word of a sentence, where
@@ -40,7 +60,7 @@
  #define ORPHAN_COST(n)        (EQUIV (150) / ((n) + 2))
  
  /* Bonus for breaking a line at the end of a sentence.  */
-@@ -114,11 +115,30 @@
+@@ -113,11 +114,30 @@
  #define MAXWORDS      1000
  #define MAXCHARS      5000
  
@@ -74,7 +94,7 @@
  
  /* Size of a tab stop, for expansion on input and re-introduction on
     output.  */
-@@ -133,8 +153,9 @@
+@@ -132,8 +152,9 @@
  
      /* Static attributes determined during input.  */
  
      int space;                        /* the size of the following space */
      unsigned int paren:1;     /* starts with open paren */
      unsigned int period:1;    /* ends in [.?!])* */
-@@ -143,7 +164,7 @@
+@@ -142,7 +163,7 @@
  
      /* The remaining fields are computed during the optimization.  */
  
      COST best_cost;           /* cost of best paragraph starting here */
      WORD *next_break;         /* break which achieves best_cost */
    };
-@@ -153,16 +174,16 @@
+@@ -152,16 +173,16 @@
  static void set_prefix (char *p);
  static void fmt (FILE *f);
  static bool get_paragraph (FILE *f);
  static void put_paragraph (WORD *finish);
  static void put_line (WORD *w, int indent);
  static void put_word (WORD *w);
-@@ -185,8 +206,11 @@
+@@ -181,8 +202,11 @@
  /* If true, don't preserve inter-word spacing (default false).  */
  static bool uniform;
  
  
  /* User-supplied maximum line width (default WIDTH).  The only output
     lines longer than this will each comprise a single word.  */
-@@ -194,14 +218,14 @@
+@@ -190,14 +214,14 @@
  
  /* Values derived from the option values.  */
  
  
  /* The preferred width of text lines, set to LEEWAY % less than max_width.  */
  static int best_width;
-@@ -216,10 +240,10 @@
+@@ -212,10 +236,10 @@
  
  /* Space for the paragraph text -- longer paragraphs are handled neatly
     (cf. flush_paragraph()).  */
  
  /* The words of a paragraph -- longer paragraphs are handled neatly
     (cf. flush_paragraph()).  */
-@@ -251,16 +275,16 @@
+@@ -247,16 +271,16 @@
     prefix (next_prefix_indent).  See get_paragraph() and copy_rest().  */
  
  /* The last character read from the input file.  */
  
  void
  usage (int status)
-@@ -288,7 +312,8 @@
-            stdout);
+@@ -284,7 +308,8 @@
+              stdout);
        fputs (_("\
    -t, --tagged-paragraph    indentation of first line different from second\n\
 -  -u, --uniform-spacing     one space between words, two after sentences\n\
    -w, --width=WIDTH         maximum line width (default of 75 columns)\n\
  "), stdout);
        fputs (HELP_OPTION_DESCRIPTION, stdout);
-@@ -311,6 +336,7 @@
+@@ -307,6 +332,7 @@
    {"split-only", no_argument, NULL, 's'},
    {"tagged-paragraph", no_argument, NULL, 't'},
    {"uniform-spacing", no_argument, NULL, 'u'},
    {"width", required_argument, NULL, 'w'},
    {GETOPT_HELP_OPTION_DECL},
    {GETOPT_VERSION_OPTION_DECL},
-@@ -333,9 +359,10 @@
+@@ -329,9 +355,10 @@
    atexit (close_stdout);
  
    crown = tagged = split = uniform = false;
  
    if (argc > 1 && argv[1][0] == '-' && ISDIGIT (argv[1][1]))
      {
-@@ -348,7 +375,7 @@
+@@ -344,7 +371,7 @@
        argc--;
      }
  
 -  while ((optchar = getopt_long (argc, argv, "0123456789cstuw:p:",
 +  while ((optchar = getopt_long (argc, argv, "0123456789cstunw:p:",
-                                long_options, NULL))
-        != -1)
+                                  long_options, NULL))
+          != -1)
      switch (optchar)
-@@ -376,6 +403,10 @@
-       uniform = true;
-       break;
+@@ -372,6 +399,10 @@
+         uniform = true;
+         break;
  
 +      case 'n':
 +        sentence_space = 1;
-+      break;
++        break;
 +
        case 'w':
-       max_width_option = optarg;
-       break;
-@@ -440,26 +471,32 @@
+         max_width_option = optarg;
+         break;
+@@ -436,26 +467,32 @@
  }
  
  /* Trim space from the front and back of the string P, yielding the prefix,
  }
  
  /* read file F and send formatted output to stdout.  */
-@@ -528,24 +565,24 @@
+@@ -524,24 +561,24 @@
  static bool
  get_paragraph (FILE *f)
  {
  
 -  while (c == '\n' || c == EOF
 +  while (c == L'\n' || c == WEOF
-        || next_prefix_indent < prefix_lead_space
--       || in_column < next_prefix_indent + prefix_full_length)
-+       || in_column < next_prefix_indent + prefix_full_width)
+          || next_prefix_indent < prefix_lead_space
+-         || in_column < next_prefix_indent + prefix_full_length)
++         || in_column < next_prefix_indent + prefix_full_width)
      {
        c = copy_rest (f, c);
 -      if (c == EOF)
 +      if (c == WEOF)
-       {
--        next_char = EOF;
-+        next_char = WEOF;
-         return false;
-       }
+         {
+-          next_char = EOF;
++          next_char = WEOF;
+           return false;
+         }
 -      putchar ('\n');
 +      putwchar (L'\n');
        c = get_prefix (f);
      }
  
-@@ -601,26 +638,26 @@
+@@ -597,26 +634,26 @@
     that failed to match the prefix.  In the latter, C is \n or EOF.
     Return the character (\n or EOF) ending the line.  */
  
      {
        put_space (next_prefix_indent);
        for (s = prefix; out_column != in_column && *s; out_column++)
--      putchar (*s++);
+-        putchar (*s++);
 -      if (c != EOF && c != '\n')
-+      putwchar (*s++);
++        putwchar (*s++);
 +      if (c != WEOF && c != L'\n')
-       put_space (in_column - out_column);
+         put_space (in_column - out_column);
 -      if (c == EOF && in_column >= next_prefix_indent + prefix_length)
--      putchar ('\n');
+-        putchar ('\n');
 +      if (c == WEOF && in_column >= next_prefix_indent + prefix_width)
-+      putwchar (L'\n');
++        putwchar (L'\n');
      }
 -  while (c != '\n' && c != EOF)
 +  while (c != L'\n' && c != WEOF)
      }
    return c;
  }
-@@ -627,11 +664,11 @@
+@@ -626,11 +663,11 @@
     otherwise false.  */
  
  static bool
 +same_para (wint_t c)
  {
    return (next_prefix_indent == prefix_indent
--        && in_column >= next_prefix_indent + prefix_full_length
--        && c != '\n' && c != EOF);
-+        && in_column >= next_prefix_indent + prefix_full_width
-+        && c != L'\n' && c != WEOF);
+-          && in_column >= next_prefix_indent + prefix_full_length
+-          && c != '\n' && c != EOF);
++          && in_column >= next_prefix_indent + prefix_full_width
++          && c != L'\n' && c != WEOF);
  }
  
  /* Read a line from input file F, given first non-blank character C
-@@ -642,11 +679,11 @@
+@@ -641,11 +678,11 @@
  
     Return the first non-blank character of the next line.  */
  
    WORD *end_of_word;
  
    end_of_parabuf = &parabuf[MAXCHARS];
-@@ -658,6 +695,7 @@
+@@ -657,6 +694,7 @@
        /* Scan word.  */
  
        word_limit->text = wptr;
 +      word_limit->width = 0;
        do
-       {
-         if (wptr == end_of_parabuf)
-@@ -666,10 +704,12 @@
-             flush_paragraph ();
-           }
-         *wptr++ = c;
--        c = getc (f);
+         {
+           if (wptr == end_of_parabuf)
+@@ -665,10 +703,12 @@
+               flush_paragraph ();
+             }
+           *wptr++ = c;
+-          c = getc (f);
 +          word_limit->width += xwcwidth (c);
-+        c = xgetwc (f);
-       }
++          c = xgetwc (f);
+         }
 -      while (c != EOF && !isspace (c));
 -      in_column += word_limit->length = wptr - word_limit->text;
 +      while (c != WEOF && !isspace (c));
        check_punctuation (word_limit);
  
        /* Scan inter-word space.  */
-@@ -677,46 +717,46 @@
+@@ -676,11 +716,11 @@
        start = in_column;
        c = get_space (f, c);
        word_limit->space = in_column - start;
 -      word_limit->final = (c == EOF
 +      word_limit->final = (c == WEOF
-                          || (word_limit->period
--                             && (c == '\n' || word_limit->space > 1)));
+                            || (word_limit->period
+-                               && (c == '\n' || word_limit->space > 1)));
 -      if (c == '\n' || c == EOF || uniform)
--      word_limit->space = word_limit->final ? 2 : 1;
-+                             && (c == L'\n' || word_limit->space > 1)));
+-        word_limit->space = word_limit->final ? 2 : 1;
++                           && (c == L'\n' || word_limit->space > 1)));
 +      if (c == L'\n' || c == WEOF || uniform)
-+      word_limit->space = word_limit->final ? sentence_space : 1;
++        word_limit->space = word_limit->final ? sentence_space : 1;
        if (word_limit == end_of_word)
-       {
-         set_other_indent (true);
-         flush_paragraph ();
-       }
+         {
+           set_other_indent (true);
+@@ -688,34 +728,34 @@
+         }
        word_limit++;
      }
 -  while (c != '\n' && c != EOF);
        next_prefix_indent = in_column;
 -      for (p = prefix; *p != '\0'; p++)
 +      for (p = prefix; *p != L'\0'; p++)
-       {
--        unsigned char pc = *p;
-+        wchar_t pc = *p;
-         if (c != pc)
-           return c;
-         in_column++;
--        c = getc (f);
-+        c = xgetwc (f);
-       }
+         {
+-          unsigned char pc = *p;
++          wchar_t pc = *p;
+           if (c != pc)
+             return c;
+           in_column++;
+-          c = getc (f);
++          c = xgetwc (f);
+         }
        c = get_space (f, c);
      }
-@@ -728,21 +768,21 @@
+@@ -725,21 +765,21 @@
  /* Read blank characters from input file F, starting with C, and keeping
     in_column up-to-date.  Return first non-blank character.  */
  
      {
 -      if (c == ' ')
 +      if (c == L' ')
-       in_column++;
+         in_column++;
 -      else if (c == '\t')
 +      else if (c == L'\t')
-       {
-         tabs = true;
-         in_column = (in_column / TABWIDTH + 1) * TABWIDTH;
-       }
+         {
+           tabs = true;
+           in_column = (in_column / TABWIDTH + 1) * TABWIDTH;
+         }
        else
-       return c;
+         return c;
 -      c = getc (f);
 +      c = xgetwc (f);
      }
  }
  
-@@ -751,9 +791,9 @@
+@@ -748,9 +788,9 @@
  static void
  check_punctuation (WORD *w)
  {
  
    w->paren = isopen (*start);
    w->punct = !! ispunct (fin);
-@@ -777,7 +817,9 @@
+@@ -774,7 +814,9 @@
  
    if (word_limit == word)
      {
        wptr = parabuf;
        return;
      }
-@@ -809,7 +851,8 @@
+@@ -806,7 +848,8 @@
    /* Copy text of words down to start of parabuf -- we use memmove because
       the source and target may overlap.  */
  
    shift = split_point->text - parabuf;
    wptr -= shift;
  
-@@ -833,53 +876,53 @@
+@@ -830,53 +873,53 @@
  fmt_paragraph (void)
  {
    WORD *start, *w;
 -      len += w->length;
 +      wid += w->width;
        do
-       {
-         w++;
+         {
+           w++;
  
-         /* Consider breaking before w.  */
+           /* Consider breaking before w.  */
  
--        wcost = line_cost (w, len) + w->best_cost;
--        if (start == word && last_line_length > 0)
--          wcost += RAGGED_COST (len - last_line_length);
+-          wcost = line_cost (w, len) + w->best_cost;
+-          if (start == word && last_line_length > 0)
+-            wcost += RAGGED_COST (len - last_line_length);
 +        wcost = line_cost (w, wid) + w->best_cost;
 +        if (start == word && last_line_width > 0)
 +          wcost += RAGGED_COST (wid - last_line_width);
-         if (wcost < best)
-           {
-             best = wcost;
-             start->next_break = w;
--            start->line_length = len;
+           if (wcost < best)
+             {
+               best = wcost;
+               start->next_break = w;
+-              start->line_length = len;
 +            start->line_width = wid;
-           }
+             }
  
--        /* This is a kludge to keep us from computing `len' as the
--           sum of the sentinel length and some non-zero number.
--           Since the sentinel w->length may be INT_MAX, adding
+-          /* This is a kludge to keep us from computing `len' as the
+-             sum of the sentinel length and some non-zero number.
+-             Since the sentinel w->length may be INT_MAX, adding
 +        /* This is a kludge to keep us from computing `wid' as the
 +           sum of the sentinel width and some non-zero number.
 +           Since the sentinel w->width may be INT_MAX, adding
-            to that would give a negative result.  */
-         if (w == word_limit)
-           break;
+              to that would give a negative result.  */
+           if (w == word_limit)
+             break;
  
--        len += (w - 1)->space + w->length;    /* w > start >= word */
+-          len += (w - 1)->space + w->length;  /* w > start >= word */
 +        wid += (w - 1)->space + w->width;     /* w > start >= word */
-       }
+         }
 -      while (len < max_width);
 +      while (wid < max_width);
        start->best_cost = best + base_cost (start);
  }
  
  /* Return the constant component of the cost of breaking before the
-@@ -904,33 +947,33 @@
+@@ -901,33 +944,33 @@
        else if ((this - 1)->punct)
-       cost -= PUNCT_BONUS;
+         cost -= PUNCT_BONUS;
        else if (this > word + 1 && (this - 2)->final)
--      cost += WIDOW_COST ((this - 1)->length);
+-        cost += WIDOW_COST ((this - 1)->length);
 +      cost += WIDOW_COST ((this - 1)->width);
      }
  
        cost += RAGGED_COST (n);
      }
    return cost;
-@@ -959,8 +1002,8 @@
+@@ -956,8 +999,8 @@
  
    out_column = 0;
    put_space (prefix_indent);
    put_space (indent - out_column);
  
    endline = w->next_break - 1;
-@@ -970,8 +1013,8 @@
+@@ -967,8 +1010,8 @@
        put_space (w->space);
      }
    put_word (w);
  }
  
  /* Output to stdout the word W.  */
-@@ -979,13 +1022,13 @@
+@@ -976,13 +1019,13 @@
  static void
  put_word (WORD *w)
  {
  }
  
  /* Output to stdout SPACE spaces, or equivalent tabs.  */
-@@ -1002,13 +1045,13 @@
+@@ -999,13 +1042,13 @@
        if (out_column + 1 < tab_target)
-       while (out_column < tab_target)
-         {
--          putchar ('\t');
+         while (out_column < tab_target)
+           {
+-            putchar ('\t');
 +          putwchar (L'\t');
-           out_column = (out_column / TABWIDTH + 1) * TABWIDTH;
-         }
+             out_column = (out_column / TABWIDTH + 1) * TABWIDTH;
+           }
      }
    while (out_column < space_target)
      {
        out_column++;
      }
  }
---- coreutils-6.7/po/pl.po~    2007-02-13 17:23:15.000000000 +0100
-+++ coreutils-6.7/po/pl.po     2007-02-13 17:32:43.000000000 +0100
-@@ -3788,12 +3788,14 @@
- #: src/fmt.c:289
- msgid ""
- "  -t, --tagged-paragraph    indentation of first line different from second\n"
--"  -u, --uniform-spacing     one space between words, two after sentences\n"
-+"  -u, --uniform-spacing     one space between words, two between sentences\n"
-+"  -n, --single-spaces       single spaces between sentences\n"
- "  -w, --width=WIDTH         maximum line width (default of 75 columns)\n"
- msgstr ""
- "  -t, --tagged-paragraph    wcięcie pierwszej linii inne niż drugiej\n"
- "  -u, --uniform-spacing     jedna spacja między słowami, dwie między "
- "zdaniami\n"
-+"  -n, --single-spaces       pojedyncze spacje między zdaniami\n"
- "  -w, --width=ILE           maksymalna szerokość linii (domyślnie 75 "
- "kolumn)\n"
index c4f3cd5e42087fb8bc99d0a7ce9089ae95bec0fb..98ecce23062a18bb05d41cf6133f5b2b280ad942 100644 (file)
 +      char const *display = getenv ("DISPLAY");
 +      char const *xauthority = getenv ("XAUTHORITY");
        if (term)
-       term = xstrdup (term);
+         term = xstrdup (term);
        environ = xmalloc ((6 + !!term) * sizeof (char *));
        environ[0] = NULL;
        if (term)
-       xsetenv ("TERM", term);
+         xsetenv ("TERM", term);
 +      if (display)
-+      xsetenv ("DISPLAY", display);
++        xsetenv ("DISPLAY", display);
 +      if (xauthority)
-+      xsetenv ("XAUTHORITY", xauthority);
++        xsetenv ("XAUTHORITY", xauthority);
        xsetenv ("HOME", pw->pw_dir);
        xsetenv ("SHELL", shell);
        xsetenv ("USER", pw->pw_name);
  
  static void
  run_shell (char const *shell, char const *command, char **additional_args,
--         size_t n_additional_args)
-+         size_t n_additional_args, const struct passwd *pw)
+-           size_t n_additional_args)
++           size_t n_additional_args, const struct passwd *pw)
  {
    size_t n_args = 1 + fast_startup + 2 * !!command + n_additional_args + 1;
    char const **args = xnmalloc (n_args, sizeof *args);
index 9f14db3af3961d47532a893d9cb6b09653362499..a25a51587ee48faad4608c2a2889bc2250215a32 100644 (file)
  
  static void
  run_shell (char const *shell, char const *command, char **additional_args,
--         size_t n_additional_args, const struct passwd *pw)
-+         size_t n_additional_args, const struct passwd *pw
+-           size_t n_additional_args, const struct passwd *pw)
++           size_t n_additional_args, const struct passwd *pw
 +#ifdef RUNUSER
-+         , gid_t *groups, int num_groups
++           , gid_t *groups, int num_groups
 +#endif
-+      )
++  )
  {
    size_t n_args = 1 + fast_startup + 2 * !!command + n_additional_args + 1;
    char const **args = xnmalloc (n_args, sizeof *args);
        switch (optc)
        {
 @@ -701,6 +756,28 @@
-         shell = optarg;
-         break;
+           shell = optarg;
+           break;
  
 +#ifdef RUNUSER
 +      case 'g':
 +        break;
 +#endif
 +
-       case_GETOPT_HELP_CHAR;
+         case_GETOPT_HELP_CHAR;
  
-       case_GETOPT_VERSION_CHAR (PROGRAM_NAME, AUTHORS);
+         case_GETOPT_VERSION_CHAR (PROGRAM_NAME, AUTHORS);
 @@ -739,7 +816,20 @@
-                         : DEFAULT_SHELL);
+                           : DEFAULT_SHELL);
    endpwent ();
  
 -  if (!correct_password (pw))
index 23edca8b8bb217c2f85f313f0096407544e15972..853be2b0d90d05e82d0ee8123bb5232d146845b9 100644 (file)
@@ -16,9 +16,9 @@ diff -urN coreutils-5.2.1-orig/src/uname.c coreutils-5.2.1/src/uname.c
        char const *element = unknown;
 -#if HAVE_SYSINFO && defined SI_ARCHITECTURE
 -      {
--      static char processor[257];
--      if (0 <= sysinfo (SI_ARCHITECTURE, processor, sizeof processor))
--        element = processor;
+-        static char processor[257];
+-        if (0 <= sysinfo (SI_ARCHITECTURE, processor, sizeof processor))
+-          element = processor;
 -      }
 -#endif
 +      char processor[BUFSIZ];
index f3c38162afa532d36f5a692b7a33177065cdfe5c..7a61e43c0a142d0383db9b30237a2fb166b77427 100644 (file)
@@ -2,12 +2,12 @@
 Summary:       GNU Core-utils - basic command line utilities
 Summary(pl.UTF-8):     GNU Core-utils - podstawowe narzędzia działające z linii poleceń
 Name:          coreutils
-Version:       7.5
+Version:       7.6
 Release:       1
 License:       GPL v3+
 Group:         Applications/System
 Source0:       http://ftp.gnu.org/gnu/coreutils/%{name}-%{version}.tar.xz
-# Source0-md5: ca9219c5b7efa533d552f61a3880f458
+# Source0-md5: a9fb9368e40205d70fc37b9fe441e8ec
 Source1:       %{name}-non-english-man-pages.tar.bz2
 # Source1-md5: f7c986ebc74ccb8d08ed70141063f14c
 Source2:       DIR_COLORS
@@ -105,7 +105,7 @@ Programy zawarte w tym pakiecie to:
 
 %prep
 %setup -q -c -T -a1
-lzma -dc %{SOURCE0} | tar xf - -C ..
+xz -dc %{SOURCE0} | tar xf - -C ..
 # currently obsolete
 # %patch13 -p1
 # ?
This page took 0.179908 seconds and 4 git commands to generate.