]> git.pld-linux.org Git - packages/coreutils.git/blob - coreutils.spec
- removed obsolete utmp patch; more pending for update
[packages/coreutils.git] / coreutils.spec
1 #
2 # Conditional build:
3 %bcond_without  selinux         # build without SELinux support
4 #
5 Summary:        GNU Core-utils - basic command line utilities
6 Summary(pl):    GNU Core-utils - podstawowe narzêdzia dzia³aj±ce z linii poleceñ
7 Name:           coreutils
8 Version:        5.2.1
9 Release:        0.2
10 License:        GPL
11 Group:          Applications/System
12 # devel versions:
13 #Source0:       ftp://alpha.gnu.org/gnu/fetish/%{name}-%{version}.tar.bz2
14 # final versions:
15 Source0:        ftp://ftp.gnu.org/gnu/coreutils/%{name}-%{version}.tar.bz2
16 # Source0-md5:  172ee3c315af93d3385ddfbeb843c53f
17 Source1:        %{name}-non-english-man-pages.tar.bz2
18 # Source1-md5:  f7c986ebc74ccb8d08ed70141063f14c
19 Source2:        DIR_COLORS
20 Source3:        fileutils.sh
21 Source4:        fileutils.csh
22 Source5:        su.pamd
23 Patch0:         %{name}-info.patch
24 Patch1:         %{name}-pl.po-update.patch
25 Patch2:         %{name}-pam.patch
26 Patch3:         %{name}-getgid.patch
27 Patch4:         %{name}-su-paths.patch
28 Patch5:         %{name}-uname-cpuinfo.patch
29 Patch6:         %{name}-date-man.patch
30 Patch7:         %{name}-mem.patch
31 Patch8:         %{name}-install-C.patch
32 # NEEDS UPDATE
33 Patch9:         %{name}-po.patch
34 Patch10:        %{name}-no-nb.patch
35 # based on http://acl.bestbits.at/current/diff/fileutils-4.1.8acl-0.8.25.diff.gz
36 Patch11:        %{name}-acl-0.8.25.patch
37 Patch12:        %{name}-lsw.patch
38 Patch13:        %{name}-nanosleep.patch
39 Patch14:        %{name}-selinux.patch
40 # allow obsolete head/tail syntax when compiled on POSIX2.200112-compliant glibc
41 # (only if POSIXLY_CORRECT is not set in environment)
42 #Patch15:       %{name}-noposix2.patch
43 BuildRequires:  acl-devel
44 BuildRequires:  autoconf >= 2.58
45 BuildRequires:  automake >= 1.8
46 %{?with_selinux:BuildRequires:  gcc >= 5:3.2}
47 BuildRequires:  gettext-devel >= 0.11.5
48 BuildRequires:  help2man
49 BuildRequires:  pam-devel
50 BuildRequires:  texinfo >= 4.2
51 %{?with_selinux:BuildRequires:  libselinux-devel}
52 Requires:       pam >= 0.77.3
53 Provides:       fileutils
54 Provides:       sh-utils
55 Provides:       stat
56 Provides:       textutils
57 Obsoletes:      fileutils
58 Obsoletes:      sh-utils
59 Obsoletes:      stat
60 Obsoletes:      textutils
61 Conflicts:      shadow < 1:4.0.3-6
62 Conflicts:      tetex < 1:2.0.2
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 These are the GNU core utilities.  This package is the union of
67 the GNU fileutils, sh-utils, and textutils packages.
68
69 Most of these programs have significant advantages over their Unix
70 counterparts, such as greater speed, additional options, and fewer
71 arbitrary limits.
72
73 The programs that can be built with this package are:
74
75   basename cat chgrp chmod chown chroot cksum comm cp csplit cut date dd
76   df dir dircolors dirname du echo env expand expr factor false fmt fold
77   ginstall groups head hostid id join link ln logname ls md5sum mkdir
78   mkfifo mknod mv nice nl nohup od paste pathchk pinky pr printenv
79   printf ptx pwd rm rmdir seq sha1sum shred sleep sort split stat stty
80   su sum sync tac tail tee test touch tr true tsort tty uname unexpand
81   uniq unlink users vdir wc who whoami yes
82
83 %description -l pl
84 Narzêdzia podstawowe (core utilities) GNU to po³±czone paczki GNU
85 fileutils, sh-utils i textutils.
86
87 Wiêkszo¶æ z zawartych programów jest znacznie ulepszona w porównaniu
88 z ich uniksowymi odpowiednikami, np. szybciej dzia³aj±, maj± dodatkowe
89 opcje i mniej ograniczeñ.
90
91 Programy zawarte w tym pakiecie to:
92
93   basename cat chgrp chmod chown chroot cksum comm cp csplit cut date dd
94   df dir dircolors dirname du echo env expand expr factor false fmt fold
95   ginstall groups head hostid id join link ln logname ls md5sum mkdir
96   mkfifo mknod mv nice nl nohup od paste pathchk pinky pr printenv
97   printf ptx pwd rm rmdir seq sha1sum shred sleep sort split stat stty
98   su sum sync tac tail tee test touch tr true tsort tty uname unexpand
99   uniq unlink users vdir wc who whoami yes
100
101 %prep
102 %setup -q -a1
103 %patch0 -p1
104 %patch1 -p1
105 %patch2 -p1
106 %patch3 -p1
107 %patch4 -p1
108 %patch5 -p1
109 %patch6 -p1
110 %patch7 -p1
111 %patch8 -p1
112 %patch9 -p1
113 %patch10 -p1
114 %patch11 -p1
115 %patch12 -p1
116 %patch13 -p1
117 %{?with_selinux:%patch14 -p1}
118
119 %{__perl} -pi -e 's@GNU/Linux@PLD Linux@' m4/host-os.m4
120
121 # no_NO is just an alias for nb_NO in recent glibc
122 # no.po is outdated, nb.po is more fresh here (see also patch10)
123 rm -f po/no.*
124
125 %build
126 # jm's inttypes.m4 and inttypes.m4 from gettext are really different files
127 mv -f m4/{inttypes.m4,jm-inttypes.m4}
128 %{__gettextize}
129 %{__aclocal} -I m4
130 %{__autoconf}
131 %{__autoheader}
132 %{__automake}
133 %configure \
134         DEFAULT_POSIX2_VERSION=199209 \
135         %{?with_selinux:--enable-selinux} \
136         --enable-pam
137
138 %{__make}
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142 install -d $RPM_BUILD_ROOT{/bin,%{_bindir},%{_sbindir},/etc/pam.d,/etc/profile.d}
143
144 %{__make} install \
145         DESTDIR=$RPM_BUILD_ROOT
146
147 rm -f $RPM_BUILD_ROOT%{_bindir}/{hostname,kill,uptime}
148 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{hostname,kill,uptime}.1*
149
150 ln -sf test $RPM_BUILD_ROOT%{_bindir}/[
151
152 mv -f $RPM_BUILD_ROOT%{_bindir}/{basename,cat,chgrp,chmod,chown,cp,date,dd,df,\
153 echo,false,id,link,ln,ls,mkdir,mknod,mv,nice,printf,pwd,rm,rmdir,sleep,sort,stty,\
154 sync,touch,true,unlink,uname} $RPM_BUILD_ROOT/bin
155
156 mv -f $RPM_BUILD_ROOT%{_bindir}/chroot $RPM_BUILD_ROOT%{_sbindir}
157
158 # su is missed by "make install"
159 install src/su $RPM_BUILD_ROOT/bin
160
161 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
162 install %{SOURCE3} %{SOURCE4} $RPM_BUILD_ROOT/etc/profile.d
163 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/su
164
165 mv -f man/pt_BR man/pt
166 for d in cs da de es fi fr hu id it ja ko nl pl pt ru zh_CN ; do
167         install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
168         install man/$d/*.1 $RPM_BUILD_ROOT%{_mandir}/$d/man1
169 done
170 rm -f $RPM_BUILD_ROOT%{_mandir}/*/man1/{hostname,kill,uptime}.1
171
172 %find_lang %{name}
173
174 %clean
175 rm -rf $RPM_BUILD_ROOT
176
177 %post
178 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
179
180 %postun
181 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
182
183 %files -f %{name}.lang
184 %defattr(644,root,root,755)
185 %doc AUTHORS ChangeLog NEWS README THANKS THANKS-to-translators TODO
186 %attr(755,root,root) /bin/[!s]*
187 %attr(755,root,root) /bin/s[!u]*
188 %attr(4755,root,root) /bin/su
189 %attr(755,root,root) %{_bindir}/*
190 %attr(755,root,root) %{_sbindir}/*
191 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/pam.d/su
192 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/DIR_COLORS
193 %attr(755,root,root) /etc/profile.d/*
194 %{_mandir}/man1/*
195 %lang(cs) %{_mandir}/cs/man1/*
196 %lang(da) %{_mandir}/da/man1/*
197 %lang(de) %{_mandir}/de/man1/*
198 %lang(es) %{_mandir}/es/man1/*
199 %lang(fi) %{_mandir}/fi/man1/*
200 %lang(fr) %{_mandir}/fr/man1/*
201 %lang(hu) %{_mandir}/hu/man1/*
202 %lang(id) %{_mandir}/id/man1/*
203 %lang(it) %{_mandir}/it/man1/*
204 %lang(ja) %{_mandir}/ja/man1/*
205 %lang(ko) %{_mandir}/ko/man1/*
206 %lang(nl) %{_mandir}/nl/man1/*
207 %lang(pl) %{_mandir}/pl/man1/*
208 %lang(pt) %{_mandir}/pt/man1/*
209 %lang(ru) %{_mandir}/ru/man1/*
210 %lang(zh_CN) %{_mandir}/zh_CN/man1/*
211 %{_infodir}/coreutils.info*
This page took 0.0773 seconds and 4 git commands to generate.