]> git.pld-linux.org Git - packages/coreutils.git/blob - coreutils.spec
- coreutils-fmt-wchars.patch: Added support for multibyte encodings
[packages/coreutils.git] / coreutils.spec
1 #
2 # Conditional build:
3 %bcond_without  selinux         # build without SELinux support
4 #
5 Summary:        GNU Core-utils - basic command line utilities
6 Summary(pl.UTF-8):      GNU Core-utils - podstawowe narzędzia działające z linii poleceń
7 Name:           coreutils
8 Version:        6.7
9 Release:        2
10 License:        GPL
11 Group:          Applications/System
12 Source0:        ftp://ftp.gnu.org/gnu/coreutils/%{name}-%{version}.tar.bz2
13 # Source0-md5:  a16465d0856cd011a1acc1c21040b7f4
14 Source1:        %{name}-non-english-man-pages.tar.bz2
15 # Source1-md5:  f7c986ebc74ccb8d08ed70141063f14c
16 Source2:        DIR_COLORS
17 Source3:        fileutils.sh
18 Source4:        fileutils.csh
19 Source5:        su.pamd
20 Patch0:         %{name}-info.patch
21 Patch1:         %{name}-pl.po-update.patch
22 Patch2:         %{name}-pam.patch
23 Patch3:         %{name}-getgid.patch
24 Patch4:         %{name}-su-paths.patch
25 Patch5:         %{name}-uname-cpuinfo.patch
26 Patch6:         %{name}-date-man.patch
27 Patch7:         %{name}-mem.patch
28 Patch8:         %{name}-install-C.patch
29 Patch9:         %{name}-po.patch
30 Patch10:        %{name}-no-nb.patch
31 Patch11:        %{name}-selinux.patch
32 Patch12:        %{name}-system-openat.patch
33 Patch13:        %{name}-fmt-wchars.patch
34 URL:            http://www.gnu.org/software/coreutils/
35 BuildRequires:  acl-devel
36 BuildRequires:  autoconf >= 2.60
37 BuildRequires:  automake >= 1:1.9.6
38 %{?with_selinux:BuildRequires:  gcc >= 5:3.2}
39 BuildRequires:  gettext-devel >= 0.16-2
40 BuildRequires:  help2man
41 %{?with_selinux:BuildRequires:  libselinux-devel}
42 BuildRequires:  pam-devel
43 BuildRequires:  texinfo >= 4.2
44 Requires:       pam >= 0.77.3
45 Requires:       setup >= 2.4.6-2
46 Provides:       fileutils
47 Provides:       sh-utils
48 Provides:       stat
49 Provides:       textutils
50 Obsoletes:      fileutils
51 Obsoletes:      sh-utils
52 Obsoletes:      stat
53 Obsoletes:      textutils
54 Conflicts:      shadow < 1:4.0.3-6
55 Conflicts:      tetex < 1:2.0.2
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %description
59 These are the GNU core utilities. This package is the union of the GNU
60 fileutils, sh-utils, and textutils packages.
61
62 Most of these programs have significant advantages over their Unix
63 counterparts, such as greater speed, additional options, and fewer
64 arbitrary limits.
65
66 The programs that can be built with this package are:
67
68   [ basename cat chgrp chmod chown chroot cksum comm cp csplit cut date
69   dd df dir dircolors dirname du echo env expand expr factor false fmt
70   fold install groups head hostid id join link ln logname ls md5sum
71   mkdir mkfifo mknod mv nice nl nohup od paste pathchk pinky pr printenv
72   printf ptx pwd rm rmdir seq sha1sum shred sleep sort split stat stty
73   su sum sync tac tail tee test touch tr true tsort tty uname unexpand
74   uniq unlink users vdir wc who whoami yes
75
76 %description -l pl.UTF-8
77 Narzędzia podstawowe (core utilities) GNU to połączone paczki GNU
78 fileutils, sh-utils i textutils.
79
80 Większość z zawartych programów jest znacznie ulepszona w porównaniu
81 z ich uniksowymi odpowiednikami, np. szybciej działają, mają dodatkowe
82 opcje i mniej ograniczeń.
83
84 Programy zawarte w tym pakiecie to:
85
86   [ basename cat chgrp chmod chown chroot cksum comm cp csplit cut date
87   dd df dir dircolors dirname du echo env expand expr factor false fmt
88   fold ginstall groups head hostid id join link ln logname ls md5sum
89   mkdir mkfifo mknod mv nice nl nohup od paste pathchk pinky pr printenv
90   printf ptx pwd rm rmdir seq sha1sum shred sleep sort split stat stty
91   su sum sync tac tail tee test touch tr true tsort tty uname unexpand
92   uniq unlink users vdir wc who whoami yes
93
94 %prep
95 %setup -q -a1
96 %patch0 -p1
97 %patch1 -p1
98 %patch2 -p1
99 %patch3 -p1
100 %patch4 -p1
101 %patch5 -p1
102 %patch6 -p1
103 %patch7 -p1
104 %patch8 -p1
105 %patch9 -p1
106 %patch10 -p1
107 %{?with_selinux:%patch11 -p1}
108 %patch12 -p1
109 %patch13 -p1
110
111 %{__perl} -pi -e 's@GNU/Linux@PLD Linux@' m4/host-os.m4
112
113 # no_NO is just an alias for nb_NO in recent glibc
114 # no.po is outdated, nb.po is more fresh here (see also patch10)
115 rm -f po/no.*
116 # allow rebuilding *.gmo
117 rm -f po/stamp-po
118
119 # missing, added to gettext.m4 by ./bootstrap
120 echo 'AC_DEFUN([gl_LOCK_EARLY],[])' > m4/gllock.m4
121
122 %build
123 %{__gettextize}
124 %{__aclocal} -I m4
125 %{__autoconf}
126 %{__autoheader}
127 %{__automake}
128 %configure \
129         CFLAGS="%{rpmcflags} -DSYSLOG_SUCCESS -DSYSLOG_FAILURE -DSYSLOG_NON_ROOT" \
130         DEFAULT_POSIX2_VERSION=199209 \
131         %{?with_selinux:--enable-selinux} \
132         --enable-pam
133
134 %{__make}
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138 install -d $RPM_BUILD_ROOT{/bin,%{_bindir},%{_sbindir},/etc/pam.d,/etc/shrc.d}
139
140 %{__make} install \
141         DESTDIR=$RPM_BUILD_ROOT
142
143 rm -f $RPM_BUILD_ROOT%{_bindir}/{hostname,kill,uptime}
144 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{hostname,kill,uptime}.1*
145
146 mv -f $RPM_BUILD_ROOT%{_bindir}/{basename,cat,chgrp,chmod,chown,cp,date,dd,df,\
147 echo,false,id,link,ln,ls,mkdir,mknod,mv,nice,printf,pwd,rm,rmdir,sleep,sort,stty,\
148 sync,touch,true,unlink,uname} $RPM_BUILD_ROOT/bin
149
150 mv -f $RPM_BUILD_ROOT%{_bindir}/chroot $RPM_BUILD_ROOT%{_sbindir}
151
152 # su is missed by "make install"
153 install src/su $RPM_BUILD_ROOT/bin
154
155 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
156 install %{SOURCE3} %{SOURCE4} $RPM_BUILD_ROOT/etc/shrc.d
157 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/su
158
159 cp -a man/pt_BR man/pt
160 for d in cs da de es fi fr hu id it ja ko nl pl pt ru zh_CN ; do
161         install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
162         install man/$d/*.1 $RPM_BUILD_ROOT%{_mandir}/$d/man1
163 done
164 rm -f $RPM_BUILD_ROOT%{_mandir}/*/man1/{hostname,kill,uptime}.1
165
166 %find_lang %{name}
167
168 %clean
169 rm -rf $RPM_BUILD_ROOT
170
171 %post
172 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
173
174 %postun
175 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
176
177 %files -f %{name}.lang
178 %defattr(644,root,root,755)
179 %doc AUTHORS ChangeLog NEWS README THANKS THANKS-to-translators TODO
180 %attr(755,root,root) /bin/[!s]*
181 %attr(755,root,root) /bin/s[!u]*
182 %attr(4755,root,root) /bin/su
183 %attr(755,root,root) %{_bindir}/*
184 %attr(755,root,root) %{_sbindir}/*
185 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/su
186 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/DIR_COLORS
187 /etc/shrc.d/*
188 %{_mandir}/man1/*
189 %lang(cs) %{_mandir}/cs/man1/*
190 %lang(da) %{_mandir}/da/man1/*
191 %lang(de) %{_mandir}/de/man1/*
192 %lang(es) %{_mandir}/es/man1/*
193 %lang(fi) %{_mandir}/fi/man1/*
194 %lang(fr) %{_mandir}/fr/man1/*
195 %lang(hu) %{_mandir}/hu/man1/*
196 %lang(id) %{_mandir}/id/man1/*
197 %lang(it) %{_mandir}/it/man1/*
198 %lang(ja) %{_mandir}/ja/man1/*
199 %lang(ko) %{_mandir}/ko/man1/*
200 %lang(nl) %{_mandir}/nl/man1/*
201 %lang(pl) %{_mandir}/pl/man1/*
202 %lang(pt) %{_mandir}/pt/man1/*
203 %lang(ru) %{_mandir}/ru/man1/*
204 %lang(zh_CN) %{_mandir}/zh_CN/man1/*
205 %{_infodir}/coreutils.info*
This page took 0.30125 seconds and 4 git commands to generate.