]> git.pld-linux.org Git - packages/coreutils.git/blob - coreutils.spec
- merged non-english-man-pages into one tarball and updated
[packages/coreutils.git] / coreutils.spec
1 #
2 # Conditional build:
3 %bcond_without  selinux         # build without SELinux support
4 #
5 Summary:        GNU Core-utils - basic command line utilities
6 Summary(pl):    GNU Core-utils - podstawowe narzêdzia dzia³aj±ce z linii poleceñ
7 Name:           coreutils
8 Version:        5.0
9 Release:        9
10 License:        GPL
11 Group:          Applications/System
12 # devel versions:
13 #Source0:       ftp://alpha.gnu.org/gnu/fetish/%{name}-%{version}.tar.bz2
14 # final versions:
15 Source0:        ftp://ftp.gnu.org/gnu/coreutils/%{name}-%{version}.tar.bz2
16 # Source0-md5:  94e5558ee2a65723d4840bfde2d323f0
17 Source1:        %{name}-non-english-man-pages.tar.bz2
18 # Source1-md5:  f7c986ebc74ccb8d08ed70141063f14c
19 Source2:        DIR_COLORS
20 Source3:        fileutils.sh
21 Source4:        fileutils.csh
22 Source5:        su.pamd
23 Patch0:         %{name}-info.patch
24 Patch1:         %{name}-pam.patch
25 Patch2:         %{name}-getgid.patch
26 Patch3:         %{name}-utmp.patch
27 Patch4:         %{name}-su-paths.patch
28 Patch5:         %{name}-uname-cpuinfo.patch
29 Patch6:         %{name}-date-man.patch
30 Patch7:         %{name}-mem.patch
31 Patch8:         %{name}-install-C.patch
32 Patch9:         %{name}-po.patch
33 Patch10:        %{name}-no-nb.patch
34 # based on http://acl.bestbits.at/current/diff/fileutils-4.1.8acl-0.8.25.diff.gz
35 Patch11:        %{name}-acl-0.8.25.patch
36 Patch12:        %{name}-lsw.patch
37 Patch13:        %{name}-nanosleep.patch
38 Patch14:        %{name}-selinux.patch
39 # allow obsolete head/tail syntax when compiled on POSIX2.200112-compliant glibc
40 # (only if POSIXLY_CORRECT is not set in environment)
41 Patch15:        %{name}-noposix2.patch
42 BuildRequires:  acl-devel
43 BuildRequires:  autoconf >= 2.56
44 BuildRequires:  automake >= 1.7
45 BuildRequires:  gettext-devel >= 0.11.5
46 BuildRequires:  help2man
47 BuildRequires:  pam-devel
48 BuildRequires:  texinfo >= 4.2
49 %{?with_selinux:BuildRequires:  libselinux-devel}
50 Requires:       pam >= 0.77.3
51 Provides:       fileutils
52 Provides:       sh-utils
53 Provides:       stat
54 Provides:       textutils
55 Obsoletes:      fileutils
56 Obsoletes:      sh-utils
57 Obsoletes:      stat
58 Obsoletes:      textutils
59 Conflicts:      shadow < 1:4.0.3-6
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %description
63 These are the GNU core utilities.  This package is the union of
64 the GNU fileutils, sh-utils, and textutils packages.
65
66 Most of these programs have significant advantages over their Unix
67 counterparts, such as greater speed, additional options, and fewer
68 arbitrary limits.
69
70 The programs that can be built with this package are:
71
72   basename cat chgrp chmod chown chroot cksum comm cp csplit cut date dd
73   df dir dircolors dirname du echo env expand expr factor false fmt fold
74   ginstall groups head hostid id join link ln logname ls md5sum mkdir
75   mkfifo mknod mv nice nl nohup od paste pathchk pinky pr printenv
76   printf ptx pwd rm rmdir seq sha1sum shred sleep sort split stat stty
77   su sum sync tac tail tee test touch tr true tsort tty uname unexpand
78   uniq unlink users vdir wc who whoami yes
79
80 %description -l pl
81 Narzêdzia podstawowe (core utilities) GNU to po³±czone paczki GNU
82 fileutils, sh-utils i textutils.
83
84 Wiêkszo¶æ z zawartych programów jest znacznie ulepszona w porównaniu
85 z ich uniksowymi odpowiednikami, np. szybciej dzia³aj±, maj± dodatkowe
86 opcje i mniej ograniczeñ.
87
88 Programy zawarte w tym pakiecie to:
89
90   basename cat chgrp chmod chown chroot cksum comm cp csplit cut date dd
91   df dir dircolors dirname du echo env expand expr factor false fmt fold
92   ginstall groups head hostid id join link ln logname ls md5sum mkdir
93   mkfifo mknod mv nice nl nohup od paste pathchk pinky pr printenv
94   printf ptx pwd rm rmdir seq sha1sum shred sleep sort split stat stty
95   su sum sync tac tail tee test touch tr true tsort tty uname unexpand
96   uniq unlink users vdir wc who whoami yes
97
98 %prep
99 %setup -q -a1
100 %patch0 -p1
101 %patch1 -p1
102 %patch2 -p1
103 %patch3 -p1
104 %patch4 -p1
105 %patch5 -p1
106 %patch6 -p1
107 %patch7 -p1
108 %patch8 -p1
109 %patch9 -p1
110 %patch10 -p1
111 %patch11 -p1
112 %patch12 -p1
113 %patch13 -p1
114 %{?with_selinux:%patch14 -p1}
115 %patch15 -p1
116
117 %{__perl} -pi -e 's@GNU/Linux@PLD Linux@' m4/host-os.m4
118
119 # no_NO is just an alias for nb_NO in recent glibc
120 # no.po is outdated, nb.po is more fresh here (see also patch10)
121 rm -f po/no.*
122
123 %build
124 # jm's inttypes.m4 and inttypes.m4 from gettext are really different files
125 mv -f m4/{inttypes.m4,jm-inttypes.m4}
126 %{__gettextize}
127 %{__aclocal} -I m4
128 %{__autoconf}
129 %{__autoheader}
130 %{__automake}
131 %configure \
132         %{?with_selinux:--enable-selinux} \
133         --enable-pam
134
135 %{__make}
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139 install -d $RPM_BUILD_ROOT{/bin,%{_bindir},%{_sbindir},/etc/pam.d,/etc/profile.d}
140
141 %{__make} install \
142         DESTDIR=$RPM_BUILD_ROOT
143
144 rm -f $RPM_BUILD_ROOT%{_bindir}/{hostname,kill,uptime}
145 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{uptime,hostname}.1*
146
147 ln -sf test $RPM_BUILD_ROOT%{_bindir}/[
148
149 mv -f $RPM_BUILD_ROOT%{_bindir}/{basename,cat,chgrp,chmod,chown,cp,date,dd,df,\
150 echo,false,id,link,ln,ls,mkdir,mknod,mv,nice,printf,pwd,rm,rmdir,sleep,sort,stty,\
151 sync,touch,true,unlink,uname} $RPM_BUILD_ROOT/bin
152
153 mv -f $RPM_BUILD_ROOT%{_bindir}/chroot $RPM_BUILD_ROOT%{_sbindir}
154
155 # su is missed by "make install"
156 install src/su $RPM_BUILD_ROOT/bin
157
158 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
159 install %{SOURCE3} %{SOURCE4} $RPM_BUILD_ROOT/etc/profile.d
160 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/su
161
162 mv -f man/pt_BR man/pt
163 for d in cs da de es fi fr hu id it ja ko nl pl pt ru zh_CN ; do
164         install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
165         install man/$d/*.1 $RPM_BUILD_ROOT%{_mandir}/$d/man1
166 done
167 rm -f $RPM_BUILD_ROOT%{_mandir}/*/man1/{hostname,kill,uptime}.1
168
169 %find_lang %{name}
170
171 %clean
172 rm -rf $RPM_BUILD_ROOT
173
174 %post
175 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
176
177 %postun
178 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
179
180 %files -f %{name}.lang
181 %defattr(644,root,root,755)
182 %doc AUTHORS ChangeLog NEWS README THANKS THANKS-to-translators TODO
183 %attr(755,root,root) /bin/[!s]*
184 %attr(755,root,root) /bin/s[!u]*
185 %attr(4755,root,root) /bin/su
186 %attr(755,root,root) %{_bindir}/*
187 %attr(755,root,root) %{_sbindir}/*
188 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/pam.d/su
189 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/DIR_COLORS
190 %attr(755,root,root) /etc/profile.d/*
191 %{_mandir}/man1/*
192 %lang(cs) %{_mandir}/cs/man1/*
193 %lang(da) %{_mandir}/da/man1/*
194 %lang(de) %{_mandir}/de/man1/*
195 %lang(es) %{_mandir}/es/man1/*
196 %lang(fi) %{_mandir}/fi/man1/*
197 %lang(fr) %{_mandir}/fr/man1/*
198 %lang(hu) %{_mandir}/hu/man1/*
199 %lang(id) %{_mandir}/id/man1/*
200 %lang(it) %{_mandir}/it/man1/*
201 %lang(ja) %{_mandir}/ja/man1/*
202 %lang(ko) %{_mandir}/ko/man1/*
203 %lang(nl) %{_mandir}/nl/man1/*
204 %lang(pl) %{_mandir}/pl/man1/*
205 %lang(pt) %{_mandir}/pt/man1/*
206 %lang(ru) %{_mandir}/ru/man1/*
207 %lang(zh_CN) %{_mandir}/zh_CN/man1/*
208 %{_infodir}/coreutils.info*
This page took 0.054637 seconds and 4 git commands to generate.