]> git.pld-linux.org Git - packages/coreutils.git/blob - coreutils.spec
- remove stamp-po to rebuild pl.gmo
[packages/coreutils.git] / coreutils.spec
1 #
2 # Conditional build:
3 %bcond_without  selinux         # build without SELinux support
4 #
5 Summary:        GNU Core-utils - basic command line utilities
6 Summary(pl):    GNU Core-utils - podstawowe narzêdzia dzia³aj±ce z linii poleceñ
7 Name:           coreutils
8 Version:        5.2.1
9 Release:        0.5
10 License:        GPL
11 Group:          Applications/System
12 # devel versions:
13 #Source0:       ftp://alpha.gnu.org/gnu/fetish/%{name}-%{version}.tar.bz2
14 # final versions:
15 Source0:        ftp://ftp.gnu.org/gnu/coreutils/%{name}-%{version}.tar.bz2
16 # Source0-md5:  172ee3c315af93d3385ddfbeb843c53f
17 Source1:        %{name}-non-english-man-pages.tar.bz2
18 # Source1-md5:  f7c986ebc74ccb8d08ed70141063f14c
19 Source2:        DIR_COLORS
20 Source3:        fileutils.sh
21 Source4:        fileutils.csh
22 Source5:        su.pamd
23 Patch0:         %{name}-info.patch
24 Patch1:         %{name}-pl.po-update.patch
25 Patch2:         %{name}-pam.patch
26 Patch3:         %{name}-getgid.patch
27 Patch4:         %{name}-su-paths.patch
28 Patch5:         %{name}-uname-cpuinfo.patch
29 Patch6:         %{name}-date-man.patch
30 Patch7:         %{name}-mem.patch
31 Patch8:         %{name}-install-C.patch
32 Patch9:         %{name}-po.patch
33 Patch10:        %{name}-no-nb.patch
34 # based on patch from Fedora, based on patches from http://acl.bestbits.at/
35 Patch11:        %{name}-acl.patch
36 Patch12:        %{name}-selinux.patch
37 BuildRequires:  acl-devel
38 BuildRequires:  autoconf >= 2.58
39 BuildRequires:  automake >= 1.8
40 %{?with_selinux:BuildRequires:  gcc >= 5:3.2}
41 BuildRequires:  gettext-devel >= 0.11.5
42 BuildRequires:  help2man
43 BuildRequires:  pam-devel
44 BuildRequires:  texinfo >= 4.2
45 %{?with_selinux:BuildRequires:  libselinux-devel}
46 Requires:       pam >= 0.77.3
47 Requires:       setup >= 2.4.6-2
48 Provides:       fileutils
49 Provides:       sh-utils
50 Provides:       stat
51 Provides:       textutils
52 Obsoletes:      fileutils
53 Obsoletes:      sh-utils
54 Obsoletes:      stat
55 Obsoletes:      textutils
56 Conflicts:      shadow < 1:4.0.3-6
57 Conflicts:      tetex < 1:2.0.2
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %description
61 These are the GNU core utilities.  This package is the union of
62 the GNU fileutils, sh-utils, and textutils packages.
63
64 Most of these programs have significant advantages over their Unix
65 counterparts, such as greater speed, additional options, and fewer
66 arbitrary limits.
67
68 The programs that can be built with this package are:
69
70   basename cat chgrp chmod chown chroot cksum comm cp csplit cut date dd
71   df dir dircolors dirname du echo env expand expr factor false fmt fold
72   ginstall groups head hostid id join link ln logname ls md5sum mkdir
73   mkfifo mknod mv nice nl nohup od paste pathchk pinky pr printenv
74   printf ptx pwd rm rmdir seq sha1sum shred sleep sort split stat stty
75   su sum sync tac tail tee test touch tr true tsort tty uname unexpand
76   uniq unlink users vdir wc who whoami yes
77
78 %description -l pl
79 Narzêdzia podstawowe (core utilities) GNU to po³±czone paczki GNU
80 fileutils, sh-utils i textutils.
81
82 Wiêkszo¶æ z zawartych programów jest znacznie ulepszona w porównaniu
83 z ich uniksowymi odpowiednikami, np. szybciej dzia³aj±, maj± dodatkowe
84 opcje i mniej ograniczeñ.
85
86 Programy zawarte w tym pakiecie to:
87
88   basename cat chgrp chmod chown chroot cksum comm cp csplit cut date dd
89   df dir dircolors dirname du echo env expand expr factor false fmt fold
90   ginstall groups head hostid id join link ln logname ls md5sum mkdir
91   mkfifo mknod mv nice nl nohup od paste pathchk pinky pr printenv
92   printf ptx pwd rm rmdir seq sha1sum shred sleep sort split stat stty
93   su sum sync tac tail tee test touch tr true tsort tty uname unexpand
94   uniq unlink users vdir wc who whoami yes
95
96 %prep
97 %setup -q -a1
98 %patch0 -p1
99 %patch1 -p1
100 %patch2 -p1
101 %patch3 -p1
102 %patch4 -p1
103 %patch5 -p1
104 %patch6 -p1
105 %patch7 -p1
106 %patch8 -p1
107 %patch9 -p1
108 %patch10 -p1
109 %patch11 -p1
110 %{?with_selinux:%patch12 -p1}
111
112 %{__perl} -pi -e 's@GNU/Linux@PLD Linux@' m4/host-os.m4
113
114 # no_NO is just an alias for nb_NO in recent glibc
115 # no.po is outdated, nb.po is more fresh here (see also patch10)
116 rm -f po/no.*
117 # allow rebuilding *.gmo
118 rm -f po/stamp-po
119
120 %build
121 # jm's inttypes.m4 and inttypes.m4 from gettext are really different files
122 mv -f m4/{inttypes.m4,jm-inttypes.m4}
123 %{__gettextize}
124 %{__aclocal} -I m4
125 %{__autoconf}
126 %{__autoheader}
127 %{__automake}
128 %configure \
129         DEFAULT_POSIX2_VERSION=199209 \
130         %{?with_selinux:--enable-selinux} \
131         --enable-pam
132
133 %{__make}
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137 install -d $RPM_BUILD_ROOT{/bin,%{_bindir},%{_sbindir},/etc/pam.d,/etc/shrc.d}
138
139 %{__make} install \
140         DESTDIR=$RPM_BUILD_ROOT
141
142 rm -f $RPM_BUILD_ROOT%{_bindir}/{hostname,kill,uptime}
143 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{hostname,kill,uptime}.1*
144
145 ln -sf test $RPM_BUILD_ROOT%{_bindir}/[
146
147 mv -f $RPM_BUILD_ROOT%{_bindir}/{basename,cat,chgrp,chmod,chown,cp,date,dd,df,\
148 echo,false,id,link,ln,ls,mkdir,mknod,mv,nice,printf,pwd,rm,rmdir,sleep,sort,stty,\
149 sync,touch,true,unlink,uname} $RPM_BUILD_ROOT/bin
150
151 mv -f $RPM_BUILD_ROOT%{_bindir}/chroot $RPM_BUILD_ROOT%{_sbindir}
152
153 # su is missed by "make install"
154 install src/su $RPM_BUILD_ROOT/bin
155
156 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
157 install %{SOURCE3} %{SOURCE4} $RPM_BUILD_ROOT/etc/shrc.d
158 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/su
159
160 mv -f man/pt_BR man/pt
161 for d in cs da de es fi fr hu id it ja ko nl pl pt ru zh_CN ; do
162         install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
163         install man/$d/*.1 $RPM_BUILD_ROOT%{_mandir}/$d/man1
164 done
165 rm -f $RPM_BUILD_ROOT%{_mandir}/*/man1/{hostname,kill,uptime}.1
166
167 %find_lang %{name}
168
169 %clean
170 rm -rf $RPM_BUILD_ROOT
171
172 %post
173 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
174
175 %postun
176 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
177
178 %files -f %{name}.lang
179 %defattr(644,root,root,755)
180 %doc AUTHORS ChangeLog NEWS README THANKS THANKS-to-translators TODO
181 %attr(755,root,root) /bin/[!s]*
182 %attr(755,root,root) /bin/s[!u]*
183 %attr(4755,root,root) /bin/su
184 %attr(755,root,root) %{_bindir}/*
185 %attr(755,root,root) %{_sbindir}/*
186 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/pam.d/su
187 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/DIR_COLORS
188 %attr(755,root,root) /etc/shrc.d/*
189 %{_mandir}/man1/*
190 %lang(cs) %{_mandir}/cs/man1/*
191 %lang(da) %{_mandir}/da/man1/*
192 %lang(de) %{_mandir}/de/man1/*
193 %lang(es) %{_mandir}/es/man1/*
194 %lang(fi) %{_mandir}/fi/man1/*
195 %lang(fr) %{_mandir}/fr/man1/*
196 %lang(hu) %{_mandir}/hu/man1/*
197 %lang(id) %{_mandir}/id/man1/*
198 %lang(it) %{_mandir}/it/man1/*
199 %lang(ja) %{_mandir}/ja/man1/*
200 %lang(ko) %{_mandir}/ko/man1/*
201 %lang(nl) %{_mandir}/nl/man1/*
202 %lang(pl) %{_mandir}/pl/man1/*
203 %lang(pt) %{_mandir}/pt/man1/*
204 %lang(ru) %{_mandir}/ru/man1/*
205 %lang(zh_CN) %{_mandir}/zh_CN/man1/*
206 %{_infodir}/coreutils.info*
This page took 0.108347 seconds and 3 git commands to generate.