]> git.pld-linux.org Git - packages/coreutils.git/blob - coreutils.spec
- rel 2
[packages/coreutils.git] / coreutils.spec
1 #
2 # Conditional build:
3 %bcond_without  selinux         # build without SELinux support
4 #
5 Summary:        GNU Core-utils - basic command line utilities
6 Summary(pl.UTF-8):      GNU Core-utils - podstawowe narzędzia działające z linii poleceń
7 Name:           coreutils
8 Version:        6.9
9 Release:        2
10 License:        GPL
11 Group:          Applications/System
12 Source0:        ftp://ftp.gnu.org/gnu/coreutils/%{name}-%{version}.tar.bz2
13 # Source0-md5:  c9607d8495f16e98906e7ed2d9751a06
14 Source1:        %{name}-non-english-man-pages.tar.bz2
15 # Source1-md5:  f7c986ebc74ccb8d08ed70141063f14c
16 Source2:        DIR_COLORS
17 Source3:        fileutils.sh
18 Source4:        fileutils.csh
19 Source5:        su.pamd
20 Source6:        su-l.pamd
21 Source7:        runuser.pamd
22 Source8:        runuser-l.pamd
23 Patch0:         %{name}-info.patch
24 Patch1:         %{name}-pam.patch
25 Patch2:         %{name}-getgid.patch
26 Patch3:         %{name}-su-paths.patch
27 Patch4:         %{name}-uname-cpuinfo.patch
28 Patch5:         %{name}-date-man.patch
29 Patch6:         %{name}-mem.patch
30 Patch7:         %{name}-install-C.patch
31 Patch8:         %{name}-po.patch
32 Patch9:         %{name}-no-nb.patch
33 Patch10:        %{name}-fmt-wchars.patch
34 Patch11:        %{name}-runuser.patch
35 Patch12:        %{name}-split-pam.patch
36 Patch13:        %{name}-selinux.patch
37 Patch14:        %{name}-pl.po-update.patch
38 URL:            http://www.gnu.org/software/coreutils/
39 BuildRequires:  acl-devel
40 BuildRequires:  autoconf >= 2.60
41 BuildRequires:  automake >= 1:1.9.6
42 %{?with_selinux:BuildRequires:  gcc >= 5:3.2}
43 BuildRequires:  gettext-devel >= 0.16-2
44 BuildRequires:  help2man
45 %{?with_selinux:BuildRequires:  libselinux-devel}
46 BuildRequires:  pam-devel
47 BuildRequires:  texinfo >= 4.2
48 Requires:       pam >= 0.77.3
49 Requires:       setup >= 2.4.6-2
50 Provides:       fileutils
51 Provides:       sh-utils
52 Provides:       stat
53 Provides:       textutils
54 Obsoletes:      fileutils
55 Obsoletes:      sh-utils
56 Obsoletes:      stat
57 Obsoletes:      textutils
58 Conflicts:      shadow < 1:4.0.3-6
59 Conflicts:      tetex < 1:2.0.2
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %description
63 These are the GNU core utilities. This package is the union of the GNU
64 fileutils, sh-utils, and textutils packages.
65
66 Most of these programs have significant advantages over their Unix
67 counterparts, such as greater speed, additional options, and fewer
68 arbitrary limits.
69
70 The programs that can be built with this package are:
71
72   [ basename cat chgrp chmod chown chroot cksum comm cp csplit cut date
73   dd df dir dircolors dirname du echo env expand expr factor false fmt
74   fold install groups head hostid id join link ln logname ls md5sum
75   mkdir mkfifo mknod mv nice nl nohup od paste pathchk pinky pr printenv
76   printf ptx pwd rm rmdir seq sha1sum shred sleep sort split stat stty
77   su sum sync tac tail tee test touch tr true tsort tty uname unexpand
78   uniq unlink users vdir wc who whoami yes
79
80 %description -l pl.UTF-8
81 Narzędzia podstawowe (core utilities) GNU to połączone paczki GNU
82 fileutils, sh-utils i textutils.
83
84 Większość z zawartych programów jest znacznie ulepszona w porównaniu
85 z ich uniksowymi odpowiednikami, np. szybciej działają, mają dodatkowe
86 opcje i mniej ograniczeń.
87
88 Programy zawarte w tym pakiecie to:
89
90   [ basename cat chgrp chmod chown chroot cksum comm cp csplit cut date
91   dd df dir dircolors dirname du echo env expand expr factor false fmt
92   fold ginstall groups head hostid id join link ln logname ls md5sum
93   mkdir mkfifo mknod mv nice nl nohup od paste pathchk pinky pr printenv
94   printf ptx pwd rm rmdir seq sha1sum shred sleep sort split stat stty
95   su sum sync tac tail tee test touch tr true tsort tty uname unexpand
96   uniq unlink users vdir wc who whoami yes
97
98 %prep
99 %setup -q -a1
100 %patch14 -p1
101 %patch0 -p1
102 %patch1 -p1
103 %patch2 -p1
104 %patch3 -p1
105 %patch4 -p1
106 %patch5 -p1
107 %patch6 -p1
108 %patch7 -p1
109 %patch8 -p1
110 %patch9 -p1
111 %patch10 -p1
112 %patch11 -p1
113 %patch12 -p1
114 %{?with_selinux:%patch13 -p1}
115
116 %{__perl} -pi -e 's@GNU/Linux@PLD Linux@' m4/host-os.m4
117
118 # no_NO is just an alias for nb_NO in recent glibc
119 # no.po is outdated, nb.po is more fresh here (see also patch10)
120 rm -f po/no.*
121 # allow rebuilding *.gmo
122 rm -f po/stamp-po
123
124 # missing, added to gettext.m4 by ./bootstrap
125 echo 'AC_DEFUN([gl_LOCK_EARLY],[])' > m4/gllock.m4
126
127 %build
128 %{__gettextize}
129 %{__aclocal} -I m4
130 %{__autoconf}
131 %{__autoheader}
132 %{__automake}
133 %configure \
134         CFLAGS="%{rpmcflags} -DSYSLOG_SUCCESS -DSYSLOG_FAILURE -DSYSLOG_NON_ROOT" \
135         DEFAULT_POSIX2_VERSION=199209 \
136         %{?with_selinux:--enable-selinux} \
137         --enable-pam
138
139 %{__make}
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143 install -d $RPM_BUILD_ROOT{/bin,/sbin,%{_bindir},%{_sbindir},/etc/pam.d,/etc/shrc.d}
144
145 %{__make} install \
146         DESTDIR=$RPM_BUILD_ROOT
147
148 rm -f $RPM_BUILD_ROOT%{_bindir}/{hostname,kill,uptime}
149 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{hostname,kill,uptime}.1*
150
151 mv -f $RPM_BUILD_ROOT%{_bindir}/{basename,cat,chgrp,chmod,chown,cp,date,dd,df,\
152 echo,false,id,link,ln,ls,mkdir,mknod,mv,nice,printf,pwd,rm,rmdir,sleep,sort,stty,\
153 sync,touch,true,unlink,uname} $RPM_BUILD_ROOT/bin
154
155 mv -f $RPM_BUILD_ROOT%{_bindir}/chroot $RPM_BUILD_ROOT%{_sbindir}
156
157 # su is missed by "make install"
158 install src/su $RPM_BUILD_ROOT/bin
159 install src/runuser $RPM_BUILD_ROOT/sbin
160
161 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
162 install %{SOURCE3} %{SOURCE4} $RPM_BUILD_ROOT/etc/shrc.d
163 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/su
164 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/su-l
165 install %{SOURCE7} $RPM_BUILD_ROOT/etc/pam.d/runuser
166 install %{SOURCE8} $RPM_BUILD_ROOT/etc/pam.d/runuser-l
167
168 cp -a man/pt_BR man/pt
169 for d in cs da de es fi fr hu id it ja ko nl pl pt ru zh_CN ; do
170         install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
171         install man/$d/*.1 $RPM_BUILD_ROOT%{_mandir}/$d/man1
172 done
173 rm -f $RPM_BUILD_ROOT%{_mandir}/*/man1/{hostname,kill,uptime}.1
174
175 %find_lang %{name}
176
177 %clean
178 rm -rf $RPM_BUILD_ROOT
179
180 %post
181 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
182
183 %postun
184 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
185
186 %files -f %{name}.lang
187 %defattr(644,root,root,755)
188 %doc AUTHORS ChangeLog NEWS README THANKS THANKS-to-translators TODO
189 %attr(755,root,root) /bin/[!s]*
190 %attr(755,root,root) /bin/s[!u]*
191 %attr(4755,root,root) /bin/su
192 %attr(755,root,root) /sbin/runuser
193 %attr(755,root,root) %{_bindir}/*
194 %attr(755,root,root) %{_sbindir}/*
195 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/su
196 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/su-l
197 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/runuser
198 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/runuser-l
199 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/DIR_COLORS
200 /etc/shrc.d/*
201 %{_mandir}/man1/*
202 %lang(cs) %{_mandir}/cs/man1/*
203 %lang(da) %{_mandir}/da/man1/*
204 %lang(de) %{_mandir}/de/man1/*
205 %lang(es) %{_mandir}/es/man1/*
206 %lang(fi) %{_mandir}/fi/man1/*
207 %lang(fr) %{_mandir}/fr/man1/*
208 %lang(hu) %{_mandir}/hu/man1/*
209 %lang(id) %{_mandir}/id/man1/*
210 %lang(it) %{_mandir}/it/man1/*
211 %lang(ja) %{_mandir}/ja/man1/*
212 %lang(ko) %{_mandir}/ko/man1/*
213 %lang(nl) %{_mandir}/nl/man1/*
214 %lang(pl) %{_mandir}/pl/man1/*
215 %lang(pt) %{_mandir}/pt/man1/*
216 %lang(ru) %{_mandir}/ru/man1/*
217 %lang(zh_CN) %{_mandir}/zh_CN/man1/*
218 %{_infodir}/coreutils.info*
This page took 0.041701 seconds and 3 git commands to generate.