]> git.pld-linux.org Git - packages/coreutils.git/blob - coreutils.spec
5fe925fcf205f92a7aebd0e2e1b8db0d5384c698
[packages/coreutils.git] / coreutils.spec
1 #
2 # Conditional build:
3 %bcond_with     advcopy # progress bar in cp (orphaned patch)
4 %bcond_with     multicall       # Compile all the tools in a single binary
5 %bcond_without  tests   # do not perform "make test check"
6
7 Summary:        GNU Core-utils - basic command line utilities
8 Summary(pl.UTF-8):      GNU Core-utils - podstawowe narzędzia działające z linii poleceń
9 Name:           coreutils
10 Version:        8.25
11 Release:        1
12 License:        GPL v3+
13 Group:          Applications/System
14 Source0:        http://ftp.gnu.org/gnu/coreutils/%{name}-%{version}.tar.xz
15 # Source0-md5:  070e43ba7f618d747414ef56ab248a48
16 Source1:        %{name}-non-english-man-pages.tar.bz2
17 # Source1-md5:  f7c986ebc74ccb8d08ed70141063f14c
18 Source2:        DIR_COLORS
19 Source3:        DIR_COLORS.256color
20 Source4:        colorls.sh
21 Source5:        colorls.csh
22 Source6:        mktemp.1.pl
23 Patch0:         %{name}-info.patch
24 Patch1:         %{name}-getgid.patch
25 Patch2:         %{name}-uname-cpuinfo.patch
26 Patch3:         %{name}-date-man.patch
27
28 Patch6:         %{name}-fmt-wchars.patch
29 Patch7:         %{name}-sparc64.patch
30 # http://translationproject.org/latest/coreutils/pl.po (pass through msgcat to generate shorter diff)
31 Patch8:         %{name}-pl.po-update.patch
32 # from http://www.beatex.org/web/advancedcopy.html, edited by shadzik
33 Patch9:         %{name}-advcopy.patch
34 Patch10:        tests.patch
35 URL:            http://www.gnu.org/software/coreutils/
36 BuildRequires:  acl-devel
37 BuildRequires:  attr-devel
38 BuildRequires:  autoconf >= 2.64
39 BuildRequires:  automake >= 1:1.11.2
40 BuildRequires:  gcc >= 5:3.2
41 BuildRequires:  gettext-tools >= 0.18.1
42 BuildRequires:  gmp-devel
43 BuildRequires:  help2man
44 BuildRequires:  libcap-devel
45 BuildRequires:  libselinux-devel
46 BuildRequires:  rpmbuild(find_lang) >= 1.24
47 BuildRequires:  tar >= 1:1.22
48 BuildRequires:  texinfo >= 4.2
49 BuildRequires:  xz
50 %if %{with tests}
51 BuildRequires:  strace
52 %endif
53 Requires:       setup >= 2.4.6-2
54 Provides:       fileutils
55 Provides:       mktemp = %{version}-%{release}
56 Provides:       sh-utils
57 Provides:       stat
58 Provides:       textutils
59 Obsoletes:      fileutils
60 Obsoletes:      mktemp
61 Obsoletes:      sh-utils
62 Obsoletes:      stat
63 Obsoletes:      textutils
64 Conflicts:      shadow < 1:4.0.3-6
65 Conflicts:      tetex < 1:2.0.2
66 # ensure util-linux has su included
67 Conflicts:      util-linux < 2.22
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 %description
71 These are the GNU core utilities. This package is the union of the GNU
72 fileutils, sh-utils, and textutils packages.
73
74 Most of these programs have significant advantages over their Unix
75 counterparts, such as greater speed, additional options, and fewer
76 arbitrary limits.
77
78 The programs that can be built with this package are:
79
80   [ basename cat chgrp chmod chown chroot cksum comm cp csplit cut date
81   dd df dir dircolors dirname du echo env expand expr factor false fmt
82   fold install groups head hostid id join link ln logname ls md5sum
83   mkdir mkfifo mknod mv nice nl nohup od paste pathchk pinky pr printenv
84   printf ptx pwd realpath rm rmdir seq sha1sum shred sleep sort split
85   stat stty sum sync tac tail tee test touch tr true tsort tty uname
86   unexpand uniq unlink users vdir wc who whoami yes
87
88 %description -l pl.UTF-8
89 Narzędzia podstawowe (core utilities) GNU to połączone paczki GNU
90 fileutils, sh-utils i textutils.
91
92 Większość z zawartych programów jest znacznie ulepszona w porównaniu
93 z ich uniksowymi odpowiednikami, np. szybciej działają, mają dodatkowe
94 opcje i mniej ograniczeń.
95
96 Programy zawarte w tym pakiecie to:
97
98   [ basename cat chgrp chmod chown chroot cksum comm cp csplit cut date
99   dd df dir dircolors dirname du echo env expand expr factor false fmt
100   fold ginstall groups head hostid id join link ln logname ls md5sum
101   mkdir mkfifo mknod mv nice nl nohup od paste pathchk pinky pr printenv
102   printf ptx pwd realpath rm rmdir seq sha1sum shred sleep sort split
103   stat stty sum sync tac tail tee test touch tr true tsort tty uname
104   unexpand uniq unlink users vdir wc who whoami yes
105
106 %prep
107 %setup -q -a1
108 %patch8 -p1
109 %patch0 -p1
110 %patch1 -p1
111 %patch2 -p1
112 %patch3 -p1
113
114 %patch6 -p1
115 %ifarch sparc64
116 %patch7 -p1
117 %endif
118 %if %{with advcopy}
119 # progress-bar patch, -g,--progress-bar //if in doubt, comment it out
120 %patch9 -p1
121 %endif
122 %patch10 -p1
123
124 mv man/pt_BR man/pt
125
126 %{__perl} -pi -e 's@GNU/Linux@PLD Linux@' m4/host-os.m4
127
128 # allow rebuilding *.gmo
129 %{__rm} po/stamp-po
130
131 # 8-bit-pfx test fails under C locale:
132 # LC_ALL=C echo -e "ça\nçb\n"|LC_ALL=C fmt -p 'ç'
133 # fmt: memory exhausted
134 %{__sed} -i -e 25,27d tests/fmt/base.pl
135
136 # /etc/resolv.conf is blocked in pld builders, try some other file
137 %{__sed} -i -e 's,/etc/resolv.conf,/etc/hosts,' gnulib-tests/test-read-file.c
138
139 # getgid needs to be fixed:
140 # getgid: missing operand
141 # Try `getgid --help' for more information.
142 %{__rm} tests/misc/help-version.sh
143 %{__sed} -i -e '/misc\/help-version/d' tests/local.mk
144
145 # fails on some filesystems (like XFS), where readdir returns d_type=DT_UNKNOWN
146 %{__rm} tests/ls/stat-free-color.sh
147 %{__sed} -i -e '/ls\/stat-free-color/d' tests/local.mk
148
149 # filesystem layout dependant (fails on some xfs fs)
150 %{__rm} tests/dd/sparse.sh
151 %{__sed} -i -e '/dd\/sparse/d' tests/local.mk
152
153 # mksh is too smart for those, won't let programs fail on ulimit
154 # would need bash here
155 %{__rm} tests/misc/sort-merge-fdlimit.sh
156 %{__sed} -i -e '/misc\/sort-merge-fdlimit/d' tests/local.mk
157 %{__rm} tests/split/r-chunk.sh
158 %{__sed} -i -e '/split\/r-chunk/d' tests/local.mk
159
160 %build
161 build-aux/gen-lists-of-programs.sh --autoconf > m4/cu-progs.m4
162 build-aux/gen-lists-of-programs.sh --automake > src/cu-progs.mk
163 %{__gettextize}
164 %{__aclocal} -I m4
165 %{__autoconf}
166 %{__autoheader}
167 %{__automake}
168 %configure \
169         CFLAGS="%{rpmcflags} -DSYSLOG_SUCCESS -DSYSLOG_FAILURE -DSYSLOG_NON_ROOT" \
170         DEFAULT_POSIX2_VERSION=199209 \
171         %{?with_multicall:--enable-single-binary=symlinks} \
172         --disable-silent-rules \
173         --enable-install-program=arch \
174         --enable-no-install-program=hostname,kill,uptime
175
176 %{__make}
177
178 %if %{with tests}
179 sed -i -e 's#COLUMNS##g' tests/envvar-check
180 LC_ALL=C LANG=C %{__make} -j1 tests check
181 %endif
182
183 %install
184 rm -rf $RPM_BUILD_ROOT
185 install -d $RPM_BUILD_ROOT{/bin,/sbin,%{_bindir},%{_sbindir},/etc/shrc.d}
186
187 %{__make} install \
188         DESTDIR=$RPM_BUILD_ROOT
189
190 mv $RPM_BUILD_ROOT%{_bindir}/{arch,basename,cat,chgrp,chmod,chown,cp,date,dd,\
191 df,echo,false,id,link,ln,ls,mkdir,mknod,mktemp,mv,nice,printf,pwd,readlink,rm,rmdir,\
192 sleep,sort,stat,stty,sync,touch,true,unlink,uname} $RPM_BUILD_ROOT/bin
193
194 %if %{with multicall}
195 mv $RPM_BUILD_ROOT{%{_bindir},/bin}/coreutils
196 ln -s ../../bin/coreutils $RPM_BUILD_ROOT%{_bindir}
197 %endif
198
199 mv $RPM_BUILD_ROOT%{_bindir}/chroot $RPM_BUILD_ROOT%{_sbindir}
200
201 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
202 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
203 cp -p %{SOURCE4} %{SOURCE5} $RPM_BUILD_ROOT/etc/shrc.d
204
205 for d in cs da de es fi fr hu id it ja ko nl pl pt ru zh_CN; do
206         install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
207         cp -p man/$d/*.1 $RPM_BUILD_ROOT%{_mandir}/$d/man1
208 done
209 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_mandir}/pl/man1/mktemp.1
210 # unwanted (-f left intentionally - some manuals could have no translations)
211 rm -f $RPM_BUILD_ROOT%{_mandir}/*/man1/{hostname,kill,su,uptime}.1
212 # always remove, never packaged but sometimes installed
213 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
214
215 %find_lang %{name}
216
217 %clean
218 rm -rf $RPM_BUILD_ROOT
219
220 %post   -p /sbin/postshell
221 -/usr/sbin/fix-info-dir -c %{_infodir}
222
223 %postun -p /sbin/postshell
224 -/usr/sbin/fix-info-dir -c %{_infodir}
225
226 %files -f %{name}.lang
227 %defattr(644,root,root,755)
228 %doc AUTHORS ChangeLog NEWS README THANKS THANKS-to-translators TODO
229 %attr(755,root,root) /bin/arch
230 %attr(755,root,root) /bin/basename
231 %attr(755,root,root) /bin/cat
232 %attr(755,root,root) /bin/chgrp
233 %attr(755,root,root) /bin/chmod
234 %attr(755,root,root) /bin/chown
235 %attr(755,root,root) /bin/cp
236 %attr(755,root,root) /bin/date
237 %attr(755,root,root) /bin/dd
238 %attr(755,root,root) /bin/df
239 %attr(755,root,root) /bin/echo
240 %attr(755,root,root) /bin/false
241 %attr(755,root,root) /bin/id
242 %attr(755,root,root) /bin/link
243 %attr(755,root,root) /bin/ln
244 %attr(755,root,root) /bin/ls
245 %attr(755,root,root) /bin/mkdir
246 %attr(755,root,root) /bin/mknod
247 %attr(755,root,root) /bin/mktemp
248 %attr(755,root,root) /bin/mv
249 %attr(755,root,root) /bin/nice
250 %attr(755,root,root) /bin/printf
251 %attr(755,root,root) /bin/pwd
252 %attr(755,root,root) /bin/readlink
253 %attr(755,root,root) /bin/rm
254 %attr(755,root,root) /bin/rmdir
255 %attr(755,root,root) /bin/sleep
256 %attr(755,root,root) /bin/sort
257 %attr(755,root,root) /bin/stat
258 %attr(755,root,root) /bin/stty
259 %attr(755,root,root) /bin/sync
260 %attr(755,root,root) /bin/touch
261 %attr(755,root,root) /bin/true
262 %attr(755,root,root) /bin/uname
263 %attr(755,root,root) /bin/unlink
264 %attr(755,root,root) %{_bindir}/[
265 %attr(755,root,root) %{_bindir}/base32
266 %attr(755,root,root) %{_bindir}/base64
267 %attr(755,root,root) %{_bindir}/chcon
268 %attr(755,root,root) %{_bindir}/cksum
269 %attr(755,root,root) %{_bindir}/comm
270 %attr(755,root,root) %{_bindir}/csplit
271 %attr(755,root,root) %{_bindir}/cut
272 %attr(755,root,root) %{_bindir}/dir
273 %attr(755,root,root) %{_bindir}/dircolors
274 %attr(755,root,root) %{_bindir}/dirname
275 %attr(755,root,root) %{_bindir}/du
276 %attr(755,root,root) %{_bindir}/env
277 %attr(755,root,root) %{_bindir}/expand
278 %attr(755,root,root) %{_bindir}/expr
279 %attr(755,root,root) %{_bindir}/factor
280 %attr(755,root,root) %{_bindir}/fmt
281 %attr(755,root,root) %{_bindir}/fold
282 %attr(755,root,root) %{_bindir}/getgid
283 %attr(755,root,root) %{_bindir}/groups
284 %attr(755,root,root) %{_bindir}/head
285 %attr(755,root,root) %{_bindir}/hostid
286 %attr(755,root,root) %{_bindir}/install
287 %attr(755,root,root) %{_bindir}/join
288 %attr(755,root,root) %{_bindir}/logname
289 %attr(755,root,root) %{_bindir}/md5sum
290 %attr(755,root,root) %{_bindir}/mkfifo
291 %attr(755,root,root) %{_bindir}/nl
292 %attr(755,root,root) %{_bindir}/nohup
293 %attr(755,root,root) %{_bindir}/nproc
294 %attr(755,root,root) %{_bindir}/numfmt
295 %attr(755,root,root) %{_bindir}/od
296 %attr(755,root,root) %{_bindir}/paste
297 %attr(755,root,root) %{_bindir}/pathchk
298 %attr(755,root,root) %{_bindir}/pinky
299 %attr(755,root,root) %{_bindir}/pr
300 %attr(755,root,root) %{_bindir}/printenv
301 %attr(755,root,root) %{_bindir}/ptx
302 %attr(755,root,root) %{_bindir}/realpath
303 %attr(755,root,root) %{_bindir}/runcon
304 %attr(755,root,root) %{_bindir}/seq
305 %attr(755,root,root) %{_bindir}/sha1sum
306 %attr(755,root,root) %{_bindir}/sha224sum
307 %attr(755,root,root) %{_bindir}/sha256sum
308 %attr(755,root,root) %{_bindir}/sha384sum
309 %attr(755,root,root) %{_bindir}/sha512sum
310 %attr(755,root,root) %{_bindir}/shred
311 %attr(755,root,root) %{_bindir}/shuf
312 %attr(755,root,root) %{_bindir}/split
313 %attr(755,root,root) %{_bindir}/stdbuf
314 %attr(755,root,root) %{_bindir}/sum
315 %attr(755,root,root) %{_bindir}/tac
316 %attr(755,root,root) %{_bindir}/tail
317 %attr(755,root,root) %{_bindir}/tee
318 %attr(755,root,root) %{_bindir}/test
319 %attr(755,root,root) %{_bindir}/timeout
320 %attr(755,root,root) %{_bindir}/tr
321 %attr(755,root,root) %{_bindir}/truncate
322 %attr(755,root,root) %{_bindir}/tsort
323 %attr(755,root,root) %{_bindir}/tty
324 %attr(755,root,root) %{_bindir}/unexpand
325 %attr(755,root,root) %{_bindir}/uniq
326 %attr(755,root,root) %{_bindir}/users
327 %attr(755,root,root) %{_bindir}/vdir
328 %attr(755,root,root) %{_bindir}/wc
329 %attr(755,root,root) %{_bindir}/who
330 %attr(755,root,root) %{_bindir}/whoami
331 %attr(755,root,root) %{_bindir}/yes
332 %attr(755,root,root) %{_sbindir}/chroot
333 %if %{with multicall}
334 %attr(755,root,root) /bin/coreutils
335 %attr(755,root,root) %{_bindir}/coreutils
336 %{_mandir}/man1/coreutils.1*
337 %endif
338 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/DIR_COLORS
339 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/DIR_COLORS.256color
340 %config(noreplace) /etc/shrc.d/colorls.csh
341 %config(noreplace) /etc/shrc.d/colorls.sh
342 %dir %{_libdir}/coreutils
343 %attr(755,root,root) %{_libdir}/coreutils/libstdbuf.so
344 %{_mandir}/man1/arch.1*
345 %{_mandir}/man1/base32.1*
346 %{_mandir}/man1/base64.1*
347 %{_mandir}/man1/basename.1*
348 %{_mandir}/man1/cat.1*
349 %{_mandir}/man1/chcon.1*
350 %{_mandir}/man1/chgrp.1*
351 %{_mandir}/man1/chmod.1*
352 %{_mandir}/man1/chown.1*
353 %{_mandir}/man1/chroot.1*
354 %{_mandir}/man1/cksum.1*
355 %{_mandir}/man1/comm.1*
356 %{_mandir}/man1/cp.1*
357 %{_mandir}/man1/csplit.1*
358 %{_mandir}/man1/cut.1*
359 %{_mandir}/man1/date.1*
360 %{_mandir}/man1/dd.1*
361 %{_mandir}/man1/df.1*
362 %{_mandir}/man1/dir.1*
363 %{_mandir}/man1/dircolors.1*
364 %{_mandir}/man1/dirname.1*
365 %{_mandir}/man1/du.1*
366 %{_mandir}/man1/echo.1*
367 %{_mandir}/man1/env.1*
368 %{_mandir}/man1/expand.1*
369 %{_mandir}/man1/expr.1*
370 %{_mandir}/man1/factor.1*
371 %{_mandir}/man1/false.1*
372 %{_mandir}/man1/fmt.1*
373 %{_mandir}/man1/fold.1*
374 %{_mandir}/man1/getgid.1*
375 %{_mandir}/man1/groups.1*
376 %{_mandir}/man1/head.1*
377 %{_mandir}/man1/hostid.1*
378 %{_mandir}/man1/id.1*
379 %{_mandir}/man1/install.1*
380 %{_mandir}/man1/join.1*
381 %{_mandir}/man1/link.1*
382 %{_mandir}/man1/ln.1*
383 %{_mandir}/man1/logname.1*
384 %{_mandir}/man1/ls.1*
385 %{_mandir}/man1/md5sum.1*
386 %{_mandir}/man1/mkdir.1*
387 %{_mandir}/man1/mkfifo.1*
388 %{_mandir}/man1/mknod.1*
389 %{_mandir}/man1/mktemp.1*
390 %{_mandir}/man1/mv.1*
391 %{_mandir}/man1/nice.1*
392 %{_mandir}/man1/nl.1*
393 %{_mandir}/man1/nohup.1*
394 %{_mandir}/man1/nproc.1*
395 %{_mandir}/man1/numfmt.1*
396 %{_mandir}/man1/od.1*
397 %{_mandir}/man1/paste.1*
398 %{_mandir}/man1/pathchk.1*
399 %{_mandir}/man1/pinky.1*
400 %{_mandir}/man1/pr.1*
401 %{_mandir}/man1/printenv.1*
402 %{_mandir}/man1/printf.1*
403 %{_mandir}/man1/ptx.1*
404 %{_mandir}/man1/pwd.1*
405 %{_mandir}/man1/readlink.1*
406 %{_mandir}/man1/realpath.1*
407 %{_mandir}/man1/rm.1*
408 %{_mandir}/man1/rmdir.1*
409 %{_mandir}/man1/runcon.1*
410 %{_mandir}/man1/seq.1*
411 %{_mandir}/man1/sha1sum.1*
412 %{_mandir}/man1/sha224sum.1*
413 %{_mandir}/man1/sha256sum.1*
414 %{_mandir}/man1/sha384sum.1*
415 %{_mandir}/man1/sha512sum.1*
416 %{_mandir}/man1/shred.1*
417 %{_mandir}/man1/shuf.1*
418 %{_mandir}/man1/sleep.1*
419 %{_mandir}/man1/sort.1*
420 %{_mandir}/man1/split.1*
421 %{_mandir}/man1/stat.1*
422 %{_mandir}/man1/stdbuf.1*
423 %{_mandir}/man1/stty.1*
424 %{_mandir}/man1/sum.1*
425 %{_mandir}/man1/sync.1*
426 %{_mandir}/man1/tac.1*
427 %{_mandir}/man1/tail.1*
428 %{_mandir}/man1/tee.1*
429 %{_mandir}/man1/test.1*
430 %{_mandir}/man1/timeout.1*
431 %{_mandir}/man1/touch.1*
432 %{_mandir}/man1/tr.1*
433 %{_mandir}/man1/true.1*
434 %{_mandir}/man1/truncate.1*
435 %{_mandir}/man1/tsort.1*
436 %{_mandir}/man1/tty.1*
437 %{_mandir}/man1/uname.1*
438 %{_mandir}/man1/unexpand.1*
439 %{_mandir}/man1/uniq.1*
440 %{_mandir}/man1/unlink.1*
441 %{_mandir}/man1/users.1*
442 %{_mandir}/man1/vdir.1*
443 %{_mandir}/man1/wc.1*
444 %{_mandir}/man1/who.1*
445 %{_mandir}/man1/whoami.1*
446 %{_mandir}/man1/yes.1*
447 %lang(cs) %{_mandir}/cs/man1/*
448 %lang(da) %{_mandir}/da/man1/*
449 %lang(de) %{_mandir}/de/man1/*
450 %lang(es) %{_mandir}/es/man1/*
451 %lang(fi) %{_mandir}/fi/man1/*
452 %lang(fr) %{_mandir}/fr/man1/*
453 %lang(hu) %{_mandir}/hu/man1/*
454 %lang(id) %{_mandir}/id/man1/*
455 %lang(it) %{_mandir}/it/man1/*
456 %lang(ja) %{_mandir}/ja/man1/*
457 %lang(ko) %{_mandir}/ko/man1/*
458 %lang(nl) %{_mandir}/nl/man1/*
459 %lang(pl) %{_mandir}/pl/man1/*
460 %lang(pt) %{_mandir}/pt/man1/*
461 %lang(ru) %{_mandir}/ru/man1/*
462 %lang(zh_CN) %{_mandir}/zh_CN/man1/*
463 %{_infodir}/coreutils.info*
This page took 0.057696 seconds and 2 git commands to generate.