]> git.pld-linux.org Git - packages/coreutils.git/blob - coreutils.spec
- partially update from fedora, fixes test suite
[packages/coreutils.git] / coreutils.spec
1 #
2 # Conditional build:
3 %bcond_with     advcopy # progress bar in cp (orphaned patch)
4 %bcond_without  tests   # do not perform "make test check"
5 #
6 Summary:        GNU Core-utils - basic command line utilities
7 Summary(pl.UTF-8):      GNU Core-utils - podstawowe narzędzia działające z linii poleceń
8 Name:           coreutils
9 Version:        8.10
10 Release:        1
11 License:        GPL v3+
12 Group:          Applications/System
13 Source0:        http://ftp.gnu.org/gnu/coreutils/%{name}-%{version}.tar.xz
14 # Source0-md5:  4bb81c051da6e5436fc1ad9a67ae44fe
15 Source1:        %{name}-non-english-man-pages.tar.bz2
16 # Source1-md5:  f7c986ebc74ccb8d08ed70141063f14c
17 Source2:        DIR_COLORS
18 Source3:        fileutils.sh
19 Source4:        fileutils.csh
20 Source5:        su.pamd
21 Source6:        su-l.pamd
22 Source7:        runuser.pamd
23 Source8:        runuser-l.pamd
24 Source9:        mktemp.1.pl
25 Patch0:         %{name}-info.patch
26 Patch1:         %{name}-pam.patch
27 Patch2:         %{name}-getgid.patch
28 Patch3:         %{name}-su-paths.patch
29 Patch4:         %{name}-uname-cpuinfo.patch
30 Patch5:         %{name}-date-man.patch
31 Patch6:         %{name}-mem.patch
32 Patch7:         %{name}-7.4-sttytcsadrain.patch
33
34 Patch9:         %{name}-fmt-wchars.patch
35 Patch10:        %{name}-runuser.patch
36 Patch11:        %{name}-split-pam.patch
37 Patch12:        %{name}-sparc64.patch
38 # http://translationproject.org/latest/coreutils/pl.po (pass through msgcat to generate shorter diff)
39 Patch13:        %{name}-pl.po-update.patch
40 # from http://www.beatex.org/web/advancedcopy.html, edited by shadzik
41 Patch14:        %{name}-advcopy.patch
42 URL:            http://www.gnu.org/software/coreutils/
43 BuildRequires:  acl-devel
44 BuildRequires:  attr-devel
45 BuildRequires:  autoconf >= 2.62
46 BuildRequires:  automake >= 1:1.11.1
47 BuildRequires:  gcc >= 5:3.2
48 BuildRequires:  gettext-devel >= 0.17
49 BuildRequires:  gmp-devel
50 BuildRequires:  help2man
51 BuildRequires:  libcap-devel
52 BuildRequires:  libselinux-devel
53 BuildRequires:  pam-devel
54 BuildRequires:  rpmbuild(find_lang) >= 1.24
55 BuildRequires:  tar >= 1:1.22
56 BuildRequires:  texinfo >= 4.2
57 BuildRequires:  xz
58 Requires:       pam >= 0.77.3
59 Requires:       setup >= 2.4.6-2
60 Provides:       coreutils-su
61 Provides:       fileutils
62 Provides:       mktemp = %{version}-%{release}
63 Provides:       sh-utils
64 Provides:       stat
65 Provides:       textutils
66 Obsoletes:      coreutils-su
67 Obsoletes:      fileutils
68 Obsoletes:      mktemp
69 Obsoletes:      sh-utils
70 Obsoletes:      stat
71 Obsoletes:      textutils
72 Conflicts:      shadow < 1:4.0.3-6
73 Conflicts:      tetex < 1:2.0.2
74 Conflicts:      util-linux < 2.13-0.pre7
75 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77 %description
78 These are the GNU core utilities. This package is the union of the GNU
79 fileutils, sh-utils, and textutils packages.
80
81 Most of these programs have significant advantages over their Unix
82 counterparts, such as greater speed, additional options, and fewer
83 arbitrary limits.
84
85 The programs that can be built with this package are:
86
87   [ basename cat chgrp chmod chown chroot cksum comm cp csplit cut date
88   dd df dir dircolors dirname du echo env expand expr factor false fmt
89   fold install groups head hostid id join link ln logname ls md5sum
90   mkdir mkfifo mknod mv nice nl nohup od paste pathchk pinky pr printenv
91   printf ptx pwd rm rmdir runuser seq sha1sum shred sleep sort split
92   stat stty su sum sync tac tail tee test touch tr true tsort tty uname
93   unexpand uniq unlink users vdir wc who whoami yes
94
95 %description -l pl.UTF-8
96 Narzędzia podstawowe (core utilities) GNU to połączone paczki GNU
97 fileutils, sh-utils i textutils.
98
99 Większość z zawartych programów jest znacznie ulepszona w porównaniu
100 z ich uniksowymi odpowiednikami, np. szybciej działają, mają dodatkowe
101 opcje i mniej ograniczeń.
102
103 Programy zawarte w tym pakiecie to:
104
105   [ basename cat chgrp chmod chown chroot cksum comm cp csplit cut date
106   dd df dir dircolors dirname du echo env expand expr factor false fmt
107   fold ginstall groups head hostid id join link ln logname ls md5sum
108   mkdir mkfifo mknod mv nice nl nohup od paste pathchk pinky pr printenv
109   printf ptx pwd rm rmdir runuser seq sha1sum shred sleep sort split
110   stat stty su sum sync tac tail tee test touch tr true tsort tty uname
111   unexpand uniq unlink users vdir wc who whoami yes
112
113 %prep
114 %setup -q -a1
115 %patch13 -p1
116 %patch0 -p1
117 %patch1 -p1
118 %patch2 -p1
119 %patch3 -p1
120 %patch4 -p1
121 %patch5 -p1
122 %patch6 -p1
123 %patch7 -p1
124 %patch9 -p1
125 %patch10 -p1
126 %patch11 -p1
127 %ifarch sparc64
128 %patch12 -p1
129 %endif
130 %if %{with advcopy}
131 # progress-bar patch, -g,--progress-bar //if in doubt, comment it out
132 %patch14 -p1
133 %endif
134
135 %{__perl} -pi -e 's@GNU/Linux@PLD Linux@' m4/host-os.m4
136
137 # allow rebuilding *.gmo
138 %{__rm} po/stamp-po
139
140 %build
141 %{__gettextize}
142 %{__aclocal} -I m4
143 %{__autoconf}
144 %{__autoheader}
145 %{__automake}
146 %configure \
147         CFLAGS="%{rpmcflags} -DSYSLOG_SUCCESS -DSYSLOG_FAILURE -DSYSLOG_NON_ROOT" \
148         DEFAULT_POSIX2_VERSION=199209 \
149         --disable-silent-rules \
150         --enable-install-program=arch \
151         --enable-no-install-program=hostname,kill,uptime \
152         --enable-pam
153
154 %{__make}
155
156 %{?with_tests:%{__make} tests check}
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160 install -d $RPM_BUILD_ROOT{/bin,/sbin,%{_bindir},%{_sbindir},/etc/pam.d,/etc/shrc.d}
161
162 %{__make} install \
163         DESTDIR=$RPM_BUILD_ROOT
164
165 mv -f $RPM_BUILD_ROOT%{_bindir}/{arch,basename,cat,chgrp,chmod,chown,cp,date,dd,\
166 df,echo,false,id,link,ln,ls,mkdir,mknod,mktemp,mv,nice,printf,pwd,rm,rmdir,\
167 sleep,sort,stat,stty,sync,touch,true,unlink,uname} $RPM_BUILD_ROOT/bin
168
169 mv -f $RPM_BUILD_ROOT%{_bindir}/chroot $RPM_BUILD_ROOT%{_sbindir}
170
171 # su is missed by "make install" called by non-root
172 install src/su $RPM_BUILD_ROOT/bin
173 install src/runuser $RPM_BUILD_ROOT/sbin
174
175 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
176 install %{SOURCE3} %{SOURCE4} $RPM_BUILD_ROOT/etc/shrc.d
177 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/su
178 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/su-l
179 install %{SOURCE7} $RPM_BUILD_ROOT/etc/pam.d/runuser
180 install %{SOURCE8} $RPM_BUILD_ROOT/etc/pam.d/runuser-l
181
182 cp -a man/pt_BR man/pt
183 for d in cs da de es fi fr hu id it ja ko nl pl pt ru zh_CN ; do
184         install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
185         install man/$d/*.1 $RPM_BUILD_ROOT%{_mandir}/$d/man1
186 done
187 install %{SOURCE9} $RPM_BUILD_ROOT%{_mandir}/pl/man1/mktemp.1
188 # unwanted (-f left intentionally - some manuals could have no translations)
189 rm -f $RPM_BUILD_ROOT%{_mandir}/*/man1/{hostname,kill,uptime}.1
190
191 %find_lang %{name}
192
193 %clean
194 rm -rf $RPM_BUILD_ROOT
195
196 %post   -p /sbin/postshell
197 -/usr/sbin/fix-info-dir -c %{_infodir}
198
199 %postun -p /sbin/postshell
200 -/usr/sbin/fix-info-dir -c %{_infodir}
201
202 %files -f %{name}.lang
203 %defattr(644,root,root,755)
204 %doc AUTHORS ChangeLog NEWS README THANKS THANKS-to-translators TODO
205 %attr(755,root,root) /bin/[!s]*
206 %attr(755,root,root) /bin/s[!u]*
207 %attr(4755,root,root) /bin/su
208 %attr(755,root,root) /sbin/runuser
209 %attr(755,root,root) %{_bindir}/*
210 %attr(755,root,root) %{_sbindir}/chroot
211 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/DIR_COLORS
212 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/su
213 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/su-l
214 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/runuser
215 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/runuser-l
216 %config(noreplace) /etc/shrc.d/fileutils.*sh
217 %dir %{_libdir}/coreutils
218 %attr(755,root,root) %{_libdir}/coreutils/libstdbuf.so
219 %{_mandir}/man1/*
220 %lang(cs) %{_mandir}/cs/man1/*
221 %lang(da) %{_mandir}/da/man1/*
222 %lang(de) %{_mandir}/de/man1/*
223 %lang(es) %{_mandir}/es/man1/*
224 %lang(fi) %{_mandir}/fi/man1/*
225 %lang(fr) %{_mandir}/fr/man1/*
226 %lang(hu) %{_mandir}/hu/man1/*
227 %lang(id) %{_mandir}/id/man1/*
228 %lang(it) %{_mandir}/it/man1/*
229 %lang(ja) %{_mandir}/ja/man1/*
230 %lang(ko) %{_mandir}/ko/man1/*
231 %lang(nl) %{_mandir}/nl/man1/*
232 %lang(pl) %{_mandir}/pl/man1/*
233 %lang(pt) %{_mandir}/pt/man1/*
234 %lang(ru) %{_mandir}/ru/man1/*
235 %lang(zh_CN) %{_mandir}/zh_CN/man1/*
236 %{_infodir}/coreutils.info*
This page took 0.11924 seconds and 3 git commands to generate.