]> git.pld-linux.org Git - packages/coova-chilli.git/commitdiff
This commit was manufactured by cvs2git to create branch 'unlabeled-1.11.2'.
authorcvs2git <feedback@pld-linux.org>
Thu, 14 Oct 2010 11:07:55 +0000 (11:07 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Sprout from master 2010-10-14 11:07:55 UTC sparky <sparky@pld-linux.org> '- added link patch'
Delete:
    link.patch
    strncpy.patch

link.patch [deleted file]
strncpy.patch [deleted file]

diff --git a/link.patch b/link.patch
deleted file mode 100644 (file)
index d8f6f2f..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- coova-chilli-1.2.4/src/Makefile.am~        2010-08-24 13:29:08.000000000 +0200
-+++ coova-chilli-1.2.4/src/Makefile.am 2010-10-14 13:00:28.640702861 +0200
-@@ -24,6 +24,7 @@
- iphash.c lookup3.c sfhash.c lookup.c system.h cmdsock.c util.c \
- garden.c ssl.c dns.c session.c pkt.c chksum.c net.c \
- ms_chap.c options.c statusfile.c conn.c sig.c
-+libchilli_la_LIBADD = $(top_builddir)/bstring/libbstring.la ${LIBRT}
- AM_CFLAGS = -D_GNU_SOURCE -Wall -Werror -fno-builtin -fno-strict-aliasing \
-   -O2 -fomit-frame-pointer -funroll-loops -pipe \
diff --git a/strncpy.patch b/strncpy.patch
deleted file mode 100644 (file)
index a6921f6..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- coova-chilli-1.2.4/src/chilli.c.orig       2010-08-24 13:29:08.000000000 +0200
-+++ coova-chilli-1.2.4/src/chilli.c    2010-09-30 13:26:40.000000000 +0200
-@@ -966,8 +966,15 @@
-     strncpy(appconn->s_state.redir.username, mac, USERNAMESIZE);
--    if (_options.macsuffix)
--      strncat(appconn->s_state.redir.username, _options.macsuffix, USERNAMESIZE);
-+    if (_options.macsuffix) {
-+      size_t ulen = strlen(appconn->s_state.redir.username + ulen);
-+      size_t size = USERNAMESIZE - ulen;
-+
-+      if (size) {
-+        appconn->s_state.redir.username[--size + ulen] = '\0';
-+        strncpy(appconn->s_state.redir.username + ulen, _options.macsuffix, size);
-+      }
-+    }
-   
-     username = appconn->s_state.redir.username;
-   } else {
This page took 0.109664 seconds and 4 git commands to generate.