]> git.pld-linux.org Git - packages/coova-chilli.git/blob - coova-chilli.spec
- package it correctly
[packages/coova-chilli.git] / coova-chilli.spec
1 Summary:        CoovaChilli - Software access controller
2 Name:           coovachilli
3 Version:        1.2.4
4 Release:        0.1
5 License:        GPL
6 Group:          Applications
7 Source0:        http://ap.coova.org/chilli/coova-chilli-%{version}.tar.gz
8 # Source0-md5:  6d942a731da07b029a1be0b58d7917d6
9 Patch0:         %{name}-strncpy.patch
10 URL:            http://coova.org/wiki/index.php/CoovaChilli
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  libtool
14 BuildRequires:  perl-base
15 BuildRequires:  rpmbuild(macros) >= 1.228
16 Requires(post,preun):   /sbin/chkconfig
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Coova-Chilli is a fork of the ChilliSpot project - an open source
21 captive portal or wireless LAN access point controller. It supports
22 web based login (Universal Access Method, or UAM), standard for public
23 HotSpots, and it supports Wireless Protected Access (WPA), the
24 standard for secure roamable networks. Authentication, Authorization
25 and Accounting (AAA) is handled by your favorite radius server. Read
26 more at http://coova.org/ and http://www.chillispot.org/.
27
28 %package devel
29 Summary:        Header files for coovachili library
30 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki coovachilli
31 Group:          Development/Libraries
32 Requires:       %{name} = %{version}-%{release}
33
34 %description devel
35 Header files for coovachilli library.
36
37 %description devel -l pl.UTF-8
38 Pliki nagłówkowe biblioteki coovachilli.
39
40 %package static
41 Summary:        Static coovachilli library
42 Summary(pl.UTF-8):      Statyczna biblioteka coovachilli
43 Group:          Development/Libraries
44 Requires:       %{name}-devel = %{version}-%{release}
45
46 %description static
47 Static coovachilli library.
48
49 %description static -l pl.UTF-8
50 Statyczna biblioteka coovachilli.
51
52 %prep
53 %setup -q -n coova-chilli-%{version}
54
55 %patch0 -p1
56
57 %build
58 %{__libtoolize}
59 %{__aclocal}
60 %{__autoconf}
61 %{__autoheader}
62 %{__automake}
63 %configure
64 %{__make}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 install -d $RPM_BUILD_ROOT/etc/rc.d
70
71 %{__make} install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 mv $RPM_BUILD_ROOT/etc/init.d $RPM_BUILD_ROOT/etc/rc.d
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post
80 /sbin/chkconfig --add chilli
81 %service chilli restart
82
83 %preun
84 if [ "$1" = "0" ]; then
85         %service -q chilli stop
86         /sbin/chkconfig --del chilli
87 fi
88
89 %files
90 %defattr(644,root,root,755)
91 %attr(755,root,root) %{_sbindir}/*
92 %attr(755,root,root) %{_libdir}/*.so*
93 %attr(755,root,root) %ghost %{_libdir}/libbstring.so.0
94 %attr(755,root,root) %{_libdir}/libbstring.so.0.0.0
95 %attr(755,root,root) %ghost %{_libdir}/libchilli.so.0
96 %attr(755,root,root) %{_libdir}/libchilli.so.0.0.0
97 %attr(754,root,root) /etc/rc.d/init.d/chilli
98 %doc AUTHORS COPYING ChangeLog INSTALL README doc/dictionary.chillispot doc/hotspotlogin.cgi
99 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/chilli.conf
100 %dir %{_sysconfdir}/chilli
101 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/chilli/*
102 %attr(755,root,root)%{_sysconfdir}/chilli/www/config.sh
103 %dir %{_sysconfdir}/chilli/www
104 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/chilli/www/*
105 %{_mandir}/man1/*.1*
106 %{_mandir}/man5/*.5*
107 %{_mandir}/man8/*.8*
108
109 %files devel
110 %defattr(644,root,root,755)
111 %{_libdir}/*.la
112 %{_libdir}/libbstring.so
113 %{_libdir}/libchilli.so
114 %{_includedir}/chilli
115
116 %files static
117 %defattr(644,root,root,755)
118 %{_libdir}/*.a
This page took 0.089088 seconds and 3 git commands to generate.