]> git.pld-linux.org Git - packages/coova-chilli.git/blob - coova-chilli.spec
- captive-portal subpackage
[packages/coova-chilli.git] / coova-chilli.spec
1 Summary:        CoovaChilli - Software access controller for hotspots
2 Name:           coova-chilli
3 Version:        1.2.5
4 Release:        0.1
5 License:        GPL
6 Group:          Applications
7 Source0:        http://ap.coova.org/chilli/%{name}-%{version}.tar.gz
8 # Source0-md5:  1b890cb043b4340e1f15c2b2cff742d3
9 Patch0:         link.patch
10 Patch1:         config.patch
11 URL:            http://coova.org/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  libtool
15 BuildRequires:  perl-base
16 BuildRequires:  rpmbuild(macros) >= 1.228
17 Requires(post,preun):   /sbin/chkconfig
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define skip_post_check_so      libchilli.so.0.0.0
21
22 %description
23 Coova-Chilli is a fork of the ChilliSpot project - an open source
24 captive portal or wireless LAN access point controller. It supports
25 web based login (Universal Access Method, or UAM), standard for public
26 HotSpots, and it supports Wireless Protected Access (WPA), the
27 standard for secure roamable networks. Authentication, Authorization
28 and Accounting (AAA) is handled by your favorite radius server. Read
29 more at http://coova.org/ and http://www.chillispot.org/.
30
31 %package captive-portal
32 Summary:        Default captive portal for Coova
33 Group:          Applications
34 Requires:       %{name} = %{version}-%{release}
35 Requires:       haserl
36
37 %description captive-portal
38 Default captive portal for Coova.
39
40 %package -n python-coova-chilli
41 Summary:        Python library for CoovaChilli
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       python-libs
45 Requires:       python-modules
46 Requires:       python-pycairo
47 Requires:       python-pygobject
48 Requires:       python-pygtk-gtk
49
50 %description -n python-coova-chilli
51 Python library for CoovaChilli.
52
53 %package devel
54 Summary:        Header files for coovachili library
55 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki coovachilli
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58
59 %description devel
60 Header files for coovachilli library.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe biblioteki coovachilli.
64
65 %package static
66 Summary:        Static coovachilli library
67 Summary(pl.UTF-8):      Statyczna biblioteka coovachilli
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{version}-%{release}
70
71 %description static
72 Static coovachilli library.
73
74 %description static -l pl.UTF-8
75 Statyczna biblioteka coovachilli.
76
77 %prep
78 %setup -q
79 %patch0 -p1
80 %patch1 -p1
81
82 %build
83 %{__libtoolize}
84 %{__aclocal}
85 %{__autoconf}
86 %{__autoheader}
87 %{__automake}
88 %configure
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 install -d $RPM_BUILD_ROOT/etc/rc.d
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 mv $RPM_BUILD_ROOT%{_sysconfdir}/init.d $RPM_BUILD_ROOT/etc/rc.d
100
101 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
102 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
103 %py_postclean
104
105 install -d $RPM_BUILD_ROOT%{_datadir}/coova-chilli
106 rm $RPM_BUILD_ROOT%{_sysconfdir}/chilli/wwwsh
107 mv $RPM_BUILD_ROOT%{_sysconfdir}/chilli/www $RPM_BUILD_ROOT%{_datadir}/coova-chilli/www
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post
113 /sbin/chkconfig --add chilli
114 %service chilli restart
115
116 %preun
117 if [ "$1" = "0" ]; then
118         %service -q chilli stop
119         /sbin/chkconfig --del chilli
120 fi
121
122 %files
123 %defattr(644,root,root,755)
124 %attr(755,root,root) %{_sbindir}/chilli
125 %attr(755,root,root) %ghost %{_libdir}/libbstring.so.0
126 %attr(755,root,root) %{_libdir}/libbstring.so.0.0.0
127 %attr(755,root,root) %ghost %{_libdir}/libchilli.so.0
128 %attr(755,root,root) %{_libdir}/libchilli.so.0.0.0
129 %attr(754,root,root) /etc/rc.d/init.d/chilli
130 %doc AUTHORS COPYING ChangeLog INSTALL README doc/dictionary.chillispot doc/hotspotlogin.cgi
131 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/chilli.conf
132 %dir %{_sysconfdir}/chilli
133 %attr(755,root,root) %{_sbindir}/chilli_opt
134 %attr(755,root,root) %{_sbindir}/chilli_query
135 %attr(755,root,root) %{_sbindir}/chilli_radconfig
136 %attr(755,root,root) %{_sbindir}/chilli_response
137 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/chilli/*
138 %{_mandir}/man1/*.1*
139 %{_mandir}/man5/*.5*
140 %{_mandir}/man8/*.8*
141
142 %files captive-portal
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_datadir}/coova-chilli/www/*.sh
145 %{_datadir}/coova-chilli/www/*.chi
146 %{_datadir}/coova-chilli/www/*.gif
147 %{_datadir}/coova-chilli/www/*.html
148 %{_datadir}/coova-chilli/www/*.jpg
149 %{_datadir}/coova-chilli/www/*.js
150 %{_datadir}/coova-chilli/www/*.png
151 %{_datadir}/coova-chilli/www/*.tmpl
152
153 %files -n python-%{name}
154 %defattr(644,root,root,755)
155 %{_libdir}/python/CoovaChilliLib.py
156
157 %files devel
158 %defattr(644,root,root,755)
159 %{_libdir}/*.la
160 %{_libdir}/libbstring.so
161 %{_libdir}/libchilli.so
162 %{_includedir}/chilli
163
164 %files static
165 %defattr(644,root,root,755)
166 %{_libdir}/*.a
This page took 0.441505 seconds and 3 git commands to generate.