]> git.pld-linux.org Git - packages/coova-chilli.git/blob - coova-chilli.spec
- even better location for www
[packages/coova-chilli.git] / coova-chilli.spec
1 Summary:        CoovaChilli - Software access controller for hotspots
2 Name:           coova-chilli
3 Version:        1.2.5
4 Release:        0.1
5 License:        GPL
6 Group:          Applications
7 Source0:        http://ap.coova.org/chilli/coova-chilli-%{version}.tar.gz
8 # Source0-md5:  1b890cb043b4340e1f15c2b2cff742d3
9 Patch0:         link.patch
10 URL:            http://coova.org/
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  libtool
14 BuildRequires:  perl-base
15 BuildRequires:  rpmbuild(macros) >= 1.228
16 Suggests:       haserl
17 Requires(post,preun):   /sbin/chkconfig
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define skip_post_check_so      libchilli.so.0.0.0
21
22 %description
23 Coova-Chilli is a fork of the ChilliSpot project - an open source
24 captive portal or wireless LAN access point controller. It supports
25 web based login (Universal Access Method, or UAM), standard for public
26 HotSpots, and it supports Wireless Protected Access (WPA), the
27 standard for secure roamable networks. Authentication, Authorization
28 and Accounting (AAA) is handled by your favorite radius server. Read
29 more at http://coova.org/ and http://www.chillispot.org/.
30
31 %package -n python-coova-chilli
32 Summary:        Python library for CoovaChilli
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}-%{release}
35 Requires:       python-libs
36 Requires:       python-modules
37 Requires:       python-pycairo
38 Requires:       python-pygobject
39 Requires:       python-pygtk-gtk
40
41 %description -n python-coova-chilli
42 Python library for CoovaChilli.
43
44 %package devel
45 Summary:        Header files for coovachili library
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki coovachilli
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49
50 %description devel
51 Header files for coovachilli library.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe biblioteki coovachilli.
55
56 %package static
57 Summary:        Static coovachilli library
58 Summary(pl.UTF-8):      Statyczna biblioteka coovachilli
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static coovachilli library.
64
65 %description static -l pl.UTF-8
66 Statyczna biblioteka coovachilli.
67
68 %prep
69 %setup -q -n coova-chilli-%{version}
70 %patch0 -p1
71
72 %build
73 %{__libtoolize}
74 %{__aclocal}
75 %{__autoconf}
76 %{__autoheader}
77 %{__automake}
78 %configure
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 install -d $RPM_BUILD_ROOT/etc/rc.d
85
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 mv $RPM_BUILD_ROOT/etc/init.d $RPM_BUILD_ROOT/etc/rc.d
90
91 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
92 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
93 %py_postclean
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post
99 /sbin/chkconfig --add chilli
100 %service chilli restart
101
102 %preun
103 if [ "$1" = "0" ]; then
104         %service -q chilli stop
105         /sbin/chkconfig --del chilli
106 fi
107
108 %files
109 %defattr(644,root,root,755)
110 %attr(755,root,root) %{_sbindir}/chilli
111 %attr(755,root,root) %ghost %{_libdir}/libbstring.so.0
112 %attr(755,root,root) %{_libdir}/libbstring.so.0.0.0
113 %attr(755,root,root) %ghost %{_libdir}/libchilli.so.0
114 %attr(755,root,root) %{_libdir}/libchilli.so.0.0.0
115 %attr(754,root,root) /etc/rc.d/init.d/chilli
116 %doc AUTHORS COPYING ChangeLog INSTALL README doc/dictionary.chillispot doc/hotspotlogin.cgi
117 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/chilli.conf
118 %dir %{_sysconfdir}/chilli
119 %attr(755,root,root) %{_sbindir}/chilli_opt
120 %attr(755,root,root) %{_sbindir}/chilli_query
121 %attr(755,root,root) %{_sbindir}/chilli_radconfig
122 %attr(755,root,root) %{_sbindir}/chilli_response
123 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/chilli/*
124 %attr(755,root,root)%{_sysconfdir}/chilli/www/config.sh
125 %if 0
126 %dir %{_sysconfdir}/chilli/www
127 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/chilli/www/*
128 %endif
129 %{_mandir}/man1/*.1*
130 %{_mandir}/man5/*.5*
131 %{_mandir}/man8/*.8*
132
133 %files -n python-%{name}
134 /usr/lib/python/CoovaChilliLib.py
135
136 %files devel
137 %defattr(644,root,root,755)
138 %{_libdir}/*.la
139 %{_libdir}/libbstring.so
140 %{_libdir}/libchilli.so
141 %{_includedir}/chilli
142
143 %files static
144 %defattr(644,root,root,755)
145 %{_libdir}/*.a
This page took 0.072807 seconds and 3 git commands to generate.