]> git.pld-linux.org Git - packages/coova-chilli.git/blob - coova-chilli.spec
- better fix for buffer overflow problem (inspired by svn trunk)
[packages/coova-chilli.git] / coova-chilli.spec
1 Summary:        CoovaChilli - Software access controller
2 Name:           coovachilli
3 Version:        1.2.4
4 Release:        0.1
5 License:        GPL
6 Group:          Applications
7 Source0:        http://ap.coova.org/chilli/coova-chilli-%{version}.tar.gz
8 # Source0-md5:  6d942a731da07b029a1be0b58d7917d6
9 Patch0:         %{name}-limits.patch
10 URL:            http://coova.org/wiki/index.php/CoovaChilli
11 BuildRequires:  perl-base
12 BuildRequires:  rpmbuild(macros) >= 1.228
13 Requires(post,preun):   /sbin/chkconfig
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 Coova-Chilli is a fork of the ChilliSpot project - an open source
18 captive portal or wireless LAN access point controller. It supports
19 web based login (Universal Access Method, or UAM), standard for public
20 HotSpots, and it supports Wireless Protected Access (WPA), the
21 standard for secure roamable networks. Authentication, Authorization
22 and Accounting (AAA) is handled by your favorite radius server. Read
23 more at http://coova.org/ and http://www.chillispot.org/.
24
25 %prep
26 %setup -q -n coova-chilli-%{version}
27
28 %patch0 -p1
29
30 %build
31 %configure
32 %{__make}
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36
37 install -d $RPM_BUILD_ROOT/etc/rc.d
38
39 %{__make} install \
40         DESTDIR=$RPM_BUILD_ROOT
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %post
46 /sbin/chkconfig --add chilli
47 %service chilli restart
48
49 %preun
50 if [ "$1" = "0" ]; then
51         %service -q chilli stop
52         /sbin/chkconfig --del chilli
53 fi
54
55 %files
56 %defattr(644,root,root,755)
57 %attr(755,root,root) %{_sbindir}/*
58 %attr(755,root,root) %{_libdir}/*.so*
59 %attr(754,root,root) /etc/init.d/chilli
60 %doc AUTHORS COPYING ChangeLog INSTALL README doc/dictionary.chillispot doc/hotspotlogin.cgi
61 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/chilli.conf
62 %dir %{_sysconfdir}/chilli
63 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/chilli/*
64 %attr(755,root,root)%{_sysconfdir}/chilli/www/config.sh
65 %dir %{_sysconfdir}/chilli/www
66 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/chilli/www/*
67 %{_mandir}/man1/*.1*
68 %{_mandir}/man5/*.5*
69 %{_mandir}/man8/*.8*
This page took 0.132413 seconds and 3 git commands to generate.