]> git.pld-linux.org Git - packages/coova-chilli.git/blob - coova-chilli.spec
- skip_post_check_so in libchilli. _options symbol needs to be defined in a
[packages/coova-chilli.git] / coova-chilli.spec
1 Summary:        CoovaChilli - Software access controller
2 Name:           coovachilli
3 Version:        1.2.5
4 Release:        0.1
5 License:        GPL
6 Group:          Applications
7 Source0:        http://ap.coova.org/chilli/coova-chilli-%{version}.tar.gz
8 # Source0-md5:  1b890cb043b4340e1f15c2b2cff742d3
9 Patch0:         %{name}-link.patch
10 URL:            http://coova.org/
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  libtool
14 BuildRequires:  perl-base
15 BuildRequires:  rpmbuild(macros) >= 1.228
16 Suggests:       haserl
17 Requires(post,preun):   /sbin/chkconfig
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define skip_post_check_so      libchilli.so.0.0.0
21
22 %description
23 Coova-Chilli is a fork of the ChilliSpot project - an open source
24 captive portal or wireless LAN access point controller. It supports
25 web based login (Universal Access Method, or UAM), standard for public
26 HotSpots, and it supports Wireless Protected Access (WPA), the
27 standard for secure roamable networks. Authentication, Authorization
28 and Accounting (AAA) is handled by your favorite radius server. Read
29 more at http://coova.org/ and http://www.chillispot.org/.
30
31 %package devel
32 Summary:        Header files for coovachili library
33 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki coovachilli
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36
37 %description devel
38 Header files for coovachilli library.
39
40 %description devel -l pl.UTF-8
41 Pliki nagłówkowe biblioteki coovachilli.
42
43 %package static
44 Summary:        Static coovachilli library
45 Summary(pl.UTF-8):      Statyczna biblioteka coovachilli
46 Group:          Development/Libraries
47 Requires:       %{name}-devel = %{version}-%{release}
48
49 %description static
50 Static coovachilli library.
51
52 %description static -l pl.UTF-8
53 Statyczna biblioteka coovachilli.
54
55 %prep
56 %setup -q -n coova-chilli-%{version}
57 %patch0 -p1
58
59 %build
60 %{__libtoolize}
61 %{__aclocal}
62 %{__autoconf}
63 %{__autoheader}
64 %{__automake}
65 %configure
66 %{__make}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 install -d $RPM_BUILD_ROOT/etc/rc.d
72
73 %{__make} install \
74         DESTDIR=$RPM_BUILD_ROOT
75
76 mv $RPM_BUILD_ROOT/etc/init.d $RPM_BUILD_ROOT/etc/rc.d
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post
82 /sbin/chkconfig --add chilli
83 %service chilli restart
84
85 %preun
86 if [ "$1" = "0" ]; then
87         %service -q chilli stop
88         /sbin/chkconfig --del chilli
89 fi
90
91 %files
92 %defattr(644,root,root,755)
93 %attr(755,root,root) %{_sbindir}/*
94 %attr(755,root,root) %{_libdir}/*.so*
95 %attr(755,root,root) %ghost %{_libdir}/libbstring.so.0
96 %attr(755,root,root) %{_libdir}/libbstring.so.0.0.0
97 %attr(755,root,root) %ghost %{_libdir}/libchilli.so.0
98 %attr(755,root,root) %{_libdir}/libchilli.so.0.0.0
99 %attr(754,root,root) /etc/rc.d/init.d/chilli
100 %doc AUTHORS COPYING ChangeLog INSTALL README doc/dictionary.chillispot doc/hotspotlogin.cgi
101 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/chilli.conf
102 %dir %{_sysconfdir}/chilli
103 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/chilli/*
104 %attr(755,root,root)%{_sysconfdir}/chilli/www/config.sh
105 %dir %{_sysconfdir}/chilli/www
106 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/chilli/www/*
107 %{_mandir}/man1/*.1*
108 %{_mandir}/man5/*.5*
109 %{_mandir}/man8/*.8*
110
111 %files devel
112 %defattr(644,root,root,755)
113 %{_libdir}/*.la
114 %{_libdir}/libbstring.so
115 %{_libdir}/libchilli.so
116 %{_includedir}/chilli
117
118 %files static
119 %defattr(644,root,root,755)
120 %{_libdir}/*.a
This page took 0.0554829999999999 seconds and 3 git commands to generate.