]> git.pld-linux.org Git - packages/cooledit.git/blob - cooledit.spec
- use more macros, some cosmetics, added missing "rm -f missing" and use new %doc
[packages/cooledit.git] / cooledit.spec
1 Summary:        Full featured multiple window programmer's text editor
2 Summary(pl):    Funkcjonalny edytor tekstu dla programistów
3 Name:           cooledit
4 Version:        3.14.2
5 Release:        1
6 License:        GPL
7 Group:          Applications/Editors
8 Source0:        ftp://sunsite.unc.edu/pub/Linux/apps/editors/X/%{name}-%{version}.tar.gz
9 Patch0:         %{name}-install.patch
10 Icon:           cooledit.gif
11 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14
15 %description
16 Full-featured X Window text editor; multiple edit windows; 3D
17 Motif-ish look and feel; shift-arrow and mouse text highlighting;
18 column text highlighting and manipulation; key for key undo; macro
19 recording; regular expression search and replace; pull-down menus;
20 drag and drop; interactive man page browser; run make and other shell
21 commands with seamless shell interface; redefine keys with an easy
22 interactive key learner; syntax highlighting for various file types;
23 full support for proportional fonts.
24
25 %description -l pl
26 Cooledit to pe³nowarto¶ciowy edytor tekstowy dla X Window. Jego
27 najistotniejsze cechy to: obs³uga wielu okien edycyjnych, zaznaczanie
28 tekstu za pomoc± shift-strza³ek i myszki, motifowy wygl±d, kolumnowe
29 zaznaczanie i modyfikacja tekstu, wielopoziomowe undo, nagrywanie
30 makr, wyszykaj i zamieñ za pomoc± wyra¿eñ regularnych, menu,
31 przeci±gnij i upu¶æ, interaktywna przegl±darka stron podrêcznika
32 systemowego (man), uruchamianie make oraz innych komend za pomoc±
33 zintegrowanego interfejsu pow³oki, redefiniowanie klawiszy za pomoc±
34 interaktywnego narzêdzia, pod¶wietlanie sk³adni rozmaitych typów
35 plików, pe³na obs³uga fontów proporcjonalnych.
36
37 %prep
38 %setup -q -T -c -D
39 (cd ..
40 gzip -dc %{SOURCE0} | tar -x --no-same-permission -f -
41 chmod -R +X %{name}-%{version})
42 %patch -p1
43
44 %build
45 %{__aclocal}
46 %{__autoconf}
47 %configure
48 %{__make}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 %{__make} install DESTDIR=$RPM_BUILD_ROOT
53
54 gzip -9nf ABOUT-NLS AUTHORS BUGS FAQ INTERNATIONAL \
55         MAILING_LIST NEWS PROGRAMMING README TODO VERSION ChangeLog \
56         cooledit.lsm coolicon.lsm coolman.lsm
57
58 %find_lang %{name}
59
60 %post
61  check if the command is already present:
62 if test -z "`grep coolicon %{_libdir}/X11/xinit/Xclients`" ; then
63  estimate the speed of this machine:
64     BOGOMIPS=`cat /proc/cpuinfo | grep bogomips | sed -e 's/^[^0-9]*//' -e 's/\..*$//'`
65     BOGOMIPS="$BOGOMIPS"
66     if test -z "$BOGOMIPS" ; then
67         BOGOMIPS=50
68     fi
69     if test "$BOGOMIPS" -gt "500" ; then
70         BOGOMIPS=500
71     fi
72  add use of shape extension if this is a fast machine:
73     if test "$BOGOMIPS" -gt "80" ; then
74         COOLICON_OPTIONS="-s -X $BOGOMIPS"
75     else
76         COOLICON_OPTIONS="-X $BOGOMIPS"
77     fi
78
79     cat > temp.Xclients <<EOF
80 #!/bin/bash
81
82  coolicon needs an existing mail file, even if it is empty
83 MAILFILE=/var/spool/mail/\$LOGNAME
84 if test -f \$MAILFILE ; then
85     cat /dev/null
86 else
87     cat /dev/null > \$MAILFILE
88     chmod 0600 \$MAILFILE
89 fi
90 coolicon $COOLICON_OPTIONS -M \$MAILFILE 2>&1 | coolmessage &
91
92 EOF
93     cat temp.Xclients %{_libdir}/X11/xinit/Xclients > temp2.Xclients
94     cp temp2.Xclients %{_libdir}/X11/xinit/Xclients
95     chmod 0755 %{_libdir}/X11/xinit/Xclients
96     rm temp.Xclients temp2.Xclients
97 fi
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %files -f %{name}.lang
103 %defattr(644,root,root,755)
104 %doc {ABOUT-NLS,AUTHORS,BUGS,FAQ,INTERNATIONAL}.gz
105 %doc {MAILING_LIST,NEWS,PROGRAMMING,README,TODO,VERSION,ChangeLog}.gz
106 %doc {cooledit.lsm,coolicon.lsm,coolman.lsm}.gz
107
108 %attr(755,root,root) %{_libdir}/libCw.so*
109 %attr(755,root,root) %{_bindir}/*
110
111 %{_libdir}/libCw.la
112 %{_libdir}/libCw.a
113
114 %{_libdir}/coolicon/*
115 %{_libdir}/cooledit/*
116
117 %{_mandir}/man1/*
This page took 0.083986 seconds and 3 git commands to generate.