]> git.pld-linux.org Git - packages/cook.git/blob - cook.spec
- removed Group translations
[packages/cook.git] / cook.spec
1 Summary:        A file construction tool
2 Summary(pl):    Narzêdzie do konstrukcji plików
3 Name:           cook
4 Version:        2.19
5 Release:        1
6 License:        GPL
7 Group:          Development/Building
8 Source0:        http://www.canb.auug.org.au/~millerp/cook/%{name}-%{version}.tar.gz
9 URL:            http://www.canb.auug.org.au/~millerp/cook/
10 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11
12 %description
13 Cook is a tool for constructing files. It is given a set of files to
14 create, and recipes of how to create them. In any non-trivial program
15 there will be prerequisites to performing the actions necessary to
16 creating any file, such as include files. The cook program provides a
17 mechanism to define these.
18
19 When a program is being developed or maintained, the programmer will
20 typically change one file of several which comprise the program. Cook
21 examines the last-modified times of the files to see when the
22 prerequisites of a file have changed, implying that the file needs to
23 be recreated as it is logically out of date.
24
25 Cook also provides a facility for implicit recipes, allowing users to
26 specify how to form a file with a given suffix from a file with a
27 different suffix. For example, to create filename.o from filename.c
28
29 - Cook is a replacement for the traditional make(1) tool. However, it
30   is necessary to convert makefiles into cookbooks using the make2cook
31   utility included in the distribution.
32
33 - Cook has a simple but powerful string-based description language
34   with many built-in functions. This allows sophisticated filename
35   specification and manipulation without loss of readability or
36   performance.
37
38 - Cook is able to use fingerprints to supplement file modification
39   times. This allows build optimization without contorted rules.
40
41 - Cook is able to build your project with multiple parallel threads,
42   with support for rules which must be single threaded. It is possible
43   to distribute parallel builds over your LAN, allowing you to turn your
44   network into a virtual parallel build engine.
45
46 If you are putting together a source-code distribution and planning to
47 write a makefile, consider writing a cookbook instead. Although Cook
48 takes a day or two to learn, it is much more powerful and a bit more
49 intuitave than the traditional make(1) tool. And Cook doesn't
50 interpret tab differently to 8 space characters!
51
52 %description -l pl
53 Cook jest narzêdziem do budowania plików. Podaje mu siê zbiór plików do
54 utworzenia i przepisy, jak je tworzyæ.
55
56 %package doc-ps
57 Summary:        Cook documentation, PostScript format
58 Summary(pl):    Dokumentacja do cooka w formacie PostScript
59 Group:          Development/Building
60
61 %description doc-ps
62 Cook documentation in PostScript format.
63
64 %description doc-ps -l pl
65 Dokumentacja do cooka w formacie PostScript.
66
67 %prep
68 %setup -q
69
70 %build
71 %configure2_13
72 %{__make}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %{__make} RPM_BUILD_ROOT=$RPM_BUILD_ROOT install
78 rm -rf $RPM_BUILD_ROOT%{_datadir}/cook/en
79
80 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
81 install cook.gif $RPM_BUILD_ROOT%{_pixmapsdir}
82
83 gzip -9nf README lib/en/*.{ps,txt}
84
85 %files
86 %defattr(644,root,root,755)
87 %doc *.gz lib/en/*.txt.gz 
88 %attr(0755,root,root) %{_bindir}/*
89 %{_libdir}/cook
90 %{_datadir}/cook
91 %{_mandir}/man*/*
92 %{_pixmapsdir}/cook.gif
93
94 %files doc-ps
95 %defattr(644,root,root,755)
96 %doc lib/en/*.ps.gz
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
This page took 0.057424 seconds and 4 git commands to generate.