]> git.pld-linux.org Git - packages/cook.git/blob - cook.spec
a6126274a5c12d645d433dd501b43270f0d46fae
[packages/cook.git] / cook.spec
1 Summary:        A file construction tool
2 Summary(pl):    Narzêdzie do konstrukcji plików
3 Name:           cook
4 Version:        2.19
5 Release:        1
6 License:        GPL
7 Group:          Development/Building
8 Group(de):      Entwicklung/Bauen
9 Group(pl):      Programowanie/Budowanie
10 Source0:        http://www.canb.auug.org.au/~millerp/cook/%{name}-%{version}.tar.gz
11 URL:            http://www.canb.auug.org.au/~millerp/cook
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description
15 Cook is a tool for constructing files. It is given a set of files to
16 create, and recipes of how to create them. In any non-trivial program
17 there will be prerequisites to performing the actions necessary to
18 creating any file, such as include files. The cook program provides a
19 mechanism to define these.
20
21 When a program is being developed or maintained, the programmer will
22 typically change one file of several which comprise the program. Cook
23 examines the last-modified times of the files to see when the
24 prerequisites of a file have changed, implying that the file needs to
25 be recreated as it is logically out of date.
26
27 Cook also provides a facility for implicit recipes, allowing users to
28 specify how to form a file with a given suffix from a file with a
29 different suffix. For example, to create filename.o from filename.c
30
31 - Cook is a replacement for the traditional make(1) tool. However, it
32   is necessary to convert makefiles into cookbooks using the make2cook
33   utility included in the distribution.
34
35 - Cook has a simple but powerful string-based description language
36   with many built-in functions. This allows sophisticated filename
37   specification and manipulation without loss of readability or
38   performance.
39
40 - Cook is able to use fingerprints to supplement file modification
41   times. This allows build optimization without contorted rules.
42
43 - Cook is able to build your project with multiple parallel threads,
44   with support for rules which must be single threaded. It is possible
45   to distribute parallel builds over your LAN, allowing you to turn your
46   network into a virtual parallel build engine.
47
48 If you are putting together a source-code distribution and planning to
49 write a makefile, consider writing a cookbook instead. Although Cook
50 takes a day or two to learn, it is much more powerful and a bit more
51 intuitave than the traditional make(1) tool. And Cook doesn't
52 interpret tab differently to 8 space characters!
53
54 %description -l pl
55 Cook jest narzêdziem do budowania plików. Podaje mu siê zbiór plików do
56 utworzenia i przepisy, jak je tworzyæ.
57
58 %package doc-ps
59 Summary:        Cook documentation, PostScript format
60 Summary(pl):    Dokumentacja do cook'a w formacie PostScript
61 Group:          Development/Building
62 Group(de):      Entwicklung/Bauen
63 Group(pl):      Programowanie/Budowanie
64
65 %description doc-ps
66 Cook documentation in PostScript format.
67
68 %description -l pl doc-ps
69 Dokumentacja do cook'a w formacie PostScript.
70
71 %prep
72 %setup -q
73
74 %build
75 %configure2_13
76 %{__make}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 %{__make} RPM_BUILD_ROOT=$RPM_BUILD_ROOT install
82 rm -rf $RPM_BUILD_ROOT%{_datadir}/cook/en
83
84 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
85 install cook.gif $RPM_BUILD_ROOT%{_pixmapsdir}
86
87 gzip -9nf README lib/en/*.{ps,txt}
88
89 %files
90 %defattr(644,root,root,755)
91 %doc *.gz lib/en/*.txt.gz 
92 %attr(0755,root,root) %{_bindir}/*
93 %{_libdir}/cook
94 %{_datadir}/cook
95 %{_mandir}/man*/*
96 %{_pixmapsdir}/cook.gif
97
98 %files doc-ps
99 %defattr(644,root,root,755)
100 %doc lib/en/*.ps.gz
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
This page took 0.037958 seconds and 2 git commands to generate.