]> git.pld-linux.org Git - packages/control-center.git/commitdiff
this files are missing in gnome-utils tarball
authorArtur Frysiak <artur@frysiak.net>
Thu, 23 May 2002 15:32:46 +0000 (15:32 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    omf.make -> 1.1
    xmldocs.make -> 1.1

omf.make [new file with mode: 0644]
xmldocs.make [new file with mode: 0644]

diff --git a/omf.make b/omf.make
new file mode 100644 (file)
index 0000000..3261e00
--- /dev/null
+++ b/omf.make
@@ -0,0 +1,53 @@
+# 
+# No modifications of this Makefile should be necessary.
+#
+# This file contains the build instructions for installing OMF files.  It is
+# generally called from the makefiles for particular formats of documentation.
+#
+# Note that you must configure your package with --localstatedir=/var/lib
+# so that the scrollkeeper-update command below will update the database
+# in the standard scrollkeeper directory.
+#
+# If it is impossible to configure with --localstatedir=/var/lib, then
+# modify the definition of scrollkeeper_localstate_dir so that
+# it points to the correct location. Note that you must still use 
+# $(localstatedir) in this or when people build RPMs it will update
+# the real database on their system instead of the one under RPM_BUILD_ROOT.
+#
+# Note: This make file is not incorporated into xmldocs.make because, in
+#       general, there will be other documents install besides XML documents
+#       and the makefiles for these formats should also include this file.
+#
+# About this file:
+#      This file was taken from scrollkeeper_example2, a package illustrating
+#      how to install documentation and OMF files for use with ScrollKeeper
+#      0.3.x and 0.4.x.  For more information, see:
+#              http://scrollkeeper.sourceforge.net/    
+#      Version: 0.1.2 (last updated: March 20, 2002)
+#
+
+omf_dest_dir=$(datadir)/omf/@PACKAGE@
+scrollkeeper_localstate_dir = $(localstatedir)/scrollkeeper
+
+omf: omf_timestamp
+
+omf_timestamp: $(omffile)
+       -for file in $(omffile); do \
+         scrollkeeper-preinstall $(docdir)/$(docname).xml $(srcdir)/$$file $$file.out; \
+       done
+       touch omf_timestamp
+
+install-data-hook-omf:
+       $(mkinstalldirs) $(DESTDIR)$(omf_dest_dir)
+       for file in $(omffile); do \
+               $(INSTALL_DATA) $$file.out $(DESTDIR)$(omf_dest_dir)/$$file; \
+       done
+       -scrollkeeper-update -p $(scrollkeeper_localstate_dir) -o $(DESTDIR)$(omf_dest_dir)
+
+uninstall-local-omf:
+       -for file in $(srcdir)/*.omf; do \
+               basefile=`basename $$file`; \
+               rm -f $(omf_dest_dir)/$$basefile; \
+       done
+       -rmdir $(omf_dest_dir)
+       -scrollkeeper-update -p $(scrollkeeper_localstate_dir)
diff --git a/xmldocs.make b/xmldocs.make
new file mode 100644 (file)
index 0000000..9f78af7
--- /dev/null
@@ -0,0 +1,95 @@
+#
+# No modifications of this Makefile should be necessary.
+#
+# To use this template:
+#     1) Define: figdir, docname, lang, omffile, and entities in
+#        your Makefile.am file for each document directory,
+#        although figdir, omffile, and entities may be empty
+#     2) Make sure the Makefile in (1) also includes 
+#       "include $(top_srcdir)/xmldocs.make" and
+#       "dist-hook: app-dist-hook".
+#     3) Optionally define 'entities' to hold xml entities which
+#        you would also like installed
+#     4) Figures must go under $(figdir)/ and be in PNG format
+#     5) You should only have one document per directory 
+#     6) Note that the figure directory, $(figdir)/, should not have its
+#        own Makefile since this Makefile installs those figures.
+#
+# example Makefile.am:
+#   figdir = figures
+#   docname = scrollkeeper-manual
+#   lang = C
+#   omffile=scrollkeeper-manual-C.omf
+#   entities = fdl.xml
+#   include $(top_srcdir)/xmldocs.make
+#   dist-hook: app-dist-hook
+#
+# About this file:
+#      This file was taken from scrollkeeper_example2, a package illustrating
+#      how to install documentation and OMF files for use with ScrollKeeper 
+#      0.3.x and 0.4.x.  For more information, see:
+#              http://scrollkeeper.sourceforge.net/
+#      Version: 0.1.2 (last updated: March 20, 2002)
+#
+
+
+# ************* Begin of section some packagers may need to modify  **************
+# This variable (docdir) specifies where the documents should be installed.
+# This default value should work for most packages.
+# docdir = $(datadir)/@PACKAGE@/doc/$(docname)/$(lang)
+docdir = $(datadir)/gnome/help/$(docname)/$(lang)
+
+# **************  You should not have to edit below this line  *******************
+xml_files = $(entities) $(docname).xml
+
+EXTRA_DIST = $(xml_files) $(omffile)
+CLEANFILES = omf_timestamp
+
+include $(top_srcdir)/omf.make
+
+all: omf
+
+$(docname).xml: $(entities)
+       -ourdir=`pwd`;  \
+       cd $(srcdir);   \
+       cp $(entities) $$ourdir
+
+app-dist-hook:
+       if test "$(figdir)"; then \
+         $(mkinstalldirs) $(distdir)/$(figdir); \
+         for file in $(srcdir)/$(figdir)/*.png; do \
+           basefile=`echo $$file | sed -e  's,^.*/,,'`; \
+           $(INSTALL_DATA) $$file $(distdir)/$(figdir)/$$basefile; \
+         done \
+       fi
+
+install-data-local: omf
+       $(mkinstalldirs) $(DESTDIR)$(docdir)
+       for file in $(xml_files); do \
+         cp $(srcdir)/$$file $(DESTDIR)$(docdir); \
+       done
+       if test "$(figdir)"; then \
+         $(mkinstalldirs) $(DESTDIR)$(docdir)/$(figdir); \
+         for file in $(srcdir)/$(figdir)/*.png; do \
+           basefile=`echo $$file | sed -e  's,^.*/,,'`; \
+           $(INSTALL_DATA) $$file $(DESTDIR)$(docdir)/$(figdir)/$$basefile; \
+         done \
+       fi
+
+install-data-hook: install-data-hook-omf
+
+uninstall-local: uninstall-local-doc uninstall-local-omf
+
+uninstall-local-doc:
+       -if test "$(figdir)"; then \
+         for file in $(srcdir)/$(figdir)/*.png; do \
+           basefile=`echo $$file | sed -e  's,^.*/,,'`; \
+           rm -f $(docdir)/$(figdir)/$$basefile; \
+         done; \
+         rmdir $(DESTDIR)$(docdir)/$(figdir); \
+       fi
+       -for file in $(xml_files); do \
+         rm -f $(DESTDIR)$(docdir)/$$file; \
+       done
+       -rmdir $(DESTDIR)$(docdir)
+
This page took 0.064224 seconds and 4 git commands to generate.