]> git.pld-linux.org Git - packages/control-center.git/commitdiff
This commit was manufactured by cvs2git to create branch 'DEVEL'.
authorcvs2git <feedback@pld-linux.org>
Sun, 14 Aug 2005 21:33:05 +0000 (21:33 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Cherrypick from master 2005-08-14 21:33:05 UTC freetz <freetz@pld-linux.org> '- pangoxft fix':
    control-center-def-apps-capplet-browsers.patch -> 1.4
    control-center-def-apps-capplet.patch -> 1.2
    control-center-pangoxft_fix.patch -> 1.1
    control-center-xft-hack.patch -> 1.1

control-center-def-apps-capplet-browsers.patch [new file with mode: 0644]
control-center-def-apps-capplet.patch [new file with mode: 0644]
control-center-pangoxft_fix.patch [new file with mode: 0644]
control-center-xft-hack.patch [new file with mode: 0644]

diff --git a/control-center-def-apps-capplet-browsers.patch b/control-center-def-apps-capplet-browsers.patch
new file mode 100644 (file)
index 0000000..927e414
--- /dev/null
@@ -0,0 +1,11 @@
+--- control-center-2.8.1/capplets/default-applications/gnome-default-applications-properties-structs.c.orig    2004-10-14 19:35:56.000000000 +0200
++++ control-center-2.8.1/capplets/default-applications/gnome-default-applications-properties-structs.c 2004-10-15 11:55:15.065483960 +0200
+@@ -10,7 +10,7 @@
+         { N_("Galeon"),               "galeon",       "galeon %s",            FALSE, FALSE },
+         { N_("Encompass"),            "encompass",    "encompass %s",         FALSE, FALSE },
+         { N_("Firebird"),       "mozilla-firebird",  "mozilla-firebird %s",  FALSE, FALSE },
+-        { N_("Firefox"),      "firefox",      "firefox %s",   FALSE, FALSE },
++        { N_("Firefox"),      "mozilla-firefox",      "mozilla-firefox %s",   FALSE, FALSE },
+         { N_("Mozilla"),      "mozilla-1.6",  "mozilla-1.6 %s",       FALSE, FALSE },
+         { N_("Mozilla"),      "mozilla",      "mozilla %s",           FALSE, FALSE },
+         { N_("Netscape Communicator"),        "netscape",     "netscape %s",          FALSE, FALSE },
diff --git a/control-center-def-apps-capplet.patch b/control-center-def-apps-capplet.patch
new file mode 100644 (file)
index 0000000..0c24729
--- /dev/null
@@ -0,0 +1,96 @@
+diff -Nuard control-center-2.4.0.orig/capplets/default-applications/gnome-default-applications-properties.c control-center-2.4.0/capplets/default-applications/gnome-default-applications-properties.c
+--- control-center-2.4.0.orig/capplets/default-applications/gnome-default-applications-properties.c    2003-08-01 21:45:43.000000000 +0200
++++ control-center-2.4.0/capplets/default-applications/gnome-default-applications-properties.c 2003-09-11 23:20:24.000000000 +0200
+@@ -259,7 +259,7 @@
+               if (strcmp (mime_app->command, li_app->command) == 0 &&
+                   mime_app->requires_terminal == li_app->requires_terminal) {
+                       gtk_entry_set_text (GTK_ENTRY (WID ("text_select_combo_entry")), _(mime_app->name));
+-                      gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (WID ("text_custom_radio")), TRUE);
++                      gtk_widget_set_sensitive(WID ("text_select_combo") ,TRUE);
+                       gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (WID ("text_select_radio")), TRUE);
+                       gnome_vfs_mime_application_free (mime_app);
+                       return;
+@@ -279,8 +279,9 @@
+       gnome_vfs_mime_set_default_application ("text/plain", mime_app->id);
+       gnome_vfs_application_registry_sync (); 
++      
++      
+  read_editor_custom:
+-      gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (WID ("text_select_radio")), TRUE);
+       gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (WID ("text_custom_radio")), TRUE);
+       if (mime_app)
+               gnome_vfs_mime_application_free (mime_app);
+@@ -388,19 +389,20 @@
+       for (i = 0; i < G_N_ELEMENTS (possible_browsers); i++ ) {
+               if (possible_browsers[i].in_path == FALSE)
+                       continue;
+-
+-              if (browser && strcmp (browser, possible_browsers[i].command) == 0 &&
+-                  needs_term == possible_browsers[i].needs_term) {
++
++              if (browser && (strcmp (browser, possible_browsers[i].command) == 0)
++              &&   needs_term == possible_browsers[i].needs_term) {
+                       gtk_entry_set_text (GTK_ENTRY (WID ("web_select_combo_entry")),
+                                           _(possible_browsers[i].name));
+-                      gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (WID ("web_custom_radio")), TRUE);
++                                          
++                      gtk_widget_set_sensitive (WID ("web_select_combo"), TRUE);
+                       gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (WID ("web_select_radio")), TRUE);
+                       g_free (browser);
+                       return;
+               }
+         }
+-      gtk_toggle_button_set_inconsistent (GTK_TOGGLE_BUTTON (WID ("web_select_radio")), TRUE);
+-      gtk_toggle_button_set_inconsistent (GTK_TOGGLE_BUTTON (WID ("web_custom_radio")), TRUE);
++      gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (WID ("web_custom_radio")), TRUE);
++
+       g_free (browser);
+ }
+@@ -427,18 +429,19 @@
+               if (possible_mailers[i].in_path == FALSE)
+                       continue;
+-              if (mailer && strcmp (mailer, possible_mailers[i].command) == 0 &&
+-                  needs_term == possible_mailers[i].needs_term) {
++              if (mailer && (strcmp (mailer, possible_mailers[i].command) == 0)
++              &&   needs_term == possible_mailers[i].needs_term) {
+                       gtk_entry_set_text (GTK_ENTRY (WID ("mail_select_combo_entry")),
+                                           _(possible_mailers[i].name));
+-                      gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (WID ("mail_custom_radio")), TRUE);
++                                          
++                      gtk_widget_set_sensitive (WID ("mail_select_combo"), TRUE);
+                       gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (WID ("mail_select_radio")), TRUE);
+                       g_free (mailer);
+                       return;
+               }
+         }
+-      gtk_toggle_button_set_inconsistent (GTK_TOGGLE_BUTTON (WID ("mail_select_radio")), TRUE);
+-      gtk_toggle_button_set_inconsistent (GTK_TOGGLE_BUTTON (WID ("mail_custom_radio")), TRUE);
++      gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (WID ("mail_custom_radio")), TRUE);
++
+       g_free (mailer);
+       
+@@ -510,17 +513,18 @@
+                   strcmp (exec_arg?exec_arg:"", possible_terminals[i].exec_arg) == 0) {
+                       gtk_entry_set_text (GTK_ENTRY (WID ("terminal_select_combo_entry")),
+                                           _(possible_terminals[i].name));
+-                      gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (WID ("terminal_custom_radio")), TRUE);
++                                          
++                      gtk_widget_set_sensitive (WID ("terminal_select_combo"), TRUE);
+                       gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (WID ("terminal_select_radio")), TRUE);
+                       g_free (exec);
+                       g_free (exec_arg);
+                       return;
+               }
+         }
+-      gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (WID ("terminal_select_radio")), TRUE);
+       gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (WID ("terminal_custom_radio")), TRUE);
+       g_free (exec);
+       g_free (exec_arg);
++
+ }
+ static void
diff --git a/control-center-pangoxft_fix.patch b/control-center-pangoxft_fix.patch
new file mode 100644 (file)
index 0000000..a858083
--- /dev/null
@@ -0,0 +1,34 @@
+diff -aurN control-center-2.11.91.orig/capplets/keyboard/Makefile.am control-center-2.11.91/capplets/keyboard/Makefile.am
+--- control-center-2.11.91.orig/capplets/keyboard/Makefile.am  2004-11-28 09:14:04.000000000 +0100
++++ control-center-2.11.91/capplets/keyboard/Makefile.am       2005-08-14 23:24:03.000000000 +0200
+@@ -10,6 +10,7 @@
+ gnome_keyboard_properties_LDADD =                             \
+       ../accessibility/keyboard/libaccessibility-keyboard.a   \
+       $(GNOMECC_CAPPLETS_LIBS) $(LIBXKLAVIER_LIBS) \
++      $(PANGOXFT_LIBS) \
+       ../../libgswitchit/libgswitchit.a \
+       ../../libkbdraw/libkbdraw.a
+@@ -29,6 +30,6 @@
+ Desktop_in_files = keyboard.desktop.in
+ desktop_DATA = $(Desktop_in_files:.desktop.in=.desktop)
+-INCLUDES   = $(GNOMECC_CAPPLETS_CFLAGS) $(LIBXKLAVIER_CFLAGS)
++INCLUDES   = $(GNOMECC_CAPPLETS_CFLAGS) $(LIBXKLAVIER_CFLAGS) $(PANGOXFT_CFLAGS)
+ CLEANFILES = $(GNOMECC_CAPPLETS_CLEANFILES) $(Desktop_in_files) $(desktop_DATA)
+ EXTRA_DIST = $(Glade_DATA) $(pixmaps_DATA)
+diff -aurN control-center-2.11.91.orig/configure.in control-center-2.11.91/configure.in
+--- control-center-2.11.91.orig/configure.in   2005-08-10 11:45:08.000000000 +0200
++++ control-center-2.11.91/configure.in        2005-08-14 23:18:51.000000000 +0200
+@@ -97,6 +97,11 @@
+  libbonobo-2.0 dnl
+  libbonoboui-2.0 dnl
+  gnome-desktop-2.0 >= 2.2.0"
++
++PKG_CHECK_MODULES(PANGOXFT, pangoxft >= 1.9.1)
++AC_SUBST(PANGOXFT_CFLAGS)
++AC_SUBST(PANGOXFT_LIBS)
++
+ PKG_CHECK_MODULES(CAPPLET, $COMMON_MODULES)
+ PKG_CHECK_MODULES(GNOMECC, $COMMON_MODULES libgnome-menu >= 2.11.1)
+ PKG_CHECK_MODULES(GNOME_SETTINGS_DAEMON,
diff --git a/control-center-xft-hack.patch b/control-center-xft-hack.patch
new file mode 100644 (file)
index 0000000..4ac6de8
--- /dev/null
@@ -0,0 +1,11 @@
+--- control-center-2.11.6/configure.in.wiget   2005-07-14 07:31:49.000000000 +0000
++++ control-center-2.11.6/configure.in 2005-07-14 07:33:52.000000000 +0000
+@@ -19,7 +19,7 @@
+ m4_define(gnomevfs_minver, 2.0.0)
+ m4_define(fontconfig_minver, 1.0.0)
+-m4_define(xft_minver, 2.1.7)
++m4_define(xft_minver, 2.1.2.2)
+ m4_define(gtk_minver, 2.6.0)
+ m4_define(libbonobo_minver, 2.0.0)
+ m4_define(libgnomeui_minver, 2.2.0)
This page took 0.041961 seconds and 4 git commands to generate.