]> git.pld-linux.org Git - packages/conserver.git/blob - conserver.spec
- jajks, it's v. 8.1.11
[packages/conserver.git] / conserver.spec
1 # TODO: smart .init/.sysconfig, maybe a default configuration
2 #
3 Summary:        Console server
4 Summary(pl):    Serwer konsoli
5 Name:           conserver
6 Version:        8.1.11
7 Release:        1
8 License:        BSD-like
9 Group:          Daemons
10 Source0:        http://www.conserver.com/%{name}-%{version}.tar.gz
11 # Source0-md5:  94259cd71f38e94b3f247768e3bc731f
12 Source1:        %{name}.init
13 Source2:        %{name}.sysconfig
14 Source3:        %{name}.logrotate
15 Patch0:         %{name}-locks.patch
16 URL:            http://www.conserver.com/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  openssl-devel
20 BuildRequires:  libwrap-devel
21 BuildRequires:  pam-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _sysconfdir     /etc/conserver
25
26 %description
27 Conserver is an application that allows multiple users to watch a
28 serial console at the same time. It can log the data, allows users
29 to take write-access of a console (one at a time), and has a
30 variety of bells and whistles to accentuate that basic
31 functionality.
32
33 %description -l pl
34 Conserver jest aplikacj±, która umo¿liwia kilku u¿ytkownikom naraz
35 ogl±daæ logi na konsoli szeregowej. Mo¿e zapisywaæ zebrane dane,
36 pozwalaæ u¿ytkownikom na pe³ne korzystanie z konsoli (ale tylko
37 jednemu naraz), oraz posiada mnóstwo dodatków rozszerzaj±cych tê
38 podstawow± funkcjonalno¶æ.
39
40 %prep
41 %setup -q
42 %patch0 -p1
43
44 %build
45 %{__aclocal}
46 %{__autoconf}
47 %{__autoheader}
48 %configure \
49         --with-master=localhost \
50         --with-extmsgs \
51         --with-libwrap \
52         --with-openssl \
53         --with-pam
54 #       --with-uds
55 %{__make}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,logrotate.d,conserver} \
61         $RPM_BUILD_ROOT/var/log/{conserver.d,archiv/conserver.d}
62
63 %{__make} install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 mv $RPM_BUILD_ROOT%{_datadir}/examples/conserver examples
67
68 install examples/conserver.cf $RPM_BUILD_ROOT%{_sysconfdir}
69 touch $RPM_BUILD_ROOT%{_sysconfdir}/conserver.passwd
70 touch $RPM_BUILD_ROOT%{_sysconfdir}/console.cf
71
72 rm -f examples/conserver.rc
73 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/conserver
74 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/conserver
75 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/conserver
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post
81 /sbin/chkconfig --add conserver
82 if [ -f /var/lock/subsys/conserver ]; then
83         /etc/rc.d/init.d/conserver restart 1>&2
84 else
85         echo "Run \"/etc/rc.d/init.d/conserver start\" to start conserver daemon."
86 fi
87
88 %preun
89 if [ "$1" = "0" ]; then
90         if [ -f /var/lock/subsys/conserver ]; then
91                 /etc/rc.d/init.d/conserver stop 1>&2
92         fi
93         /sbin/chkconfig --del conserver
94 fi
95
96 %files
97 %defattr(644,root,root,755)
98 %doc CHANGES FAQ README TODO examples LICENSE
99 %attr(755,root,root) %{_bindir}/*
100 %attr(755,root,root) %{_sbindir}/*
101 %attr(754,root,root) /etc/rc.d/init.d/conserver
102 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/*
103 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/*
104 %attr(750,root,root) %dir /var/log/conserver.d
105 %attr(750,root,root) %dir /var/log/archiv/conserver.d
106 %dir /etc/conserver
107 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/*
108 %{_mandir}/man*/*
This page took 0.297448 seconds and 3 git commands to generate.