]> git.pld-linux.org Git - packages/conserver.git/blob - conserver.spec
- rel 2
[packages/conserver.git] / conserver.spec
1 # TODO: smart .init/.sysconfig, maybe a default configuration
2 #
3 Summary:        Console server
4 Summary(pl):    Serwer konsoli
5 Name:           conserver
6 Version:        8.1.12
7 Release:        2
8 License:        BSD-like
9 Group:          Daemons
10 Source0:        http://www.conserver.com/%{name}-%{version}.tar.gz
11 # Source0-md5:  1fb356224f018625be5c3d35529a4ac6
12 Source1:        %{name}.init
13 Source2:        %{name}.sysconfig
14 Source3:        %{name}.logrotate
15 Patch0:         %{name}-locks.patch
16 URL:            http://www.conserver.com/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  libwrap-devel
20 BuildRequires:  openssl-devel
21 BuildRequires:  pam-devel
22 BuildRequires:  rpmbuild(macros) >= 1.268
23 Requires(post,preun):   /sbin/chkconfig
24 Requires:       rc-scripts
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _sysconfdir     /etc/conserver
28
29 %description
30 Conserver is an application that allows multiple users to watch a
31 serial console at the same time. It can log the data, allows users to
32 take write-access of a console (one at a time), and has a variety of
33 bells and whistles to accentuate that basic functionality.
34
35 %description -l pl
36 Conserver jest aplikacj±, która umo¿liwia kilku u¿ytkownikom naraz
37 ogl±daæ logi na konsoli szeregowej. Mo¿e zapisywaæ zebrane dane,
38 pozwalaæ u¿ytkownikom na pe³ne korzystanie z konsoli (ale tylko
39 jednemu naraz), oraz posiada mnóstwo dodatków rozszerzaj±cych tê
40 podstawow± funkcjonalno¶æ.
41
42 %prep
43 %setup -q
44 %patch0 -p1
45
46 %build
47 %{__aclocal}
48 %{__autoconf}
49 %{__autoheader}
50 %configure \
51         --with-master=localhost \
52         --with-extmsgs \
53         --with-libwrap \
54         --with-openssl \
55         --with-pam
56 #       --with-uds
57 %{__make}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,logrotate.d,conserver} \
63         $RPM_BUILD_ROOT/var/log/{conserver.d,archiv/conserver.d}
64
65 %{__make} install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 mv $RPM_BUILD_ROOT%{_datadir}/examples/conserver examples
69
70 install examples/conserver.cf $RPM_BUILD_ROOT%{_sysconfdir}
71 touch $RPM_BUILD_ROOT%{_sysconfdir}/conserver.passwd
72 touch $RPM_BUILD_ROOT%{_sysconfdir}/console.cf
73
74 rm -f examples/conserver.rc
75 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/conserver
76 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/conserver
77 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/conserver
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %post
83 /sbin/chkconfig --add conserver
84 %service conserver restart "conserver daemon"
85
86 %preun
87 if [ "$1" = "0" ]; then
88         %service conserver stop
89         /sbin/chkconfig --del conserver
90 fi
91
92 %files
93 %defattr(644,root,root,755)
94 %doc CHANGES FAQ README TODO examples LICENSE
95 %attr(755,root,root) %{_bindir}/*
96 %attr(755,root,root) %{_sbindir}/*
97 %attr(754,root,root) /etc/rc.d/init.d/conserver
98 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
99 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/*
100 %attr(750,root,root) %dir /var/log/conserver.d
101 %attr(750,root,root) %dir /var/log/archiv/conserver.d
102 %dir %{_sysconfdir}
103 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
104 %{_mandir}/man*/*
This page took 0.261771 seconds and 3 git commands to generate.