]> git.pld-linux.org Git - packages/cone.git/blame - cone.spec
- updated to 0.96.2
[packages/cone.git] / cone.spec
CommitLineData
147daf49 1#
b848eaf8
JB
2# Conditional build:
3%bcond_without tests # "make check"
4%bcond_with gnutls # GnuTLS instead of OpenSSL
5%bcond_with socks # (Courier) Socks support
6
6657dc05 7Summary: CONE - Console Newsreader and Emailer
28d6cad6 8Summary(pl.UTF-8): CONE - tekstowy klient poczty i czytnik newsów
f976440c 9Name: cone
b848eaf8
JB
10Version: 0.96.2
11Release: 1
12License: GPL v3 with OpenSSL exception
f976440c 13Group: Applications/Mail
31f2e7d7 14Source0: http://downloads.sourceforge.net/courier/%{name}-%{version}.tar.bz2
b848eaf8 15# Source0-md5: ea8925d531b43fd8ee36b0363434b1b8
ad21e748 16Patch0: %{name}-maildir.patch
b848eaf8 17Patch1: %{name}-curses.patch
509212ad 18URL: http://www.courier-mta.org/cone/
f976440c 19BuildRequires: aspell-devel
b848eaf8 20BuildRequires: autoconf >= 2.59
6657dc05 21BuildRequires: automake
b848eaf8
JB
22%{?with_socks:BuildRequires: courier-sox-devel}
23BuildRequires: courier-unicode-devel >= 2.0
f976440c 24BuildRequires: fam-devel
b848eaf8
JB
25# or gnupg2 --with-gpg2, will use the same at runtime
26BuildRequires: gnupg
27%{?with_gnutls:BuildRequires: gnutls-devel >= 3.0}
28%{?with_gnutls:BuildRequires: libgcrypt-devel}
29%{?with_gnutls:BuildRequires: libgpg-error-devel}
30BuildRequires: libidn-devel >= 0.0.0
f976440c 31BuildRequires: libstdc++-devel
b848eaf8
JB
32BuildRequires: libtool >= 2:1.5
33BuildRequires: libxml2-devel >= 2.0
34BuildRequires: ncurses-devel >= 5
35BuildRequires: openldap-devel
36%{!?with_gnutls:BuildRequires: openssl-devel >= 0.9.7d}
37BuildRequires: pcre-devel
509212ad 38BuildRequires: perl-base
b848eaf8
JB
39BuildRequires: pkgconfig
40BuildRequires: procps
48814c1c 41BuildRequires: sysconftool
f976440c 42BuildRequires: zlib-devel
31f2e7d7 43Requires: ca-certificates
b848eaf8 44Suggests: gnupg
f976440c
AA
45BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47%description
509212ad
JB
48CONE is a simple, text-based E-mail reader and writer, and a simple
49newsreader.
f976440c 50
8628d5b4
JR
51%description -l pl.UTF-8
52CONE jest prostym, tekstowym klientem pocztowym, a także prostym
53czytnikiem newsów.
f976440c 54
509212ad 55%package devel
b848eaf8
JB
56Summary: Header files and static LibMAIL library
57Summary(pl.UTF-8): Pliki nagłówkowe i biblioteka statyczna LibMAIL
58Group: Development/Libraries
59Requires: courier-unicode-devel >= 2.0
60%{?with_gnutls:Requires: gnutls-devel >= 3.0}
61Requires: libidn-devel >= 0.0.0
62Requires: libstdc++-devel
63%{!?with_gnutls:Requires: openssl-devel >= 0.9.7d}
64Obsoletes: cone-static < 0.96
f976440c
AA
65
66%description devel
b848eaf8
JB
67This package includes the header files and static library for
68developing applications using LibMAIL - a high level, C++ OO library
69for mail clients.
f976440c 70
8628d5b4 71%description devel -l pl.UTF-8
b848eaf8
JB
72Ten pakiet zawiera pliki nagłówkowe i bibliotekę statyczną do
73tworzenia aplikacji z użyciem LibMAIL - wysokopoziomowej,
74zorientowanej obiektowo biblioteki C++ dla klientów pocztowych.
f976440c 75
6657dc05
AA
76%package -n leaf
77Summary: Console text file editor
28d6cad6 78Summary(pl.UTF-8): Konsolowy edytor plików tekstowych
6657dc05
AA
79Group: Applications/Editors
80
81%description -n leaf
b78eacde
ER
82Leaf is a simple console text file editor, with paragraph
83word-wrapping and spell checking. Leaf is based on the text editor in
84the Cone mail reader and composer.
6657dc05 85
8628d5b4 86%description -n leaf -l pl.UTF-8
b848eaf8
JB
87Leaf jest prostym konsolowym edytorem plików tekstowych, z zawijaniem
88wierszy w akapitach i sprawdzaniem pisowni. Jest oparty na edytorze
89używanym w czytniku poczty Cone.
6657dc05 90
f976440c
AA
91%prep
92%setup -q
ad21e748 93%patch0 -p1
f976440c
AA
94
95%build
b848eaf8
JB
96%{__libtoolize}
97for d in $(sed -ne 's/.*AC_CONFIG_SUBDIRS(\([^)]*\))/\1/p' configure.ac) . ; do
98 if [ -d "$d" ]; then
99 cd $d
100 %{__aclocal}
101 %{__autoconf}
102 if grep -q AC_CONFIG_HEADER configure.ac ; then
103 %{__autoheader}
104 fi
105 %{__automake}
106 cd -
107 fi
108done
109
f976440c 110%configure \
b848eaf8 111 SENDMAIL=/usr/lib/sendmail \
a3ca27dd 112 --with-certdb=%{_sysconfdir}/certs/ca-certificates.crt \
b848eaf8
JB
113 --with-devel \
114 %{?with_gnutls:--with-gnutls}
f976440c
AA
115
116%{__make}
117
b848eaf8
JB
118%if %{with tests}
119%{__make} check
120%endif
f976440c
AA
121
122%install
123rm -rf $RPM_BUILD_ROOT
124
125%{__make} install \
126 DESTDIR=$RPM_BUILD_ROOT
127
b848eaf8 128%{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/cone.dist $RPM_BUILD_ROOT%{_sysconfdir}/cone
6657dc05 129
b848eaf8
JB
130# move docs to more specific location
131install -d $RPM_BUILD_ROOT%{_docdir}/%{name}
132%{__mv} $RPM_BUILD_ROOT%{_datadir}/cone/{*.html,manpage.css} $RPM_BUILD_ROOT%{_docdir}/%{name}
f976440c 133
f976440c
AA
134%clean
135rm -rf $RPM_BUILD_ROOT
136
137%files
138%defattr(644,root,root,755)
b848eaf8
JB
139%doc AUTHORS COPYING ChangeLog NEWS README
140%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cone
509212ad 141%attr(755,root,root) %{_bindir}/cone
509212ad 142%attr(755,root,root) %{_bindir}/mailtool
b848eaf8 143%attr(755,root,root) %{_libexecdir}/cone
f976440c 144%{_datadir}/cone
b848eaf8
JB
145%{_mandir}/man1/cone.1*
146%{_mandir}/man1/mailtool.1*
147%dir %{_docdir}/%{name}
148%{_docdir}/%{name}/FAQ.html
149%{_docdir}/%{name}/INSTALL.html
150%{_docdir}/%{name}/README.html
151%{_docdir}/%{name}/add.html
152%{_docdir}/%{name}/attributes.html
153%{_docdir}/%{name}/bk01-toc.html
154%{_docdir}/%{name}/cone*.html
155%{_docdir}/%{name}/conn.html
156%{_docdir}/%{name}/index.html
157%{_docdir}/%{name}/maillist.html
158%{_docdir}/%{name}/mailtool.html
159%{_docdir}/%{name}/manpage.css
160%{_docdir}/%{name}/moredocs.html
161%{_docdir}/%{name}/search.html
162%{_docdir}/%{name}/smap*.html
163%{_docdir}/%{name}/store.html
f976440c
AA
164
165%files devel
166%defattr(644,root,root,755)
b848eaf8 167%{_libdir}/libmail.a
b41719b0 168%{_libdir}/libmail.la
f976440c 169%{_includedir}/libmail
b848eaf8
JB
170%{_mandir}/man3/mail::*.3x*
171%dir %{_docdir}/%{name}
172%{_docdir}/%{name}/account-*.html
173%{_docdir}/%{name}/address.html
174%{_docdir}/%{name}/cppnamespace.html
175%{_docdir}/%{name}/emailaddress.html
176%{_docdir}/%{name}/envelope.html
177%{_docdir}/%{name}/folder-*.html
178%{_docdir}/%{name}/header-*.html
179%{_docdir}/%{name}/libmail*.html
180%{_docdir}/%{name}/mail-*.html
181%{_docdir}/%{name}/mimestruct.html
182%{_docdir}/%{name}/misc.html
183%{_docdir}/%{name}/native.html
184%{_docdir}/%{name}/synchronous.html
6657dc05
AA
185
186%files -n leaf
187%defattr(644,root,root,755)
6657dc05 188%attr(755,root,root) %{_bindir}/leaf
b848eaf8
JB
189%{_mandir}/man1/leaf.1*
190%dir %{_docdir}/%{name}
191%{_docdir}/%{name}/leaf.html
This page took 0.165493 seconds and 4 git commands to generate.