]> git.pld-linux.org Git - packages/composer.git/commitdiff
make build not to use network
authorElan Ruusamäe <glen@delfi.ee>
Wed, 9 Apr 2014 18:25:47 +0000 (21:25 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Wed, 9 Apr 2014 18:25:47 +0000 (21:25 +0300)
composer.spec

index ed83da4f355de2578b0898c5ca03e8b96d694cd2..ca2f90bc296555e658a42620a5532081eef9ab73 100644 (file)
@@ -6,7 +6,7 @@
 
 %define                php_min_version 5.3.4
 %define                subver  alpha8
-%define                rel             0.22
+%define                rel             1
 %include       /usr/lib/rpm/macros.php
 Summary:       Dependency Manager for PHP
 Name:          composer
@@ -35,6 +35,8 @@ BuildRequires:        rpm-php-pearprov >= 4.4.2-11
 BuildRequires: rpmbuild(macros) >= 1.461
 %if %{without bootstrap}
 BuildRequires: %{name}
+BuildRequires: php-symfony2-Console >= 2.3
+BuildRequires: php-symfony2-Finder >= 2.2
 %endif
 Requires:      php(core) >= %{php_min_version}
 Requires:      php(hash)
@@ -79,7 +81,7 @@ composer=composer
 %endif
 if [ ! -d vendor ]; then
        COMPOSER_HOME=${PWD:=$(pwd)} \
-       $composer install --prefer-dist -v --no-dev
+       $composer dump-autoload -v
        %{__patch} -p1 < %{PATCH2}
 fi
 
This page took 0.084337 seconds and 4 git commands to generate.