]> git.pld-linux.org Git - packages/composer.git/commitdiff
up to 1.6.5 (2018-05-04) auto/th/composer-1.6.5-1
authorElan Ruusamäe <glen@pld-linux.org>
Sun, 20 May 2018 15:45:25 +0000 (18:45 +0300)
committerElan Ruusamäe <glen@pld-linux.org>
Sun, 20 May 2018 15:47:06 +0000 (18:47 +0300)
- Fixed regression in 1.6.4 causing strange update behaviors with dev packages
- Fixed regression in 1.6.4 color support detection for Windows
- Fixed issues dealing with broken symlinks when switching branches and using path repositories
- Fixed JSON schema for package repositories
- Fixed issues on computers set to Turkish locale
- Fixed classmap parsing of files using short-open-tags when they are disabled in php

autoload.patch
composer.spec

index 4e21c3d8a1a3df839b99d02a7f61de7fa5e9399b..a6e229eade0896687e1692b681c6b037f3622d31 100644 (file)
@@ -1,9 +1,9 @@
---- composer-1.0.0-14.alpha11/bin/composer~    2015-11-25 23:34:22.000000000 +0200
-+++ composer-1.0.0-14.alpha11/bin/composer     2015-11-25 23:34:25.939418752 +0200
-@@ -5,7 +5,11 @@
-     echo 'Warning: Composer should be invoked via the CLI version of PHP, not the '.PHP_SAPI.' SAPI'.PHP_EOL;
+--- composer-1.6.5/bin/composer~       2018-05-04 12:44:59.000000000 +0300
++++ composer-1.6.5/bin/composer        2018-05-20 18:46:39.628512375 +0300
+@@ -6,7 +6,11 @@
  }
  
+ setlocale(LC_ALL, 'C');
 -require __DIR__.'/../src/bootstrap.php';
 +if (file_exists($autoload = __DIR__ . '/../src/Composer/autoload.php')) {
 +      require $autoload;
@@ -11,8 +11,8 @@
 +      require '/usr/share/php/Composer/autoload.php';
 +}
  
- use Composer\Console\Application;
+ use Composer\Factory;
+ use Composer\XdebugHandler;
 --- composer-1.4.1/src/Composer/Json/JsonFile.php~     2017-03-10 10:29:45.000000000 +0200
 +++ composer-1.4.1/src/Composer/Json/JsonFile.php      2017-03-28 13:37:49.762829930 +0300
 @@ -156,7 +156,7 @@
index fc6aa197b3b2ec4a4c5ba2ffc8ab055118121cea..319b57e578b00979e8934643cc164df162d71651 100644 (file)
@@ -6,12 +6,12 @@
 %include       /usr/lib/rpm/macros.php
 Summary:       Dependency Manager for PHP
 Name:          composer
-Version:       1.6.4
+Version:       1.6.5
 Release:       1
 License:       MIT
 Group:         Development/Languages/PHP
 Source0:       https://github.com/composer/composer/archive/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: d2cd6048c50d8baa44ad1d5150d27992
+# Source0-md5: 2feed0f843c82f863710f31539913a25
 Source2:       https://raw.githubusercontent.com/iArren/%{name}-bash-completion/86a8129/composer
 # Source2-md5: cdeebf0a0da1fd07d0fd886d0461642e
 Source3:       autoload.php
This page took 0.110252 seconds and 4 git commands to generate.