]> git.pld-linux.org Git - packages/composer.git/commitdiff
AutoloadGenerator needs LICENSE file at run time
authorElan Ruusamäe <glen@delfi.ee>
Thu, 26 Nov 2015 12:57:26 +0000 (14:57 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Thu, 26 Nov 2015 12:57:26 +0000 (14:57 +0200)
autoload.patch
composer.spec

index 87b44f7359045a38cbcbe36bb66dbd2251a9fa76..cc85247f3bfd61fc3f2788febbfcecfdd3e8ba93 100644 (file)
          $schemaData = json_decode(file_get_contents($schemaFile));
  
          if ($schema === self::LAX_SCHEMA) {
+--- composer-1.0.0-15.alpha11/src/Composer/Autoload/AutoloadGenerator.php~     2015-11-14 18:21:07.000000000 +0200
++++ composer-1.0.0-15.alpha11/src/Composer/Autoload/AutoloadGenerator.php      2015-11-26 14:52:01.344498517 +0200
+@@ -275,7 +275,7 @@
+         file_put_contents($targetDir.'/autoload_real.php', $this->getAutoloadRealFile(true, (bool) $includePathFileContents, $targetDirLoader, (bool) $includeFilesFileContents, $vendorPathCode, $appBaseDirCode, $suffix, $useGlobalIncludePath, $prependAutoloader));
+         $this->safeCopy(__DIR__.'/ClassLoader.php', $targetDir.'/ClassLoader.php');
+-        $this->safeCopy(__DIR__.'/../../../LICENSE', $targetDir.'/LICENSE');
++        $this->safeCopy(__DIR__.'/../res/LICENSE', $targetDir.'/LICENSE');
+         $this->eventDispatcher->dispatchScript(ScriptEvents::POST_AUTOLOAD_DUMP, $this->devMode, array(), array(
+             'optimize' => (bool) $scanPsr0Packages,
index c1fc1c72e502e6c6e7d6da761633283020caea5a..bb0a5257a17b50384f1c48bc7edf4d7960a97731 100644 (file)
@@ -98,6 +98,9 @@ mv composer.lock{,.disabled}
 
 cp -p %{SOURCE3} src/Composer/autoload.php
 
+# AutoloadGenerator needs this runtime
+mv LICENSE res
+
 # move to Composer dir, this will simplify testing
 mv res src/Composer
 ln -s src/Composer/res
@@ -135,7 +138,8 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README.md CHANGELOG.md LICENSE PORTING_INFO
+%doc README.md CHANGELOG.md PORTING_INFO
+%doc src/Composer/res/LICENSE
 %attr(755,root,root) %{_bindir}/composer
 %{php_data_dir}/Composer
 
This page took 0.081681 seconds and 4 git commands to generate.