]> git.pld-linux.org Git - packages/compiz.git/blob - compiz.spec
- BR new libwnck
[packages/compiz.git] / compiz.spec
1 #
2 # Conditional build:
3 %bcond_without  gconf           # don't build gconf plugin
4 %bcond_without  gnome           # don't build gnome-window-decorator
5 %bcond_with     kde             # build kde-window-decorator (not working)
6 #
7 %define         _snap   20060424
8 #
9 Summary:        OpenGL window and compositing manager
10 Summary(pl):    OpenGL-owy zarz±dca okien i sk³adania
11 Name:           compiz
12 Version:        0.0.9
13 Release:        1.%{_snap}.1
14 License:        GPL/MIT
15 Group:          X11
16 Source0:        %{name}-%{_snap}.tar.bz2
17 # Source0-md5:  87045b62bcf724785105a88641214a2a
18 Source1:        %{name}-pld.png
19 # Source1-md5:  3050dc90fd4e5e990bb5baeb82bd3c8a
20 Patch0:         %{name}-minimize-scaler-mod.patch
21 %if %{with gconf} || %{with gnome}
22 BuildRequires:  GConf2-devel >= 2.0
23 %endif
24 BuildRequires:  OpenGL-devel
25 BuildRequires:  autoconf >= 2.57
26 BuildRequires:  automake
27 BuildRequires:  glib2-devel >= 2.0
28 BuildRequires:  libpng-devel
29 BuildRequires:  libsvg-cairo-devel
30 BuildRequires:  libtool
31 BuildRequires:  pkgconfig
32 BuildRequires:  startup-notification-devel >= 0.7
33 BuildRequires:  xorg-lib-libSM-devel
34 BuildRequires:  xorg-lib-libXcomposite-devel
35 BuildRequires:  xorg-lib-libXdamage-devel
36 BuildRequires:  xorg-lib-libXrandr-devel
37 %if %{with gnome}
38 BuildRequires:  control-center-devel >= 2.0
39 BuildRequires:  gnome-desktop-devel >= 2.0
40 BuildRequires:  gtk+2-devel >= 2:2.8.0
41 BuildRequires:  libwnck-devel >= 2.14.1-2
42 %endif
43 %if %{with kde}
44 BuildRequires:  QtCore-devel
45 BuildRequires:  QtGui-devel
46 BuildRequires:  qt4-build
47 %endif
48 Requires(post,preun):   GConf2
49 Obsoletes:      compiz-opacity
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 Compiz is an OpenGL compositing manager that use
54 GLX_EXT_texture_from_pixmap for binding redirected top-level windows
55 to texture objects. It has a flexible plug-in system and it is
56 designed to run well on most graphics hardware.
57
58 %description -l pl
59 Compiz jest OpenGL-owym zarz±dc± sk³adania, u¿ywaj±cym rozszerzenia
60 GLX_EXT_texture_from_pixmap w celu wi±zania przekierowanych okien do
61 tekstur. Posiada elastyczny system wtyczek i jest tak zaprojektowany,
62 by dobrze dzia³aæ na wiêkszo¶ci kart graficznych.
63
64 %package devel
65 Summary:        Header files for compiz
66 Summary(pl):    Pliki nag³ówkowe dla compiza
67 Group:          Development
68 # (by compiz.pc; header requires only: OpenGL-devel, startup-notification-devel, damageproto, xextproto, libX11-devel)
69 Requires:       OpenGL-devel
70 Requires:       libpng-devel
71 Requires:       startup-notification-devel >= 0.7
72 Requires:       xorg-lib-libSM-devel
73 Requires:       xorg-lib-libXcomposite-devel
74 Requires:       xorg-lib-libXdamage-devel
75 Requires:       xorg-lib-libXrandr-devel
76
77 %description devel
78 Header files for compiz.
79
80 %description devel -l pl
81 Pliki nag³ówkowe dla compiza.
82
83 %package gnome-settings
84 Summary:        Compiz settings for gnome control panel
85 Summary(pl):    Ustawienia compiza dla panelu sterowania gnome
86 Group:          X11
87 Requires:       %{name} = %{version}-%{release}
88
89 %description gnome-settings
90 Compiz settings for gnome control panel.
91
92 %description gnome-settings -l pl
93 Ustawienia compiza dla panelu sterowania gnome.
94
95 %package gnome-decorator
96 Summary:        Window decorator for gnome
97 Summary(pl):    Dekorator okien dla gnome
98 Group:          X11
99 Requires:       %{name} = %{version}-%{release}
100
101 %description gnome-decorator
102 Window decorator for gnome.
103
104 %description gnome-decorator -l pl
105 Dekorator okien dla gnome.
106
107 %package kde-decorator
108 Summary:        Window decorator for KDE
109 Summary(pl):    Dekorator okien dla KDE
110 Group:          X11
111 Requires:       %{name} = %{version}-%{release}
112
113 %description kde-decorator
114 Window decorator for KDE.
115
116 %description kde-decorator -l pl
117 Dekorator okien dla KDE.
118
119 %prep
120 %setup -q -n %{name}-%{_snap}
121 %patch0 -p0
122
123 %build
124 autoreconf -v --install
125
126 %configure \
127         --disable-static \
128         --enable-svg \
129         --enable-libsvg-cairo \
130         %{!?with_gconf:--disable-gconf} \
131         --%{?with_gnome:en}%{!?with_gnome:dis}able-gnome \
132         --%{?with_kde:en}%{!?with_kde:dis}able-kde
133
134 %{__make}
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138
139 %{__make} install \
140         DESTDIR=$RPM_BUILD_ROOT
141
142 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/compiz/novell.png
143
144 rm -f $RPM_BUILD_ROOT%{_libdir}/compiz/*.la
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post
150 %gconf_schema_install compiz.schemas
151
152 %preun
153 %gconf_schema_uninstall compiz.schemas
154
155 %files
156 %defattr(644,root,root,755)
157 %doc AUTHORS ChangeLog README TODO
158 %attr(755,root,root) %{_bindir}/compiz
159 %dir %{_libdir}/compiz
160 %attr(755,root,root) %{_libdir}/compiz/*.so
161 %{_datadir}/compiz
162 %if %{with gnome}
163 %{_datadir}/gnome/wm-properties/*
164 %endif
165 %{_sysconfdir}/gconf/schemas/compiz.schemas
166
167 %files devel
168 %defattr(644,root,root,755)
169 %{_includedir}/compiz
170 %{_pkgconfigdir}/compiz.pc
171
172 %if %{with gnome}
173 %files gnome-settings
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{_libdir}/window-manager-settings/*.so
176
177 %files gnome-decorator
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_bindir}/gnome-window-decorator
180 %endif
181
182 %if %{with kde}
183 %files kde-decorator
184 %defattr(644,root,root,755)
185 %attr(755,root,root) %{_bindir}/kde-window-decorator
186 %endif
This page took 0.343386 seconds and 4 git commands to generate.