]> git.pld-linux.org Git - packages/compiz.git/blob - compiz.spec
- added missing BR's
[packages/compiz.git] / compiz.spec
1 #
2 # Conditional build:
3 %bcond_without  gconf           # don't build gconf plugin
4 %bcond_without  gnome           # don't build gnome-window-decorator
5 %bcond_with     kde             # build kde-window-decorator (not working)
6 #
7 %define         _snap   20060430
8 #
9 Summary:        OpenGL window and compositing manager
10 Summary(pl):    OpenGL-owy zarz±dca okien i sk³adania
11 Name:           compiz
12 Version:        0.0.10
13 Release:        1.%{_snap}.1
14 License:        GPL/MIT
15 Group:          X11
16 Source0:        %{name}-%{_snap}.tar.bz2
17 # Source0-md5:  fc79625701b36903cba32d7f1cc4f63e
18 Source1:        %{name}-pld.png
19 # Source1-md5:  3050dc90fd4e5e990bb5baeb82bd3c8a
20 Patch0:         %{name}-minimize-scaler-mod.patch
21 %if %{with gconf} || %{with gnome}
22 BuildRequires:  GConf2-devel >= 2.0
23 %endif
24 BuildRequires:  OpenGL-devel
25 BuildRequires:  autoconf >= 2.57
26 BuildRequires:  automake
27 BuildRequires:  glib2-devel >= 2.0
28 BuildRequires:  glitz-devel
29 BuildRequires:  libpng-devel
30 BuildRequires:  libsvg-cairo-devel
31 BuildRequires:  libtool
32 BuildRequires:  pkgconfig
33 BuildRequires:  startup-notification-devel >= 0.7
34 BuildRequires:  xorg-lib-libSM-devel
35 BuildRequires:  xorg-lib-libXcomposite-devel
36 BuildRequires:  xorg-lib-libXdamage-devel
37 BuildRequires:  xorg-lib-libXrandr-devel
38 BuildRequires:  xorg-lib-libXres-devel
39 %if %{with gnome}
40 BuildRequires:  control-center-devel >= 2.0
41 BuildRequires:  gnome-desktop-devel >= 2.0
42 BuildRequires:  gnome-menus-devel
43 BuildRequires:  gtk+2-devel >= 2:2.8.0
44 BuildRequires:  libwnck-devel >= 2.14.1-2
45 %endif
46 %if %{with kde}
47 BuildRequires:  QtCore-devel
48 BuildRequires:  QtGui-devel
49 BuildRequires:  qt4-build
50 %endif
51 Requires(post,preun):   GConf2
52 Obsoletes:      compiz-opacity
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %description
56 Compiz is an OpenGL compositing manager that use
57 GLX_EXT_texture_from_pixmap for binding redirected top-level windows
58 to texture objects. It has a flexible plug-in system and it is
59 designed to run well on most graphics hardware.
60
61 %description -l pl
62 Compiz jest OpenGL-owym zarz±dc± sk³adania, u¿ywaj±cym rozszerzenia
63 GLX_EXT_texture_from_pixmap w celu wi±zania przekierowanych okien do
64 tekstur. Posiada elastyczny system wtyczek i jest tak zaprojektowany,
65 by dobrze dzia³aæ na wiêkszo¶ci kart graficznych.
66
67 %package devel
68 Summary:        Header files for compiz
69 Summary(pl):    Pliki nag³ówkowe dla compiza
70 Group:          Development
71 # (by compiz.pc; header requires only: OpenGL-devel, startup-notification-devel, damageproto, xextproto, libX11-devel)
72 Requires:       OpenGL-devel
73 Requires:       libpng-devel
74 Requires:       startup-notification-devel >= 0.7
75 Requires:       xorg-lib-libSM-devel
76 Requires:       xorg-lib-libXcomposite-devel
77 Requires:       xorg-lib-libXdamage-devel
78 Requires:       xorg-lib-libXrandr-devel
79
80 %description devel
81 Header files for compiz.
82
83 %description devel -l pl
84 Pliki nag³ówkowe dla compiza.
85
86 %package gnome-settings
87 Summary:        Compiz settings for gnome control panel
88 Summary(pl):    Ustawienia compiza dla panelu sterowania gnome
89 Group:          X11
90 Requires:       %{name} = %{version}-%{release}
91
92 %description gnome-settings
93 Compiz settings for gnome control panel.
94
95 %description gnome-settings -l pl
96 Ustawienia compiza dla panelu sterowania gnome.
97
98 %package gnome-decorator
99 Summary:        Window decorator for gnome
100 Summary(pl):    Dekorator okien dla gnome
101 Group:          X11
102 Requires:       %{name} = %{version}-%{release}
103
104 %description gnome-decorator
105 Window decorator for gnome.
106
107 %description gnome-decorator -l pl
108 Dekorator okien dla gnome.
109
110 %package kde-decorator
111 Summary:        Window decorator for KDE
112 Summary(pl):    Dekorator okien dla KDE
113 Group:          X11
114 Requires:       %{name} = %{version}-%{release}
115
116 %description kde-decorator
117 Window decorator for KDE.
118
119 %description kde-decorator -l pl
120 Dekorator okien dla KDE.
121
122 %prep
123 %setup -q -n %{name}-%{_snap}
124 %patch0 -p0
125
126 %build
127 autoreconf -v --install
128
129 %configure \
130         --disable-static \
131         --enable-svg \
132         --enable-libsvg-cairo \
133         %{!?with_gconf:--disable-gconf} \
134         --%{?with_gnome:en}%{!?with_gnome:dis}able-gnome \
135         --%{?with_kde:en}%{!?with_kde:dis}able-kde
136
137 %{__make}
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141
142 %{__make} install \
143         DESTDIR=$RPM_BUILD_ROOT
144
145 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/compiz/novell.png
146
147 rm -f $RPM_BUILD_ROOT%{_libdir}/compiz/*.la
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post
153 %gconf_schema_install compiz.schemas
154
155 %preun
156 %gconf_schema_uninstall compiz.schemas
157
158 %files
159 %defattr(644,root,root,755)
160 %doc AUTHORS ChangeLog README TODO
161 %attr(755,root,root) %{_bindir}/compiz
162 %dir %{_libdir}/compiz
163 %attr(755,root,root) %{_libdir}/compiz/*.so
164 %{_datadir}/compiz
165 %if %{with gnome}
166 %{_datadir}/gnome/wm-properties/*
167 %endif
168 %{_sysconfdir}/gconf/schemas/compiz.schemas
169
170 %files devel
171 %defattr(644,root,root,755)
172 %{_includedir}/compiz
173 %{_pkgconfigdir}/compiz.pc
174
175 %if %{with gnome}
176 %files gnome-settings
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_libdir}/window-manager-settings/*.so
179
180 %files gnome-decorator
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_bindir}/gnome-window-decorator
183 %endif
184
185 %if %{with kde}
186 %files kde-decorator
187 %defattr(644,root,root,755)
188 %attr(755,root,root) %{_bindir}/kde-window-decorator
189 %endif
This page took 0.10764 seconds and 4 git commands to generate.