]> git.pld-linux.org Git - packages/compiz.git/blob - compiz.spec
- kde builds (whether it works it's not so important :)
[packages/compiz.git] / compiz.spec
1 #
2 # Conditional build:
3 %bcond_without  gconf           # don't build gconf plugin
4 %bcond_without  gnome           # don't build gnome-window-decorator
5 %bcond_without  kde             # dont' build kde-window-decorator
6 #
7 %define         _snap   20060331
8 #
9 Summary:        OpenGL window and compositing manager
10 Summary(pl):    OpenGL-owy zarz±dca okien i sk³adania
11 Name:           compiz
12 Version:        0.0.7
13 Release:        1.%{_snap}.1
14 License:        GPL/MIT
15 Group:          X11
16 Source0:        %{name}-%{_snap}.tar.bz2
17 # Source0-md5:  b42d03bf0625cb32cd8f6f24a6028f2c
18 Patch0:         %{name}-switcher-all-desktops.patch
19 Patch1:         %{name}-minimize-scaler-mod.patch
20 %if %{with gconf} || %{with gnome}
21 BuildRequires:  GConf2-devel >= 2.0
22 %endif
23 BuildRequires:  OpenGL-devel
24 BuildRequires:  autoconf >= 2.57
25 BuildRequires:  automake
26 BuildRequires:  glib2-devel >= 2.0
27 BuildRequires:  libpng-devel
28 BuildRequires:  libsvg-cairo-devel
29 BuildRequires:  libtool
30 BuildRequires:  pkgconfig
31 BuildRequires:  startup-notification-devel >= 0.7
32 BuildRequires:  xorg-lib-libSM-devel
33 BuildRequires:  xorg-lib-libXcomposite-devel
34 BuildRequires:  xorg-lib-libXdamage-devel
35 BuildRequires:  xorg-lib-libXrandr-devel
36 %if %{with gnome}
37 BuildRequires:  control-center-devel >= 2.0
38 BuildRequires:  gnome-desktop-devel >= 2.0
39 BuildRequires:  gtk+2-devel >= 2:2.8.0
40 BuildRequires:  libwnck-devel >= 2.0
41 %endif
42 %if %{with kde}
43 BuildRequires:  QtCore-devel
44 BuildRequires:  QtGui-devel
45 BuildRequires:  qt4-build
46 %endif
47 Obsoletes:      compiz-opacity
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 Compiz is an OpenGL compositing manager that use
52 GLX_EXT_texture_from_pixmap for binding redirected top-level
53 windows to texture objects. It has a flexible plug-in system
54 and it is designed to run well on most graphics hardware.
55
56 %description -l pl
57 Compiz jest OpenGL-owym zarz±dc± sk³adania, u¿ywaj±cym rozszerzenia
58 GLX_EXT_texture_from_pixmap w celu wi±zania przekierowanych okien
59 do tekstur. Posiada elastyczny system wtyczek i jest tak
60 zaprojektowany, by dobrze dzia³aæ na wiêkszo¶ci kart graficznych.
61
62 %package devel
63 Summary:        Header files for compiz
64 Summary(pl):    Pliki nag³ówkowe dla compiza
65 Group:          Development
66 # (by compiz.pc; header requires only: OpenGL-devel, startup-notification-devel, damageproto, xextproto, libX11-devel)
67 Requires:       OpenGL-devel
68 Requires:       libpng-devel
69 Requires:       startup-notification-devel >= 0.7
70 Requires:       xorg-lib-libSM-devel
71 Requires:       xorg-lib-libXcomposite-devel
72 Requires:       xorg-lib-libXdamage-devel
73 Requires:       xorg-lib-libXrandr-devel
74
75 %description devel
76 Header files for compiz.
77
78 %description devel -l pl
79 Pliki nag³ówkowe dla compiza.
80
81 %package gnome-settings
82 Summary:        Compiz settings for gnome control panel
83 Summary(pl):    Ustawienia compiza dla panelu sterowania gnome
84 Group:          X11
85 Requires:       %{name} = %{version}-%{release}
86
87 %description gnome-settings
88 Compiz settings for gnome control panel.
89
90 %description gnome-settings -l pl
91 Ustawienia compiza dla panelu sterowania gnome.
92
93 %package gnome-decorator
94 Summary:        Window decorator for gnome
95 Summary(pl):    Dekorator okien dla gnome
96 Group:          X11
97 Requires:       %{name} = %{version}-%{release}
98
99 %description gnome-decorator
100 Window decorator for gnome.
101
102 %description gnome-decorator -l pl
103 Dekorator okien dla gnome.
104
105 %package kde-decorator
106 Summary:        Window decorator for KDE
107 Summary(pl):    Dekorator okien dla KDE
108 Group:          X11
109 Requires:       %{name} = %{version}-%{release}
110
111 %description kde-decorator
112 Window decorator for KDE.
113
114 %description kde-decorator -l pl
115 Dekorator okien dla KDE.
116
117 %prep
118 %setup -q -n %{name}-%{_snap}
119 %patch0 -p1
120 %patch1 -p0
121
122 %build
123 autoreconf -v --install
124
125 %configure \
126         --disable-static \
127         --enable-svg \
128         --enable-libsvg-cairo \
129         %{!?with_gconf:--disable-gconf} \
130         --%{?with_gnome:en}%{!?with_gnome:dis}able-gnome \
131         --%{?with_kde:en}%{!?with_kde:dis}able-kde
132
133 %{__make}
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137
138 %{__make} install \
139         DESTDIR=$RPM_BUILD_ROOT
140
141 rm -f $RPM_BUILD_ROOT%{_libdir}/compiz/*.la
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %files
147 %defattr(644,root,root,755)
148 %doc AUTHORS ChangeLog README TODO
149 %attr(755,root,root) %{_bindir}/compiz
150 %dir %{_libdir}/compiz
151 %attr(755,root,root) %{_libdir}/compiz/*.so
152 %{_datadir}/compiz
153 %if %{with gnome}
154 %{_datadir}/gnome/wm-properties/*
155 %endif
156
157 %files devel
158 %defattr(644,root,root,755)
159 %{_includedir}/compiz
160 %{_pkgconfigdir}/compiz.pc
161
162 %if %{with gnome}
163 %files gnome-settings
164 %defattr(644,root,root,755)
165 %attr(755,root,root) %{_libdir}/window-manager-settings/*.so
166
167 %files gnome-decorator
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_bindir}/gnome-window-decorator
170 %endif
171
172 %if %{with kde}
173 %files kde-decorator
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{_bindir}/kde-window-decorator
176 %endif
This page took 0.469372 seconds and 4 git commands to generate.