]> git.pld-linux.org Git - packages/compiz.git/blob - compiz.spec
- version bumped
[packages/compiz.git] / compiz.spec
1 #
2 # Conditional build:
3 %bcond_without  gconf           # don't build gconf plugin
4 %bcond_without  gnome           # don't build gnome-window-decorator
5 %bcond_with     kde             # build kde-window-decorator (not working)
6 #
7 %define         _snap   20060404
8 #
9 Summary:        OpenGL window and compositing manager
10 Summary(pl):    OpenGL-owy zarz±dca okien i sk³adania
11 Name:           compiz
12 Version:        0.0.8
13 Release:        1.%{_snap}.1
14 License:        GPL/MIT
15 Group:          X11
16 Source0:        %{name}-%{_snap}.tar.bz2
17 # Source0-md5:  5fc65a91a09ec3ba6d10270a949bbeaf
18 Patch0:         %{name}-minimize-scaler-mod.patch
19 %if %{with gconf} || %{with gnome}
20 BuildRequires:  GConf2-devel >= 2.0
21 %endif
22 BuildRequires:  OpenGL-devel
23 BuildRequires:  autoconf >= 2.57
24 BuildRequires:  automake
25 BuildRequires:  glib2-devel >= 2.0
26 BuildRequires:  libpng-devel
27 BuildRequires:  libsvg-cairo-devel
28 BuildRequires:  libtool
29 BuildRequires:  pkgconfig
30 BuildRequires:  startup-notification-devel >= 0.7
31 BuildRequires:  xorg-lib-libSM-devel
32 BuildRequires:  xorg-lib-libXcomposite-devel
33 BuildRequires:  xorg-lib-libXdamage-devel
34 BuildRequires:  xorg-lib-libXrandr-devel
35 %if %{with gnome}
36 BuildRequires:  control-center-devel >= 2.0
37 BuildRequires:  gnome-desktop-devel >= 2.0
38 BuildRequires:  gtk+2-devel >= 2:2.8.0
39 BuildRequires:  libwnck-devel >= 2.0
40 %endif
41 %if %{with kde}
42 BuildRequires:  QtCore-devel
43 BuildRequires:  QtGui-devel
44 BuildRequires:  qt4-build
45 %endif
46 Obsoletes:      compiz-opacity
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 Compiz is an OpenGL compositing manager that use
51 GLX_EXT_texture_from_pixmap for binding redirected top-level
52 windows to texture objects. It has a flexible plug-in system
53 and it is designed to run well on most graphics hardware.
54
55 %description -l pl
56 Compiz jest OpenGL-owym zarz±dc± sk³adania, u¿ywaj±cym rozszerzenia
57 GLX_EXT_texture_from_pixmap w celu wi±zania przekierowanych okien
58 do tekstur. Posiada elastyczny system wtyczek i jest tak
59 zaprojektowany, by dobrze dzia³aæ na wiêkszo¶ci kart graficznych.
60
61 %package devel
62 Summary:        Header files for compiz
63 Summary(pl):    Pliki nag³ówkowe dla compiza
64 Group:          Development
65 # (by compiz.pc; header requires only: OpenGL-devel, startup-notification-devel, damageproto, xextproto, libX11-devel)
66 Requires:       OpenGL-devel
67 Requires:       libpng-devel
68 Requires:       startup-notification-devel >= 0.7
69 Requires:       xorg-lib-libSM-devel
70 Requires:       xorg-lib-libXcomposite-devel
71 Requires:       xorg-lib-libXdamage-devel
72 Requires:       xorg-lib-libXrandr-devel
73
74 %description devel
75 Header files for compiz.
76
77 %description devel -l pl
78 Pliki nag³ówkowe dla compiza.
79
80 %package gnome-settings
81 Summary:        Compiz settings for gnome control panel
82 Summary(pl):    Ustawienia compiza dla panelu sterowania gnome
83 Group:          X11
84 Requires:       %{name} = %{version}-%{release}
85
86 %description gnome-settings
87 Compiz settings for gnome control panel.
88
89 %description gnome-settings -l pl
90 Ustawienia compiza dla panelu sterowania gnome.
91
92 %package gnome-decorator
93 Summary:        Window decorator for gnome
94 Summary(pl):    Dekorator okien dla gnome
95 Group:          X11
96 Requires:       %{name} = %{version}-%{release}
97
98 %description gnome-decorator
99 Window decorator for gnome.
100
101 %description gnome-decorator -l pl
102 Dekorator okien dla gnome.
103
104 %package kde-decorator
105 Summary:        Window decorator for KDE
106 Summary(pl):    Dekorator okien dla KDE
107 Group:          X11
108 Requires:       %{name} = %{version}-%{release}
109
110 %description kde-decorator
111 Window decorator for KDE.
112
113 %description kde-decorator -l pl
114 Dekorator okien dla KDE.
115
116 %prep
117 %setup -q -n %{name}-%{_snap}
118 %patch0 -p0
119
120 %build
121 autoreconf -v --install
122
123 %configure \
124         --disable-static \
125         --enable-svg \
126         --enable-libsvg-cairo \
127         %{!?with_gconf:--disable-gconf} \
128         --%{?with_gnome:en}%{!?with_gnome:dis}able-gnome \
129         --%{?with_kde:en}%{!?with_kde:dis}able-kde
130
131 %{__make}
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135
136 %{__make} install \
137         DESTDIR=$RPM_BUILD_ROOT
138
139 rm -f $RPM_BUILD_ROOT%{_libdir}/compiz/*.la
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %files
145 %defattr(644,root,root,755)
146 %doc AUTHORS ChangeLog README TODO
147 %attr(755,root,root) %{_bindir}/compiz
148 %dir %{_libdir}/compiz
149 %attr(755,root,root) %{_libdir}/compiz/*.so
150 %{_datadir}/compiz
151 %if %{with gnome}
152 %{_datadir}/gnome/wm-properties/*
153 %endif
154
155 %files devel
156 %defattr(644,root,root,755)
157 %{_includedir}/compiz
158 %{_pkgconfigdir}/compiz.pc
159
160 %if %{with gnome}
161 %files gnome-settings
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_libdir}/window-manager-settings/*.so
164
165 %files gnome-decorator
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_bindir}/gnome-window-decorator
168 %endif
169
170 %if %{with kde}
171 %files kde-decorator
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{_bindir}/kde-window-decorator
174 %endif
This page took 0.041997 seconds and 4 git commands to generate.