]> git.pld-linux.org Git - packages/compiz.git/blob - compiz.spec
f8a859f4f4f9675ab1ad31dbc8fa4a4f254c5d43
[packages/compiz.git] / compiz.spec
1 #
2 # Conditional build:
3 %bcond_without  gconf           # don't build gconf plugin
4 %bcond_without  gnome           # don't build gnome-window-decorator
5 %bcond_with     kde             # build kde-window-decorator (currently not working)
6 #
7 Summary:        OpenGL window and compositing manager
8 Summary(pl):    OpenGL-owy zarz±dca okien i sk³adania
9 Name:           compiz
10 Version:        0.0.7
11 Release:        1
12 License:        GPL/MIT
13 Group:          X11
14 %define         _snap   20060329
15 Source0:        %{name}-%{_snap}.tar.bz2
16 # Source0-md5:  568564b3fc4ee9583df3631c1dca8e28
17 Patch0:         %{name}-switcher-all-desktops.patch
18 %if %{with gconf} || %{with gnome}
19 BuildRequires:  GConf2-devel >= 2.0
20 %endif
21 BuildRequires:  OpenGL-devel
22 BuildRequires:  autoconf >= 2.57
23 BuildRequires:  automake
24 BuildRequires:  glib2-devel >= 2.0
25 BuildRequires:  libpng-devel
26 BuildRequires:  libsvg-cairo-devel
27 BuildRequires:  libtool
28 BuildRequires:  pkgconfig
29 BuildRequires:  startup-notification-devel >= 0.7
30 BuildRequires:  xorg-lib-libSM-devel
31 BuildRequires:  xorg-lib-libXcomposite-devel
32 BuildRequires:  xorg-lib-libXdamage-devel
33 BuildRequires:  xorg-lib-libXrandr-devel
34 %if %{with gnome}
35 BuildRequires:  control-center-devel >= 2.0
36 BuildRequires:  gnome-desktop-devel >= 2.0
37 BuildRequires:  gtk+2-devel >= 2:2.8.0
38 BuildRequires:  libwnck-devel >= 2.0
39 %endif
40 %if %{with kde}
41 BuildRequires:  QtCore-devel
42 BuildRequires:  QtGui-devel
43 BuildRequires:  qt4-build
44 %endif
45 Obsoletes:      compiz-opacity
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 Compiz is an OpenGL compositing manager that use
50 GLX_EXT_texture_from_pixmap for binding redirected top-level
51 windows to texture objects. It has a flexible plug-in system
52 and it is designed to run well on most graphics hardware.
53
54 %description -l pl
55 Compiz jest OpenGL-owym zarz±dc± sk³adania, u¿ywaj±cym rozszerzenia
56 GLX_EXT_texture_from_pixmap w celu wi±zania przekierowanych okien
57 do tekstur. Posiada elastyczny system wtyczek i jest tak
58 zaprojektowany, by dobrze dzia³aæ na wiêkszo¶ci kart graficznych.
59
60 %package devel
61 Summary:        Header files for compiz
62 Summary(pl):    Pliki nag³ówkowe dla compiza
63 Group:          Development
64 # (by compiz.pc; header requires only: OpenGL-devel, startup-notification-devel, damageproto, xextproto, libX11-devel)
65 Requires:       OpenGL-devel
66 Requires:       libpng-devel
67 Requires:       startup-notification-devel >= 0.7
68 Requires:       xorg-lib-libSM-devel
69 Requires:       xorg-lib-libXcomposite-devel
70 Requires:       xorg-lib-libXdamage-devel
71 Requires:       xorg-lib-libXrandr-devel
72
73 %description devel
74 Header files for compiz.
75
76 %description devel -l pl
77 Pliki nag³ówkowe dla compiza.
78
79 %package gnome-settings
80 Summary:        Compiz settings for gnome control panel
81 Summary(pl):    Ustawienia compiza dla panelu sterowania gnome
82 Group:          X11
83 Requires:       %{name} = %{version}-%{release}
84
85 %description gnome-settings
86 Compiz settings for gnome control panel.
87
88 %description gnome-settings -l pl
89 Ustawienia compiza dla panelu sterowania gnome.
90
91 %package gnome-decorator
92 Summary:        Window decorator for gnome
93 Summary(pl):    Dekorator okien dla gnome
94 Group:          X11
95 Requires:       %{name} = %{version}-%{release}
96
97 %description gnome-decorator
98 Window decorator for gnome.
99
100 %description gnome-decorator -l pl
101 Dekorator okien dla gnome.
102
103 %package kde-decorator
104 Summary:        Window decorator for KDE
105 Summary(pl):    Dekorator okien dla KDE
106 Group:          X11
107 Requires:       %{name} = %{version}-%{release}
108
109 %description kde-decorator
110 Window decorator for KDE.
111
112 %description kde-decorator -l pl
113 Dekorator okien dla KDE.
114
115 %prep
116 %setup -q -n %{name}-%{_snap}
117 %patch0 -p1
118
119 %build
120 autoreconf -v --install
121
122 %configure \
123         --disable-static \
124         --enable-svg \
125         --enable-libsvg-cairo \
126         %{!?with_gconf:--disable-gconf} \
127         --%{?with_gnome:en}%{!?with_gnome:dis}able-gnome \
128         --%{?with_kde:en}%{!?with_kde:dis}able-kde
129
130 %{__make}
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134
135 %{__make} install \
136         DESTDIR=$RPM_BUILD_ROOT
137
138 rm -f $RPM_BUILD_ROOT%{_libdir}/compiz/*.la
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %files
144 %defattr(644,root,root,755)
145 %doc AUTHORS ChangeLog README TODO
146 %attr(755,root,root) %{_bindir}/compiz
147 %dir %{_libdir}/compiz
148 %attr(755,root,root) %{_libdir}/compiz/*.so
149 %{_datadir}/compiz
150 %if %{with gnome}
151 %{_datadir}/gnome/wm-properties/*
152 %endif
153
154 %files devel
155 %defattr(644,root,root,755)
156 %{_includedir}/compiz
157 %{_pkgconfigdir}/compiz.pc
158
159 %if %{with gnome}
160 %files gnome-settings
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_libdir}/window-manager-settings/*.so
163
164 %files gnome-decorator
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_bindir}/gnome-window-decorator
167 %endif
168
169 %if %{with kde}
170 %files kde-decorator
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_bindir}/kde-window-decorator
173 %endif
This page took 0.053978 seconds and 2 git commands to generate.