]> git.pld-linux.org Git - packages/compiz.git/blob - compiz.spec
- updated gettext BR
[packages/compiz.git] / compiz.spec
1 #
2 # Conditional build:
3 %bcond_without  gconf           # gconf plugin
4 %bcond_without  gtk             # gtk window decorator
5 %bcond_with     gnome           # gnome settings module
6 %bcond_without  metacity        # metacity theme support
7 %bcond_with     kde             # kde-window-decorator and kconfig
8 %bcond_without  kde4            # kde4-window-decorator
9
10 Summary:        OpenGL window and compositing manager
11 Summary(pl.UTF-8):      OpenGL-owy zarządca okien i składania
12 Name:           compiz
13 # note that even versions are STABLE
14 Version:        0.8.6
15 Release:        3
16 License:        GPL or MIT
17 Group:          X11/Applications
18 Source0:        http://releases.compiz.org/%{version}/%{name}-%{version}.tar.bz2
19 # Source0-md5:  1e284eade99ff310551d5919b6ba57c1
20 Source1:        %{name}-gtk
21 Source2:        %{name}-gtk.desktop
22 Patch0:         %{name}-kde4.patch
23 Patch1:         %{name}-no-gdk_display.patch
24 URL:            http://www.compiz.org/
25 %if %{with gconf} || %{with gtk}
26 BuildRequires:  GConf2-devel >= 2.0
27 %endif
28 BuildRequires:  OpenGL-GLU-devel
29 BuildRequires:  OpenGL-devel >= 2.1
30 BuildRequires:  autoconf >= 2.57
31 BuildRequires:  automake >= 1:1.7
32 BuildRequires:  cairo-devel >= 1.0
33 BuildRequires:  dbus-glib-devel
34 BuildRequires:  gettext-tools
35 BuildRequires:  glib2-devel >= 2.0
36 # <sys/inotify.h>
37 BuildRequires:  glibc-devel >= 6:2.4
38 BuildRequires:  intltool >= 0.23
39 BuildRequires:  libfuse-devel >= 2.2
40 BuildRequires:  libpng-devel
41 BuildRequires:  librsvg-devel >= 1:2.14.0
42 BuildRequires:  libtool
43 BuildRequires:  libxcb-devel
44 BuildRequires:  libxml2-devel
45 BuildRequires:  libxslt-devel
46 BuildRequires:  libxslt-progs
47 BuildRequires:  pkgconfig
48 BuildRequires:  startup-notification-devel >= 0.7
49 BuildRequires:  xorg-lib-libSM-devel
50 BuildRequires:  xorg-lib-libXcomposite-devel
51 BuildRequires:  xorg-lib-libXdamage-devel
52 BuildRequires:  xorg-lib-libXinerama-devel
53 BuildRequires:  xorg-lib-libXrandr-devel
54 BuildRequires:  xorg-lib-libXrender-devel >= 0.9.3
55 BuildRequires:  xorg-lib-libXres-devel
56 %if %{with gtk}
57 BuildRequires:  gtk+2-devel >= 2:2.8.0
58 BuildRequires:  libwnck-devel >= 2.20.0
59 %if %{with gnome}
60 BuildRequires:  gnome-control-center-devel >= 2.0
61 BuildRequires:  gnome-desktop-devel >= 2.0
62 BuildRequires:  gnome-menus-devel
63 %endif
64 %if %{with metacity}
65 BuildRequires:  metacity-devel >= 2.24.0
66 %endif
67 %endif
68 %if %{with kde}
69 BuildRequires:  dbus-qt-devel
70 BuildRequires:  kdebase-devel
71 BuildRequires:  kdelibs-devel
72 BuildRequires:  qt-devel >= 1:3.0
73 %endif
74 %if %{with kde4}
75 BuildRequires:  kde4-kdebase-workspace-devel
76 BuildRequires:  kde4-kdelibs-devel
77 BuildRequires:  qt4-build
78 %endif
79 Requires:       %{name}-libs = %{version}-%{release}
80 Obsoletes:      compiz-opacity
81 Conflicts:      filesystem < 3.0-20
82 Conflicts:      xorg-xserver-xgl < 0.0.20060505
83 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85 # for gconf subpackage
86 %define plugins annotate blur clone core cube dbus decoration fade fs gconf glib gnomecompat ini inotify minimize move obs place png regex resize rotate scale screenshot svg switcher video water wobbly zoom
87
88 %description
89 Compiz is a compositing window manager that uses 3D graphics
90 acceleration via OpenGL. It provides various new graphical effects and
91 features on any desktop environment, including Gnome and KDE.
92
93 %description -l pl.UTF-8
94 Compiz jest menedżerem okien obsługującym składanie, który używa
95 akceleracji grafiki 3D przez OpenGL-a. Umożliwia on uzyskanie nowych
96 efektów graficznych i możliwości w dowolnym środowisku, nie wyłączając
97 Gnome i KDE.
98
99 %package libs
100 Summary:        Compiz libraries
101 Summary(pl.UTF-8):      Biblioteki compiza
102 Group:          X11/Applications
103 Obsoletes:      beryl-core
104 Conflicts:      compiz < 0.5.2-2
105
106 %description libs
107 Compiz libraries.
108
109 %description libs -l pl.UTF-8
110 Biblioteki Compiza.
111
112 %package devel
113 Summary:        Header files for compiz
114 Summary(pl.UTF-8):      Pliki nagłówkowe dla compiza
115 Group:          X11/Development/Libraries
116 Requires:       %{name}-libs = %{version}-%{release}
117 # (by compiz.pc; header requires only: OpenGL-devel, startup-notification-devel, damageproto, xextproto, libX11-devel)
118 Requires:       OpenGL-devel
119 Requires:       libpng-devel
120 Requires:       libxslt-devel
121 Requires:       startup-notification-devel >= 0.7
122 Requires:       xorg-lib-libSM-devel
123 Requires:       xorg-lib-libXcomposite-devel
124 Requires:       xorg-lib-libXdamage-devel
125 Requires:       xorg-lib-libXinerama-devel
126 Requires:       xorg-lib-libXrandr-devel
127 Obsoletes:      beryl-core-devel
128
129 %description devel
130 Header files for compiz.
131
132 %description devel -l pl.UTF-8
133 Pliki nagłówkowe dla compiza.
134
135 %package fuse
136 Summary:        FUSE plugin for Compiz
137 Summary(pl.UTF-8):      Wtyczka FUSE dla Compiza
138 Group:          X11/Applications
139 Requires:       %{name} = %{version}-%{release}
140
141 %description fuse
142 FUSE plugin for Compiz (userspace file system).
143
144 %description fuse -l pl.UTF-8
145 Wtyczka FUSE dla Compiza (system plików w przestrzeni użytkownika).
146
147 %package gconf
148 Summary:        GConf plugin for Compiz
149 Summary(pl.UTF-8):      Wtyczka GConf dla Compiza
150 Group:          X11/Applications
151 Requires(post,preun):   GConf2
152 Requires:       %{name} = %{version}-%{release}
153 Obsoletes:      beryl-core-gconf
154
155 %description gconf
156 GConf plugin for Compiz (GConf control backend).
157
158 %description gconf -l pl.UTF-8
159 Wtyczka GConf dla Compiza (backend sterujący oparty na GConfie).
160
161 %package kconfig
162 Summary:        kconfig plugin for Compiz
163 Summary(pl.UTF-8):      Wtyczka kconfig dla Compiza
164 Group:          X11/Applications
165 Requires:       %{name} = %{version}-%{release}
166
167 %description kconfig
168 kconfig plugin for Compiz (KDE control backend).
169
170 %description kconfig -l pl.UTF-8
171 Wtyczka kconfig dla Compiza (backend sterujący oparty na KDE).
172
173 %package svg
174 Summary:        SVG plugin for Compiz
175 Summary(pl.UTF-8):      Wtyczka SVG dla Compiza
176 Group:          X11/Applications
177 Requires:       %{name} = %{version}-%{release}
178
179 %description svg
180 SVG image loader plugin for Compiz.
181
182 %description svg -l pl.UTF-8
183 Wtyczka wczytująca obrazy SVG dla Compiza.
184
185 %package gnome-settings
186 Summary:        Compiz settings for GNOME control panel
187 Summary(pl.UTF-8):      Ustawienia compiza dla panelu sterowania GNOME
188 Group:          X11/Applications
189 Requires:       %{name} = %{version}-%{release}
190
191 %description gnome-settings
192 Compiz settings for GNOME control panel.
193
194 %description gnome-settings -l pl.UTF-8
195 Ustawienia compiza dla panelu sterowania GNOME.
196
197 %package gtk-decorator
198 Summary:        Window decorator for GTK+
199 Summary(pl.UTF-8):      Dekorator okien dla GTK+
200 Group:          X11/Applications
201 %if %{with gconf}
202 Requires(post,preun):   GConf2
203 %endif
204 Requires:       %{name} = %{version}-%{release}
205 Obsoletes:      compiz-gnome-decorator
206 Obsoletes:      heliodor
207
208 %description gtk-decorator
209 Window decorator for GTK+.
210
211 %description gtk-decorator -l pl.UTF-8
212 Dekorator okien dla GTK+.
213
214 %package kde-decorator
215 Summary:        Window decorator for KDE
216 Summary(pl.UTF-8):      Dekorator okien dla KDE
217 Group:          X11/Applications
218 Requires:       %{name} = %{version}-%{release}
219 Obsoletes:      aquamarine
220
221 %description kde-decorator
222 Window decorator for KDE.
223
224 %description kde-decorator -l pl.UTF-8
225 Dekorator okien dla KDE.
226
227 %package kde4-decorator
228 Summary:        Window decorator for KDE 4
229 Summary(pl.UTF-8):      Dekorator okien dla KDE 4
230 Group:          X11/Applications
231 Requires:       %{name} = %{version}-%{release}
232 Obsoletes:      aquamarine
233
234 %description kde4-decorator
235 Window decorator for KDE 4.
236
237 %description kde4-decorator -l pl.UTF-8
238 Dekorator okien dla KDE 4.
239
240 %prep
241 %setup -q
242 %patch0 -p0
243 %patch1 -p1
244
245 %build
246 %{__intltoolize}
247 %{__libtoolize}
248 %{__aclocal}
249 %{__autoconf}
250 %{__autoheader}
251 %{__automake}
252 export QTLIB=%{_libdir}
253 export QTDIR=%{_prefix}
254 %configure \
255         --disable-static \
256         --enable-librsvg \
257         %{!?with_gconf:--disable-gconf} \
258         %{!?with_gnome:--disable-gnome} \
259         %{!?with_gtk:--disable-gtk} \
260         %{!?with_kde:--disable-kde} \
261         %{!?with_kde4:--disable-kde4} \
262         %{!?with_metacity:--disable-metacity}
263
264 %{__make}
265
266 %install
267 rm -rf $RPM_BUILD_ROOT
268
269 %{__make} install \
270         DESTDIR=$RPM_BUILD_ROOT
271
272 rm -f $RPM_BUILD_ROOT%{_libdir}/compiz/*.la
273 %if %{with gnome}
274 rm -f $RPM_BUILD_ROOT%{_libdir}/window-manager-settings/*.la
275 %endif
276
277 %if %{with gtk}
278 install %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
279 desktop-file-install \
280         --vendor="" \
281         --dir $RPM_BUILD_ROOT%{_desktopdir} \
282         %{SOURCE2}
283 %endif
284
285 %find_lang %{name}
286
287 %clean
288 rm -rf $RPM_BUILD_ROOT
289
290 %post   libs -p /sbin/ldconfig
291 %postun libs -p /sbin/ldconfig
292
293 %post gconf
294 for p in %{plugins}; do
295         %gconf_schema_install compiz-$p.schemas
296 done
297
298 %preun gconf
299 for p in %{plugins}; do
300         %gconf_schema_uninstall compiz-$p.schemas
301 done
302
303 %if %{with gconf}
304 %post gtk-decorator
305 %gconf_schema_install gwd.schemas
306
307 %preun gtk-decorator
308 %gconf_schema_uninstall gwd.schemas
309 %endif
310
311 %files -f %{name}.lang
312 %defattr(644,root,root,755)
313 %doc AUTHORS COPYING COPYING.MIT ChangeLog NEWS README TODO
314 %attr(755,root,root) %{_bindir}/compiz
315 %attr(755,root,root) %{_libdir}/compiz/*.so
316 %exclude %{_libdir}/compiz/libfs.so
317 %{?with_kde:%exclude %{_libdir}/compiz/libkconfig.so}
318 %{?with_gconf:%exclude %{_libdir}/compiz/libgconf.so}
319 %exclude %{_libdir}/compiz/libsvg.so
320 %{_datadir}/compiz/*.xml
321 %{_datadir}/compiz/*.png
322 %exclude %{_datadir}/compiz/fs.xml
323 %exclude %{_datadir}/compiz/gconf.xml
324 %exclude %{_datadir}/compiz/svg.xml
325
326 %files libs
327 %defattr(644,root,root,755)
328 %attr(755,root,root) %{_libdir}/libdecoration.so.*.*.*
329 %attr(755,root,root) %ghost %{_libdir}/libdecoration.so.0
330 %dir %{_libdir}/compiz
331 %dir %{_datadir}/compiz
332
333 %files devel
334 %defattr(644,root,root,755)
335 %attr(755,root,root) %{_libdir}/libdecoration.so
336 %{_libdir}/libdecoration.la
337 %{_includedir}/compiz
338 %{_pkgconfigdir}/compiz.pc
339 %{_pkgconfigdir}/libdecoration.pc
340 %{?with_kde:%{_pkgconfigdir}/compiz-kconfig.pc}
341 # checked by compiz-fusion-plugins-extra
342 %{_pkgconfigdir}/compiz-cube.pc
343 # checked by compiz-fusion-plugins-main
344 %{_pkgconfigdir}/compiz-scale.pc
345
346 %files fuse
347 %defattr(644,root,root,755)
348 %attr(755,root,root) %{_libdir}/compiz/libfs.so
349 %{_datadir}/compiz/fs.xml
350
351 %if %{with gconf}
352 %files gconf
353 %defattr(644,root,root,755)
354 %attr(755,root,root) %{_libdir}/compiz/libgconf.so
355 %{_sysconfdir}/gconf/schemas/compiz-*.schemas
356 %{_datadir}/compiz/gconf.xml
357 %{_datadir}/compiz/schemas.xslt
358 # checked by compiz-fusion-plugins-* (with non-default --enable-schemas only)
359 %{_pkgconfigdir}/compiz-gconf.pc
360 %endif
361
362 %if %{with kde}
363 %files kconfig
364 %defattr(644,root,root,755)
365 %attr(755,root,root) %{_libdir}/compiz/libkconfig.so
366 %{_datadir}/config/compizrc
367 %{_datadir}/config.kcfg/*.kcfg
368 %{_datadir}/compiz/kcfg.xslt
369 %{_datadir}/compiz/kconfig.xslt
370 %endif
371
372 %files svg
373 %defattr(644,root,root,755)
374 %attr(755,root,root) %{_libdir}/compiz/libsvg.so
375 %{_datadir}/compiz/gconf.xml
376
377 %if %{with gnome} && %{with gtk}
378 %files gnome-settings
379 %defattr(644,root,root,755)
380 %attr(755,root,root) %{_libdir}/window-manager-settings/libcompiz.so
381 %{_datadir}/gnome-control-center/keybindings/50-compiz-desktop-key.xml
382 %{_datadir}/gnome-control-center/keybindings/50-compiz-key.xml
383 %{_datadir}/gnome/wm-properties/compiz-wm.desktop
384 %{_desktopdir}/compiz.desktop
385 %endif
386
387 %if %{with gtk}
388 %files gtk-decorator
389 %defattr(644,root,root,755)
390 %attr(755,root,root) %{_bindir}/compiz-gtk
391 %attr(755,root,root) %{_bindir}/gtk-window-decorator
392 %{_desktopdir}/compiz-gtk.desktop
393 %if %{with gconf}
394 %{_sysconfdir}/gconf/schemas/gwd.schemas
395 %endif
396 %endif
397
398 %if %{with kde}
399 %files kde-decorator
400 %defattr(644,root,root,755)
401 %attr(755,root,root) %{_bindir}/kde-window-decorator
402 %endif
403
404 %if %{with kde4}
405 %files kde4-decorator
406 %defattr(644,root,root,755)
407 %attr(755,root,root) %{_bindir}/kde4-window-decorator
408 %endif
This page took 0.099931 seconds and 3 git commands to generate.